Update vserver patch to 2.0.2-rc21.

* debian/changelog: Update.
* debian/patches/series/15-extra: Add vserver-vs2.0.2-rc21-update.patch.
* debian/patches/vserver-vs2.0.2-rc21-update.patch: Add.

svn path=/dists/sid/linux-2.6/; revision=6710
This commit is contained in:
Bastian Blank 2006-05-26 13:00:27 +00:00
parent 6f1a7645c4
commit 04f444e177
3 changed files with 29 additions and 1 deletions

5
debian/changelog vendored
View File

@ -28,7 +28,10 @@ linux-2.6 (2.6.16-15) UNRELEASED; urgency=low
of the -powerpc one.
* Upgraded mkvmlinuz dependency to mkvmlinuz 21.
-- Sven Luther <luther@debian.org> Fri, 26 May 2006 10:42:10 +0200
[ Bastian Blank ]
* Update vserver patch to 2.0.2-rc21.
-- Bastian Blank <waldi@debian.org> Fri, 26 May 2006 14:59:27 +0200
linux-2.6 (2.6.16-14) unstable; urgency=low

View File

@ -4,3 +4,4 @@
+ mips-dec-scsi.patch mipsel
+ mips-dec-rtc.patch mipsel
+ hppa-rw-can-lock.patch hppa
+ vserver-vs2.0.2-rc21-update.patch *_vserver *_xen-vserver

View File

@ -0,0 +1,24 @@
diff -u linux-2.6.16.16-vs2.0.2-rc20/include/net/route.h linux-2.6.16.17-vs2.0.2-rc21/include/net/route.h
--- linux-2.6.16.16-vs2.0.2-rc20/include/net/route.h 2006-05-11 18:47:46 +0200
+++ linux-2.6.16.17-vs2.0.2-rc21/include/net/route.h 2006-05-11 18:47:46 +0200
@@ -229,7 +229,7 @@
return err;
if (fl.fl4_dst == IPI_LOOPBACK && !vx_check(0, VX_ADMIN))
fl.fl4_dst = nx_info->ipv4[0];
-#ifdef VSERVER_REMAP_SADDR
+#ifdef ONFIG_VSERVER_REMAP_SADDR
if (fl.fl4_src == IPI_LOOPBACK && !vx_check(0, VX_ADMIN))
fl.fl4_src = nx_info->ipv4[0];
#endif
diff -u linux-2.6.16.16-vs2.0.2-rc20/net/ipv4/udp.c linux-2.6.16.17-vs2.0.2-rc21/net/ipv4/udp.c
--- linux-2.6.16.16-vs2.0.2-rc20/net/ipv4/udp.c 2006-05-11 18:49:21 +0200
+++ linux-2.6.16.17-vs2.0.2-rc21/net/ipv4/udp.c 2006-05-11 18:49:21 +0200
@@ -617,7 +617,7 @@
goto out;
if (daddr == IPI_LOOPBACK && !vx_check(0, VX_ADMIN))
daddr = fl.fl4_dst = nxi->ipv4[0];
-#ifdef VSERVER_REMAP_SADDR
+#ifdef CONFIG_VSERVER_REMAP_SADDR
if (saddr == IPI_LOOPBACK && !vx_check(0, VX_ADMIN))
saddr = fl.fl4_src = nxi->ipv4[0];
#endif