IP22 fixes

svn path=/dists/sid/linux-2.6.16/; revision=6999
This commit is contained in:
Martin Michlmayr 2006-07-14 09:18:27 +00:00
parent 41d7e01277
commit 08a9e7c255
3 changed files with 44 additions and 1 deletions

4
debian/changelog vendored
View File

@ -1,7 +1,9 @@
linux-2.6.16 (2.6.16-17) UNRELEASED; urgency=low
[ Martin Michlmayr ]
* [arm/nslu2] Unset CONFIG_USB_STORAGE_DEBUG.
* [arm/nslu2] Unset CONFIG_USB_STORAGE_DEBUG. Closes: #377853.
* [mips] SGI ip22 RTC was broken, fixed thanks to Julien Blache.
* [mips] Fix SGI ip22 serial console, thanks to Julien Blache.
-- Martin Michlmayr <tbm@cyrius.com> Fri, 14 Jul 2006 01:00:57 +0200

18
debian/patches/mips-ip22-rtcfix.patch vendored Normal file
View File

@ -0,0 +1,18 @@
# Upstream status: in 2.6.18-rc2
This patch fixes a typo in arch/mips/sgi-ip22/ip22-time.c, leading to
the incorrect year being set into the RTC chip.
Signed-off-by: Julien BLACHE <jb@jblache.org>
--- a/arch/mips/sgi-ip22/ip22-time.c 2006-07-08 22:17:02.000000000 +0000
+++ b/arch/mips/sgi-ip22/ip22-time.c 2006-07-08 22:17:29.000000000 +0000
@@ -76,7 +76,7 @@
save_control = hpc3c0->rtcregs[RTC_CMD] & 0xff;
hpc3c0->rtcregs[RTC_CMD] = save_control | RTC_TE;
- hpc3c0->rtcregs[RTC_YEAR] = BIN2BCD(tm.tm_sec);
+ hpc3c0->rtcregs[RTC_YEAR] = BIN2BCD(tm.tm_year);
hpc3c0->rtcregs[RTC_MONTH] = BIN2BCD(tm.tm_mon);
hpc3c0->rtcregs[RTC_DATE] = BIN2BCD(tm.tm_mday);
hpc3c0->rtcregs[RTC_HOURS] = BIN2BCD(tm.tm_hour);

View File

@ -0,0 +1,23 @@
# Upstream status: in 2.6.18-rc2
The patch below fixes serial console hangs as seen on IP22
machines. Typically, while booting, the machine hangs for ~1 minute
displaying "INIT: ", then the same thing happens again when init
enters in the designated runlevel and finally the getty process on
ttyS0 hangs indefinitely (though strace'ing it helps).
Signed-off-by: Julien BLACHE <jb@jblache.org>
--- source-mips-none/drivers/serial/ip22zilog.c 2006-06-18 03:49:35.000000000 +0200
+++ source/drivers/serial/ip22zilog.c 2006-07-09 14:25:11.847260358 +0200
@@ -1145,9 +1145,8 @@
up[(chip * 2) + 1].port.fifosize = 1;
up[(chip * 2) + 1].port.ops = &ip22zilog_pops;
up[(chip * 2) + 1].port.type = PORT_IP22ZILOG;
- up[(chip * 2) + 1].port.flags |= IP22ZILOG_FLAG_IS_CHANNEL_A;
up[(chip * 2) + 1].port.line = (chip * 2) + 1;
- up[(chip * 2) + 1].flags = 0;
+ up[(chip * 2) + 1].flags |= IP22ZILOG_FLAG_IS_CHANNEL_A;
}
}