Update to 3.13

Refresh/drop patches as appropriate.

svn path=/dists/trunk/linux-tools/; revision=20993
This commit is contained in:
Ben Hutchings 2014-01-21 05:53:15 +00:00
parent 4f97c4f1e9
commit 09bd3a69be
7 changed files with 73 additions and 110 deletions

3
debian/changelog vendored
View File

@ -1,5 +1,6 @@
linux-tools (3.12-1~exp2) UNRELEASED; urgency=low linux-tools (3.13-1~exp1) UNRELEASED; urgency=low
* New upstream release
* linux-tools: Replace build-dependency on binutils-dev with * linux-tools: Replace build-dependency on binutils-dev with
libiberty-dev (or old binutils-dev, for ease of backporting) libiberty-dev (or old binutils-dev, for ease of backporting)
(Closes: #730883) (Closes: #730883)

View File

@ -12,9 +12,9 @@ can simply omit it.]
--- a/scripts/mod/modpost.c --- a/scripts/mod/modpost.c
+++ b/scripts/mod/modpost.c +++ b/scripts/mod/modpost.c
@@ -18,7 +18,6 @@ @@ -19,7 +19,6 @@
#include <limits.h>
#include <stdbool.h> #include <stdbool.h>
#include <errno.h>
#include "modpost.h" #include "modpost.h"
-#include "../../include/generated/autoconf.h" -#include "../../include/generated/autoconf.h"
#include "../../include/linux/license.h" #include "../../include/linux/license.h"

View File

@ -1,46 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 18 Nov 2013 05:12:30 +0000
Subject: perf: Fix type errors in bench/numa.c
Forwarded: no
Fix the following errors on i386 and probably most other 32-bit
architectures:
bench/numa.c: In function 'worker_thread':
bench/numa.c:1113:20: error: comparison between signed and unsigned integer expressions [-Werror=sign-compare]
if (diff.tv_sec >= g->p.nr_secs) {
^
bench/numa.c:1161:6: error: format '%lx' expects argument of type 'long unsigned int', but argument 5 has type 'u64' [-Werror=format=]
process_nr, thread_nr, runtime_ns_max / bytes_done, val);
^
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/perf/bench/numa.c
+++ b/tools/perf/bench/numa.c
@@ -12,6 +12,7 @@
#include "bench.h"
#include <errno.h>
+#include <inttypes.h>
#include <sched.h>
#include <stdio.h>
#include <assert.h>
@@ -1110,7 +1111,7 @@ static void *worker_thread(void *__tdata
/* Check whether our max runtime timed out: */
if (g->p.nr_secs) {
timersub(&stop, &start0, &diff);
- if (diff.tv_sec >= g->p.nr_secs) {
+ if (diff.tv_sec >= (time_t)g->p.nr_secs) {
g->stop_work = true;
break;
}
@@ -1157,7 +1158,7 @@ static void *worker_thread(void *__tdata
runtime_ns_max += diff.tv_usec * 1000;
if (details >= 0) {
- printf(" #%2d / %2d: %14.2lf nsecs/op [val: %016lx]\n",
+ printf(" #%2d / %2d: %14.2lf nsecs/op [val: %016"PRIx64"]\n",
process_nr, thread_nr, runtime_ns_max / bytes_done, val);
}
fflush(stdout);

View File

@ -2,4 +2,3 @@ modpost-symbol-prefix.patch
tools-perf-version.patch tools-perf-version.patch
tools-perf-install.patch tools-perf-install.patch
usbip-document-tcp-wrappers.patch usbip-document-tcp-wrappers.patch
perf-fix-numa-types.patch

View File

@ -3,36 +3,42 @@ Date: Fri, 07 Oct 2011 21:37:52 +0100
Subject: Install perf scripts non-executable Subject: Install perf scripts non-executable
Forwarded: no Forwarded: no
--- a/tools/perf/Makefile [bwh: Forward-ported to 3.12]
+++ b/tools/perf/Makefile
@@ -775,23 +775,23 @@ install-bin: all --- a/tools/perf/Makefile.perf
+++ b/tools/perf/Makefile.perf
@@ -827,8 +827,8 @@ install-bin: all install-gtk
ifndef NO_LIBPERL ifndef NO_LIBPERL
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace' $(call QUIET_INSTALL, perl-scripts) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'; \
- $(INSTALL) scripts/perl/Perf-Trace-Util/lib/Perf/Trace/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace' - $(INSTALL) scripts/perl/Perf-Trace-Util/lib/Perf/Trace/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'; \
- $(INSTALL) scripts/perl/*.pl -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl' - $(INSTALL) scripts/perl/*.pl -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl'; \
+ $(INSTALL) -m 644 scripts/perl/Perf-Trace-Util/lib/Perf/Trace/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace' + $(INSTALL) -m 644 scripts/perl/Perf-Trace-Util/lib/Perf/Trace/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'; \
+ $(INSTALL) -m 644 scripts/perl/*.pl -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl' + $(INSTALL) -m 644 scripts/perl/*.pl -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl'; \
$(INSTALL) scripts/perl/bin/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'; \
$(INSTALL) scripts/perl/bin/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'
endif endif
ifndef NO_LIBPYTHON @@ -836,18 +836,18 @@ ifndef NO_LIBPYTHON
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/Perf-Trace-Util/lib/Perf/Trace' $(call QUIET_INSTALL, python-scripts) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/bin' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/Perf-Trace-Util/lib/Perf/Trace'; \
- $(INSTALL) scripts/python/Perf-Trace-Util/lib/Perf/Trace/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/Perf-Trace-Util/lib/Perf/Trace' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/bin'; \
- $(INSTALL) scripts/python/*.py -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python' - $(INSTALL) scripts/python/Perf-Trace-Util/lib/Perf/Trace/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/Perf-Trace-Util/lib/Perf/Trace'; \
+ $(INSTALL) -m 644 scripts/python/Perf-Trace-Util/lib/Perf/Trace/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/Perf-Trace-Util/lib/Perf/Trace' - $(INSTALL) scripts/python/*.py -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python'; \
+ $(INSTALL) -m 644 scripts/python/*.py -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python' + $(INSTALL) -m 644 scripts/python/Perf-Trace-Util/lib/Perf/Trace/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/Perf-Trace-Util/lib/Perf/Trace'; \
$(INSTALL) scripts/python/bin/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/bin' + $(INSTALL) -m 644 scripts/python/*.py -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python'; \
$(INSTALL) scripts/python/bin/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/bin'
endif endif
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d' $(call QUIET_INSTALL, bash_completion-script) \
- $(INSTALL) bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d'; \
+ $(INSTALL) -m 644 bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)' - $(INSTALL) bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests' + $(INSTALL) -m 644 bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)'
- $(INSTALL) tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests' $(call QUIET_INSTALL, tests) \
+ $(INSTALL) -m 644 tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'; \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr' - $(INSTALL) tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'; \
- $(INSTALL) tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr' + $(INSTALL) -m 644 tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'; \
+ $(INSTALL) -m 644 tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'; \
- $(INSTALL) tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
+ $(INSTALL) -m 644 tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
install: install-bin try-install-man install: install-bin try-install-man

View File

@ -5,29 +5,31 @@ Forwarded: no
[bwh: Fix version insertion in perf man page cross-references and perf [bwh: Fix version insertion in perf man page cross-references and perf
man page title. Install bash_completion script for perf with a man page title. Install bash_completion script for perf with a
version-dependent name.] version-dependent name. And do the same for trace.]
--- a/tools/perf/Makefile --- a/tools/perf/Makefile.perf
+++ b/tools/perf/Makefile +++ b/tools/perf/Makefile.perf
@@ -769,7 +769,7 @@ check: $(OUTPUT)common-cmds.h @@ -818,8 +818,8 @@ install-gtk:
install-bin: all install-gtk
install-bin: all $(call QUIET_INSTALL, binaries) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'; \
- $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)' - $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)'; \
+ $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)/perf_$(VERSION)' - $(LN) '$(DESTDIR_SQ)$(bindir_SQ)/perf' '$(DESTDIR_SQ)$(bindir_SQ)/trace'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)' + $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)/perf_$(VERSION)'; \
$(INSTALL) $(OUTPUT)perf-archive -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)' + $(LN) '$(DESTDIR_SQ)$(bindir_SQ)/perf_$(VERSION)' '$(DESTDIR_SQ)$(bindir_SQ)/trace_$(VERSION)'
ifndef NO_LIBPERL $(call QUIET_INSTALL, libexec) \
@@ -787,7 +787,7 @@ ifndef NO_LIBPYTHON $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
$(INSTALL) scripts/python/bin/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/bin' $(call QUIET_INSTALL, perf-archive) \
@@ -842,7 +842,7 @@ ifndef NO_LIBPYTHON
endif endif
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d' $(call QUIET_INSTALL, bash_completion-script) \
- $(INSTALL) bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d'; \
+ $(INSTALL) bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)' - $(INSTALL) bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests' + $(INSTALL) bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)'
$(INSTALL) tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests' $(call QUIET_INSTALL, tests) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr' $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'; \
@@ -800,7 +800,7 @@ install-python_ext: $(INSTALL) tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'; \
@@ -856,7 +856,7 @@ install-python_ext:
# 'make install-doc' should call 'make -C Documentation install' # 'make install-doc' should call 'make -C Documentation install'
$(INSTALL_DOC_TARGETS): $(INSTALL_DOC_TARGETS):
@ -38,7 +40,7 @@ version-dependent name.]
--- a/tools/perf/Documentation/Makefile --- a/tools/perf/Documentation/Makefile
+++ b/tools/perf/Documentation/Makefile +++ b/tools/perf/Documentation/Makefile
@@ -182,13 +182,15 @@ ifdef missing_tools @@ -183,14 +183,16 @@ ifdef missing_tools
$(error "You need to install $(missing_tools) for man pages") $(error "You need to install $(missing_tools) for man pages")
endif endif
@ -50,13 +52,14 @@ version-dependent name.]
+ sed -e 's/"PERF"/"PERF_$(VERSION)"/' -e 's/fBperf-/fBperf_$(VERSION)-/g' $^ > $(DESTDIR)$(man1dir)/perf_$(VERSION).1 + sed -e 's/"PERF"/"PERF_$(VERSION)"/' -e 's/fBperf-/fBperf_$(VERSION)-/g' $^ > $(DESTDIR)$(man1dir)/perf_$(VERSION).1
+ +
+install-man-perf%.1: $(OUTPUT)perf%.1 +install-man-perf%.1: $(OUTPUT)perf%.1
$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir) $(call QUIET_INSTALL, Documentation-man) \
-# $(INSTALL) -d -m 755 $(DESTDIR)$(man5dir) $(INSTALL) -d -m 755 $(DESTDIR)$(man1dir); \
-# $(INSTALL) -d -m 755 $(DESTDIR)$(man7dir) -# $(INSTALL) -d -m 755 $(DESTDIR)$(man5dir); \
- $(INSTALL) -m 644 $(DOC_MAN1) $(DESTDIR)$(man1dir) -# $(INSTALL) -d -m 755 $(DESTDIR)$(man7dir); \
-# $(INSTALL) -m 644 $(DOC_MAN5) $(DESTDIR)$(man5dir) - $(INSTALL) -m 644 $(DOC_MAN1) $(DESTDIR)$(man1dir); \
-# $(INSTALL) -m 644 $(DOC_MAN7) $(DESTDIR)$(man7dir) -# $(INSTALL) -m 644 $(DOC_MAN5) $(DESTDIR)$(man5dir); \
+ sed -e 's/"PERF\\-/"PERF_$(VERSION)\\-/' -e 's/fBperf-/fBperf_$(VERSION)-/g' $^ > $(DESTDIR)$(man1dir)/perf_$(VERSION)$*.1 -# $(INSTALL) -m 644 $(DOC_MAN7) $(DESTDIR)$(man7dir)
+ sed -e 's/"PERF\\-/"PERF_$(VERSION)\\-/' -e 's/fBperf-/fBperf_$(VERSION)-/g' $^ > $(DESTDIR)$(man1dir)/perf_$(VERSION)$*.1
install-man: check-man-tools man install-man: check-man-tools man

View File

@ -7,17 +7,17 @@ Add references to TCP wrappers configuration in the manual page.
--- a/drivers/staging/usbip/userspace/doc/usbipd.8 --- a/drivers/staging/usbip/userspace/doc/usbipd.8
+++ b/drivers/staging/usbip/userspace/doc/usbipd.8 +++ b/drivers/staging/usbip/userspace/doc/usbipd.8
@@ -14,7 +14,8 @@ @@ -14,7 +14,8 @@ Devices have to explicitly be exported u
before usbipd makes them available to other hosts. before usbipd makes them available to other hosts.
The daemon accepts connections from USB/IP clients The daemon accepts connections from USB/IP clients
-on TCP port 3240. -on TCP port 3240 by default.
+on TCP port 3240. The clients authorised to connect may be +on TCP port 3240 by default. The clients authorised to connect may be
+configured as documented in hosts_access(5). +configured as documented in hosts_access(5).
.SH OPTIONS .SH OPTIONS
.HP .HP
@@ -44,7 +45,8 @@ @@ -69,7 +70,8 @@ Show version.
.B usbipd .B usbipd
offers no authentication or authorization for USB/IP. Any offers no authentication or authorization for USB/IP. Any