Update to 3.14-rc7

svn path=/dists/trunk/linux-tools/; revision=21159
This commit is contained in:
Ben Hutchings 2014-03-17 19:30:58 +00:00
parent e534752fb2
commit 0b8b168b15
3 changed files with 1 additions and 46 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux-tools (3.14~rc5-1~exp1) UNRELEASED; urgency=medium
linux-tools (3.14~rc7-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate

View File

@ -1,44 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 6 Feb 2014 00:47:06 +0000
Subject: [PATCH 3/3] perf trace: Decode architecture-specific signal numbers
Forwarded: http://mid.gmane.org/1391648441.3003.101.camel@deadeye.wl.decadent.org.uk
SIGSTKFLT is not defined on alpha, mips or sparc.
SIGEMT and SIGSWI are defined on some architectures and should be
decoded here if so.
Fixes: 8bad5b0abfdb ('perf trace: Beautify signal number arg in several syscalls')
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Cc: <stable@vger.kernel.org>
---
tools/perf/builtin-trace.c | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/tools/perf/builtin-trace.c b/tools/perf/builtin-trace.c
index 5c32dcf..25ea64c 100644
--- a/tools/perf/builtin-trace.c
+++ b/tools/perf/builtin-trace.c
@@ -807,7 +807,6 @@ static size_t syscall_arg__scnprintf_signum(char *bf, size_t size, struct syscal
P_SIGNUM(PIPE);
P_SIGNUM(ALRM);
P_SIGNUM(TERM);
- P_SIGNUM(STKFLT);
P_SIGNUM(CHLD);
P_SIGNUM(CONT);
P_SIGNUM(STOP);
@@ -823,6 +822,15 @@ static size_t syscall_arg__scnprintf_signum(char *bf, size_t size, struct syscal
P_SIGNUM(IO);
P_SIGNUM(PWR);
P_SIGNUM(SYS);
+#ifdef SIGEMT
+ P_SIGNUM(EMT);
+#endif
+#ifdef SIGSTKFLT
+ P_SIGNUM(STKFLT);
+#endif
+#ifdef SIGSWI
+ P_SIGNUM(SWI);
+#endif
default: break;
}

View File

@ -2,4 +2,3 @@ modpost-symbol-prefix.patch
tools-perf-version.patch
tools-perf-install.patch
usbip-document-tcp-wrappers.patch
perf-trace-Decode-architecture-specific-signal-numbe.patch