Dropped those two patches, as they will not be upstream, we don't build 32bit kernels for ppc64 cpus anymore, and upstream will drop support for them anyway.

svn path=/dists/trunk/linux-2.6-2.6.14-rc4/; revision=4496
This commit is contained in:
Sven Luther 2005-10-16 23:07:21 +00:00
parent c84981243f
commit 0d7d2b40e9
3 changed files with 0 additions and 59 deletions

View File

@ -1,27 +0,0 @@
#! /bin/sh -e
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Description: Works around a broken build system, namely the
## DP: Description: simple bootloader on power 3/4.
## DP: Misc: Pulled from the ubuntu tree.
## DP: Patch author: fabbione@ubuntu.com
## DP: Upstream status: FTBFS fix, guess it will be fixed upstream too
. $(dirname $0)/DPATCH
@DPATCH@
diff -urNad linux-source-2.6.10-2.6.10/arch/ppc/boot/simple/misc-prep.c /usr/src/dpatchtemp/dpep.cQRwcC/linux-source-2.6.10-2.6.10/arch/ppc/boot/simple/misc-prep.c
--- linux-source-2.6.10-2.6.10/arch/ppc/boot/simple/misc-prep.c 2004-12-24 22:33:51.000000000 +0100
+++ /usr/src/dpatchtemp/dpep.cQRwcC/linux-source-2.6.10-2.6.10/arch/ppc/boot/simple/misc-prep.c 2004-12-28 10:43:29.838010536 +0100
@@ -152,9 +152,11 @@
hold_residual->VitalProductData.Reserved5 = 0xdeadbeef;
}
+#if defined(CONFIG_6xx)
/* Now go and clear out the BATs and ensure that our MSR is
* correct .*/
disable_6xx_mmu();
+#endif
/* Make r3 be a pointer to the residual data. */
return (unsigned long)hold_residual;

View File

@ -1,30 +0,0 @@
#! /bin/sh -e
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Description: [PATCH] ppc32: fixes FTBFS on power3/4.
## DP: This patch doesn't build pmac_cache.S on power3/power4, since it is
## DP: broken there and not needed.
## DP: Patch author: Sven Luther <luther@debian.org>
## DP: Upstream status: FTBFS, submitted to linuxppc-dev and benh.
. $(dirname $0)/DPATCH
@DPATCH@
--- kernel-source-2.6.11/arch/ppc/platforms/Makefile.orig 2005-03-27 11:38:25.000000000 +0200
+++ kernel-source-2.6.11/arch/ppc/platforms/Makefile 2005-03-27 11:39:23.000000000 +0200
@@ -9,9 +9,15 @@
ifeq ($(CONFIG_APUS),y)
obj-$(CONFIG_PCI) += apus_pci.o
endif
+ifeq ($(CONFIG_6xx),y)
obj-$(CONFIG_PPC_PMAC) += pmac_pic.o pmac_setup.o pmac_time.o \
pmac_feature.o pmac_pci.o pmac_sleep.o \
pmac_low_i2c.o pmac_cache.o
+else
+obj-$(CONFIG_PPC_PMAC) += pmac_pic.o pmac_setup.o pmac_time.o \
+ pmac_feature.o pmac_pci.o pmac_sleep.o \
+ pmac_low_i2c.o
+endif
obj-$(CONFIG_PPC_CHRP) += chrp_setup.o chrp_time.o chrp_pci.o \
chrp_pegasos_eth.o
obj-$(CONFIG_PPC_PREP) += prep_pci.o prep_setup.o

View File

@ -7,11 +7,9 @@
+ modular-ide.patch
+ modular-ide-pnp.patch
+ powerpc-calibrate-tau.patch
+ powerpc-fix-power3-ftbfs.patch
+ powerpc-g3-750cxe.patch
#+ powerpc-g4-l2-flush-errata.patch
+ powerpc-mkvmlinuz-support.patch
+ powerpc-pmac-cache-power34-fix.patch
+ powerpc-serial.patch
+ qla2xxx-removed.patch
#+ remove-references-to-removed-drivers.patch