add netpoll fix

svn path=/dists/trunk/linux-2.6/; revision=7642
This commit is contained in:
maximilian attems 2006-10-24 14:35:49 +00:00
parent 47d0693c0d
commit 13120ef70a
3 changed files with 47 additions and 1 deletions

5
debian/changelog vendored
View File

@ -16,7 +16,10 @@ linux-2.6 (2.6.18-4) UNRELEASED; urgency=low
sys_msgrcv() and compat_sys_msgrcv(), triggered every 5 seconds whenever
fakeroot is running.
-- Norbert Tretkowski <nobse@debian.org> Sat, 21 Oct 2006 18:52:12 +0200
[ maximilian attems ]
* Add netpoll leak fix.
-- maximilian attems <maks@sternwelten.at> Tue, 24 Oct 2006 16:29:06 +0200
linux-2.6 (2.6.18-3) unstable; urgency=low

42
debian/patches/bugfix/net-netpoll.patch vendored Normal file
View File

@ -0,0 +1,42 @@
From netdev-owner@vger.kernel.org Wed Oct 18 23:31:05 2006
From: Stephen Hemminger <shemminger@osdl.org>
If netpoll uses up it's retries, it should drop the skb
not leak memory.
Signed-off-by: Stephen Hemminger <shemminger@osdl.org>
---
net/core/netpoll.c | 8 ++++----
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/net/core/netpoll.c b/net/core/netpoll.c
index ead5920..c375fde 100644
--- a/net/core/netpoll.c
+++ b/net/core/netpoll.c
@@ -273,10 +273,8 @@ static void netpoll_send_skb(struct netp
int status;
struct netpoll_info *npinfo;
- if (!np || !np->dev || !netif_running(np->dev)) {
- __kfree_skb(skb);
- return;
- }
+ if (!np || !np->dev || !netif_running(np->dev))
+ goto free_skb;
npinfo = np->dev->npinfo;
@@ -314,6 +312,8 @@ static void netpoll_send_skb(struct netp
netpoll_poll(np);
udelay(50);
} while (npinfo->tries > 0);
+free_skb:
+ __kfree_skb(skb);
}
void netpoll_send_udp(struct netpoll *np, const char *msg, int len)
--
1.4.2.3

View File

@ -1,3 +1,4 @@
- sparc64-atyfb-xl-gr.patch
+ bugfix/sparc/sunblade-clock-hang.patch
+ bugfix/sparc/compat-alloc-user-space-alignment.patch
+ bugfix/net-netpoll.patch