linux-kbuild: Build and install recordmcount and recordmcount.pl

These are needed now that we build kernels with DYNAMIC_FTRACE enabled.

Also fix the recordmcount dependency for OOT modules - they should not
depend on its source files!

svn path=/dists/trunk/linux-tools/; revision=21789
This commit is contained in:
Ben Hutchings 2014-09-08 17:43:57 +00:00
parent 98b8aa1ab7
commit 2123f44168
4 changed files with 31 additions and 1 deletions

View File

@ -2,7 +2,8 @@ PROGS = \
bin2c \
conmakehash \
kallsyms \
pnmtologo
pnmtologo \
recordmcount
DATA = \
Kbuild.include \
@ -33,6 +34,7 @@ SCRIPTS = \
mkuboot.sh \
namespace.pl \
patch-kernel \
recordmcount.pl \
setlocalversion \
ver_linux

5
debian/changelog vendored
View File

@ -5,6 +5,11 @@ linux-tools (3.16-1) UNRELEASED; urgency=medium
[ Mauricio Faria de Oliveira ]
* [ppc64el] Build linux-tools binary package (Closes: #754213)
[ Ben Hutchings ]
* linux-kbuild: Build and install recordmcount and recordmcount.pl,
needed for kernels with DYNAMIC_FTRACE enabled
* linux-kbuild: Fix recordmcount dependency for OOT modules
-- Ben Hutchings <ben@decadent.org.uk> Sat, 23 Aug 2014 17:50:42 -0700
linux-tools (3.16~rc7-1~exp1) experimental; urgency=medium

View File

@ -0,0 +1,22 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: kbuild: Fix recordmcount dependency for OOT modules
Date: Mon, 08 Sep 2014 18:31:24 +0100
We never rebuild anything in-tree when building an out-of-tree
modules, so external modules should not depend on the recordmcount
sources.
--- a/scripts/Makefile.build
+++ b/scripts/Makefile.build
@@ -240,6 +240,11 @@ cmd_record_mcount = \
fi;
endif
+# Don't require recordmcount source for an OOT build.
+ifdef KBUILD_EXTMOD
+recordmcount_source :=
+endif
+
define rule_cc_o_c
$(call echo-cmd,checksrc) $(cmd_checksrc) \
$(call echo-cmd,cc_o_c) $(cmd_cc_o_c); \

View File

@ -2,3 +2,4 @@ modpost-symbol-prefix.patch
tools-perf-version.patch
tools-perf-install.patch
usbip-document-tcp-wrappers.patch
kbuild-fix-recordmcount-dependency.patch