Update to 4.19.132

Drop "nfsd: apply umask on fs without ACL support"

Drop "usb: usbtest: fix missing kfree(dev->buf) in usbtest_disconnect"

Cleanup debian/changelog file
This commit is contained in:
Salvatore Bonaccorso 2020-07-14 21:48:41 +02:00
parent 83c1f79989
commit 214a334057
4 changed files with 40 additions and 123 deletions

40
debian/changelog vendored
View File

@ -1,3 +1,43 @@
linux (4.19.132-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.132
- btrfs: fix a block group ref counter leak after failure to remove block
group
- mm: fix swap cache node allocation mask
- [x86] EDAC/amd64: Read back the scrub rate PCI register on F15h
- usbnet: smsc95xx: Fix use-after-free after removal
- mm/slub.c: fix corrupted freechain in deactivate_slab()
- mm/slub: fix stack overruns with SLUB_STATS
- [s390x] debug: avoid kernel warning on too large number of pages
- nvme-multipath: set bdi capabilities once
- nvme-multipath: fix deadlock between ana_work and scan_work
- crypto: af_alg - fix use-after-free in af_alg_accept() due to
bh_lock_sock()
- [arm64] drm/msm/dpu: fix error return code in dpu_encoder_init
- cxgb4: use unaligned conversion for fetching timestamp
- cxgb4: parse TC-U32 key values and masks natively
- cxgb4: use correct type for all-mask IP address comparison
- cxgb4: fix SGE queue dump destination buffer context
- [x86] hwmon: (acpi_power_meter) Fix potential memory leak in
acpi_power_meter_add()
- [arm64,armhf] drm: sun4i: hdmi: Remove extra HPD polling
- virtio-blk: free vblk-vqs in error path of virtblk_probe()
- SMB3: Honor 'posix' flag for multiuser mounts
- nvme: fix a crash in nvme_mpath_add_disk
- i2c: algo-pca: Add 0x78 as SCL stuck low status for PCA9665
- Revert "ALSA: usb-audio: Improve frames size computation"
- SMB3: Honor 'seal' flag for multiuser mounts
- SMB3: Honor persistent/resilient handle flags for multiuser mounts
- SMB3: Honor lease disabling for multiuser mounts
- cifs: Fix the target file was deleted when rename failed.
- [mips*] Add missing EHB in mtc0 -> mfc0 sequence for DSPen
- [arm64,armhf] irqchip/gic: Atomically update affinity
- dm zoned: assign max_io_len correctly
- efi: Make it possible to disable efivar_ssdt entirely
-- Salvatore Bonaccorso <carnil@debian.org> Tue, 14 Jul 2020 21:48:28 +0200
linux (4.19.131-2) buster; urgency=medium
[ Aurelien Jarno ]

View File

@ -1,56 +0,0 @@
From: "J. Bruce Fields" <bfields@redhat.com>
Date: Tue, 16 Jun 2020 16:43:18 -0400
Subject: nfsd: apply umask on fs without ACL support
Origin: http://git.linux-nfs.org/?p=bfields/linux.git;a=commit;h=22cf8419f1319ff87ec759d0ebdff4cbafaee832
Bug-Debian: https://bugs.debian.org/962254
The server is failing to apply the umask when creating new objects on
filesystems without ACL support.
To reproduce this, you need to use NFSv4.2 and a client and server
recent enough to support umask, and you need to export a filesystem that
lacks ACL support (for example, ext4 with the "noacl" mount option).
Filesystems with ACL support are expected to take care of the umask
themselves (usually by calling posix_acl_create).
For filesystems without ACL support, this is up to the caller of
vfs_create(), vfs_mknod(), or vfs_mkdir().
Reported-by: Elliott Mitchell <ehem+debian@m5p.com>
Reported-by: Salvatore Bonaccorso <carnil@debian.org>
Tested-by: Salvatore Bonaccorso <carnil@debian.org>
Fixes: 47057abde515 ("nfsd: add support for the umask attribute")
Cc: stable@vger.kernel.org
Signed-off-by: J. Bruce Fields <bfields@redhat.com>
---
fs/nfsd/vfs.c | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/fs/nfsd/vfs.c b/fs/nfsd/vfs.c
index c3fbab1753ec..d22a056da477 100644
--- a/fs/nfsd/vfs.c
+++ b/fs/nfsd/vfs.c
@@ -1226,6 +1226,9 @@ nfsd_create_locked(struct svc_rqst *rqstp, struct svc_fh *fhp,
iap->ia_mode = 0;
iap->ia_mode = (iap->ia_mode & S_IALLUGO) | type;
+ if (!IS_POSIXACL(dirp))
+ iap->ia_mode &= ~current_umask();
+
err = 0;
host_err = 0;
switch (type) {
@@ -1458,6 +1461,9 @@ do_nfsd_create(struct svc_rqst *rqstp, struct svc_fh *fhp,
goto out;
}
+ if (!IS_POSIXACL(dirp))
+ iap->ia_mode &= ~current_umask();
+
host_err = vfs_create(dirp, dchild, iap->ia_mode, true);
if (host_err < 0) {
fh_drop_write(fhp);
--
2.27.0

View File

@ -1,65 +0,0 @@
From: Zqiang <qiang.zhang@windriver.com>
Date: Fri, 12 Jun 2020 11:52:10 +0800
Subject: usb: usbtest: fix missing kfree(dev->buf) in usbtest_disconnect
Origin: https://git.kernel.org/linus/28ebeb8db77035e058a510ce9bd17c2b9a009dba
Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2020-15393
BUG: memory leak
unreferenced object 0xffff888055046e00 (size 256):
comm "kworker/2:9", pid 2570, jiffies 4294942129 (age 1095.500s)
hex dump (first 32 bytes):
00 70 04 55 80 88 ff ff 18 bb 5a 81 ff ff ff ff .p.U......Z.....
f5 96 78 81 ff ff ff ff 37 de 8e 81 ff ff ff ff ..x.....7.......
backtrace:
[<00000000d121dccf>] kmemleak_alloc_recursive
include/linux/kmemleak.h:43 [inline]
[<00000000d121dccf>] slab_post_alloc_hook mm/slab.h:586 [inline]
[<00000000d121dccf>] slab_alloc_node mm/slub.c:2786 [inline]
[<00000000d121dccf>] slab_alloc mm/slub.c:2794 [inline]
[<00000000d121dccf>] kmem_cache_alloc_trace+0x15e/0x2d0 mm/slub.c:2811
[<000000005c3c3381>] kmalloc include/linux/slab.h:555 [inline]
[<000000005c3c3381>] usbtest_probe+0x286/0x19d0
drivers/usb/misc/usbtest.c:2790
[<000000001cec6910>] usb_probe_interface+0x2bd/0x870
drivers/usb/core/driver.c:361
[<000000007806c118>] really_probe+0x48d/0x8f0 drivers/base/dd.c:551
[<00000000a3308c3e>] driver_probe_device+0xfc/0x2a0 drivers/base/dd.c:724
[<000000003ef66004>] __device_attach_driver+0x1b6/0x240
drivers/base/dd.c:831
[<00000000eee53e97>] bus_for_each_drv+0x14e/0x1e0 drivers/base/bus.c:431
[<00000000bb0648d0>] __device_attach+0x1f9/0x350 drivers/base/dd.c:897
[<00000000838b324a>] device_initial_probe+0x1a/0x20 drivers/base/dd.c:944
[<0000000030d501c1>] bus_probe_device+0x1e1/0x280 drivers/base/bus.c:491
[<000000005bd7adef>] device_add+0x131d/0x1c40 drivers/base/core.c:2504
[<00000000a0937814>] usb_set_configuration+0xe84/0x1ab0
drivers/usb/core/message.c:2030
[<00000000e3934741>] generic_probe+0x6a/0xe0 drivers/usb/core/generic.c:210
[<0000000098ade0f1>] usb_probe_device+0x90/0xd0
drivers/usb/core/driver.c:266
[<000000007806c118>] really_probe+0x48d/0x8f0 drivers/base/dd.c:551
[<00000000a3308c3e>] driver_probe_device+0xfc/0x2a0 drivers/base/dd.c:724
Acked-by: Alan Stern <stern@rowland.harvard.edu>
Reported-by: Kyungtae Kim <kt0755@gmail.com>
Signed-off-by: Zqiang <qiang.zhang@windriver.com>
Link: https://lore.kernel.org/r/20200612035210.20494-1-qiang.zhang@windriver.com
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
---
drivers/usb/misc/usbtest.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/usb/misc/usbtest.c b/drivers/usb/misc/usbtest.c
index 98ada1a3425c..bae88893ee8e 100644
--- a/drivers/usb/misc/usbtest.c
+++ b/drivers/usb/misc/usbtest.c
@@ -2873,6 +2873,7 @@ static void usbtest_disconnect(struct usb_interface *intf)
usb_set_intfdata(intf, NULL);
dev_dbg(&intf->dev, "disconnect\n");
+ kfree(dev->buf);
kfree(dev);
}
--
2.27.0

View File

@ -101,7 +101,6 @@ bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/mt76-use-the-correct-hweight8-function.patch
bugfix/all/rtc-s35390a-set-uie_unsupported.patch
bugfix/all/nfsd-apply-umask-on-fs-without-ACL-support.patch
# Miscellaneous features
@ -296,6 +295,5 @@ features/arm/staging-vc04_services-Use-correct-cache-line-size.patch
# Security fixes
debian/i386-686-pae-pci-set-pci-nobios-by-default.patch
debian/ntfs-mark-it-as-broken.patch
bugfix/all/usb-usbtest-fix-missing-kfree-dev-buf-in-usbtest_dis.patch
# ABI maintenance