Update to 4.19.147

Drop "gfs2: initialize transaction tr_ailX_lists earlier"

Cleanup debian/changelog file
This commit is contained in:
Salvatore Bonaccorso 2020-09-26 11:18:01 +02:00
parent d9f092067b
commit 2666759d22
3 changed files with 43 additions and 55 deletions

43
debian/changelog vendored
View File

@ -1,3 +1,46 @@
linux (4.19.147-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.147
- [arm64,armhf] dsa: Allow forwarding of redirected IGMP traffic
- scsi: qla2xxx: Update rscn_rcvd field to more meaningful scan_needed
- scsi: qla2xxx: Move rport registration out of internal work_list
- scsi: qla2xxx: Reduce holding sess_lock to prevent CPU lock-up
- net: handle the return value of pskb_carve_frag_list() correctly
- [x86] hv_netvsc: Remove "unlikely" from netvsc_select_queue
- NFSv4.1 handle ERR_DELAY error reclaiming locking state on delegation
recall
- scsi: pm8001: Fix memleak in pm8001_exec_internal_task_abort
- scsi: libfc: Fix for double free()
- scsi: lpfc: Fix FLOGI/PLOGI receive race condition in pt2pt discovery
- [arm64] regulator: pwm: Fix machine constraints application
- NFS: Zero-stateid SETATTR should first return delegation
- SUNRPC: stop printk reading past end of string
- nvme-fc: cancel async events before freeing event struct
- nvme-rdma: cancel async events before freeing event struct
- f2fs: fix indefinite loop scanning for free nid
- f2fs: Return EOF on unaligned end of file DIO read
- i2c: algo: pca: Reapply i2c bus settings after reset
- spi: Fix memory leak on splited transfers
- [arm64,armhf] clk: rockchip: Fix initialization of mux_pll_src_4plls_p
- [arm64] ASoC: qcom: Set card->owner to avoid warnings
- [x86] Drivers: hv: vmbus: Add timeout to vmbus_wait_for_unload
- fbcon: Fix user font detection test at fbcon_resize().
- USB: quirks: Add USB_QUIRK_IGNORE_REMOTE_WAKEUP quirk for BYD zhaoxin
notebook
- USB: UAS: fix disconnect by unplugging a hub
- usblp: fix race between disconnect() and read()
- [x86] i2c: i801: Fix resume bug
- Revert "ALSA: hda - Fix silent audio output and corrupted input on MSI
X570-A PRO"
- percpu: fix first chunk size calculation for populated bitmap
- Input: trackpoint - add new trackpoint variant IDs
- serial: 8250_pci: Add Realtek 816a and 816b
- ehci-hcd: Move include to keep CRC stable
- [powerpc*] dma: Fix dma_map_ops::get_required_mask
-- Salvatore Bonaccorso <carnil@debian.org> Sat, 26 Sep 2020 11:17:48 +0200
linux (4.19.146-1) buster; urgency=medium
* New upstream stable update:

View File

@ -1,54 +0,0 @@
From: Bob Peterson <rpeterso@redhat.com>
Date: Fri, 5 Jun 2020 14:12:34 -0500
Subject: gfs2: initialize transaction tr_ailX_lists earlier
Origin: https://git.kernel.org/linus/cbcc89b630447ec7836aa2b9242d9bb1725f5a61
Bug-Debian: https://bugs.debian.org/968567
Since transactions may be freed shortly after they're created, before
a log_flush occurs, we need to initialize their ail1 and ail2 lists
earlier. Before this patch, the ail1 list was initialized in gfs2_log_flush().
This moves the initialization to the point when the transaction is first
created.
Signed-off-by: Bob Peterson <rpeterso@redhat.com>
Signed-off-by: Andreas Gruenbacher <agruenba@redhat.com>
[Salvatore Bonaccorso: Backport to 4.19.144 for context changes]
---
fs/gfs2/glops.c | 2 ++
fs/gfs2/log.c | 2 --
fs/gfs2/trans.c | 2 ++
3 files changed, 4 insertions(+), 2 deletions(-)
--- a/fs/gfs2/glops.c
+++ b/fs/gfs2/glops.c
@@ -89,6 +89,8 @@ static void gfs2_ail_empty_gl(struct gfs
memset(&tr, 0, sizeof(tr));
INIT_LIST_HEAD(&tr.tr_buf);
INIT_LIST_HEAD(&tr.tr_databuf);
+ INIT_LIST_HEAD(&tr.tr_ail1_list);
+ INIT_LIST_HEAD(&tr.tr_ail2_list);
tr.tr_revokes = atomic_read(&gl->gl_ail_count);
if (!tr.tr_revokes)
--- a/fs/gfs2/log.c
+++ b/fs/gfs2/log.c
@@ -806,8 +806,6 @@ void gfs2_log_flush(struct gfs2_sbd *sdp
tr = sdp->sd_log_tr;
if (tr) {
sdp->sd_log_tr = NULL;
- INIT_LIST_HEAD(&tr->tr_ail1_list);
- INIT_LIST_HEAD(&tr->tr_ail2_list);
tr->tr_first = sdp->sd_log_flush_head;
if (unlikely (state == SFS_FROZEN))
gfs2_assert_withdraw(sdp, !tr->tr_num_buf_new && !tr->tr_num_databuf_new);
--- a/fs/gfs2/trans.c
+++ b/fs/gfs2/trans.c
@@ -56,6 +56,8 @@ int gfs2_trans_begin(struct gfs2_sbd *sd
sizeof(u64));
INIT_LIST_HEAD(&tr->tr_databuf);
INIT_LIST_HEAD(&tr->tr_buf);
+ INIT_LIST_HEAD(&tr->tr_ail1_list);
+ INIT_LIST_HEAD(&tr->tr_ail2_list);
sb_start_intwrite(sdp->sd_vfs);

View File

@ -100,7 +100,6 @@ bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/mt76-use-the-correct-hweight8-function.patch
bugfix/all/rtc-s35390a-set-uie_unsupported.patch
bugfix/all/gfs2-initialize-transaction-tr_ailX_lists-earlier.patch
# Miscellaneous features
features/all/e1000e-Add-support-for-Comet-Lake.patch