workaround bug

svn path=/dists/trunk/linux-2.6/; revision=12811
This commit is contained in:
Martin Michlmayr 2009-02-16 11:39:27 +00:00
parent 5fad4790a6
commit 294e2ead98
2 changed files with 16 additions and 0 deletions

View File

@ -0,0 +1,15 @@
workaround this bug:
cc1: warnings being treated as errors
arch/mips/kernel/../../../fs/binfmt_elf.c: In function vma_dump_size:
arch/mips/kernel/../../../fs/binfmt_elf.c:1202: warning: word may be used uninitialized in this function
--- a/arch/mips/kernel/Makefile 2009-02-16 11:25:13.000000000 +0000
+++ b/arch/mips/kernel/Makefile 2009-02-16 11:25:23.000000000 +0000
@@ -89,4 +89,3 @@
obj-$(CONFIG_HAVE_STD_PC_SERIAL_PORT) += 8250-platform.o
-EXTRA_CFLAGS += -Werror

View File

@ -17,6 +17,7 @@
+ bugfix/mips/disable-advansys.patch
+ bugfix/arm/disable-scsi_acard.patch
+ bugfix/arm/disable-orion5x_wdt.patch
+ bugfix/mips/disable-werror.patch
+ bugfix/fix-hifn_795X-divdi3.patch
+ bugfix/powerpc/mm-mol.patch
+ bugfix/powerpc/lpar-console.patch