This is the final apus-unbreaking version.

svn path=/dists/trunk/linux-2.6/; revision=4373
This commit is contained in:
Sven Luther 2005-10-10 16:24:38 +00:00
parent dff8673cfc
commit 2a261fbb99
1 changed files with 9 additions and 7 deletions

View File

@ -20,7 +20,7 @@
#
--- linux-kernel-2.6.12-2.6.12/arch/ppc/boot/Makefile.orig 2005-07-15 12:46:28.000000000 +0000
+++ linux-kernel-2.6.12-2.6.12/arch/ppc/boot/Makefile 2005-07-15 12:55:56.000000000 +0000
@@ -32,3 +32,35 @@
@@ -32,3 +32,37 @@
$(bootdir-y): $(addprefix $(obj)/,$(subdir-y)) \
$(addprefix $(obj)/,$(hostprogs-y))
$(Q)$(MAKE) $(build)=$(obj)/$@ $(MAKECMDGOALS)
@ -30,19 +30,21 @@
+ mkdir -p $(INSTALL_MKVMLINUZ)/boot
+ install -m 644 -o root -g root ld.script $(INSTALL_MKVMLINUZ)/boot
+ if [ -e openfirmware/note ]; then \
+ install -m 644 -o root -g root openfirmware/note $(INSTALL_MKVMLINUZ)/boot \
+ install -m 644 -o root -g root openfirmware/note $(INSTALL_MKVMLINUZ)/boot; \
+ fi
+
+ mkdir -p $(INSTALL_MKVMLINUZ)/lib
+ install -m 644 -o root -g root ../../../lib/lib.a $(INSTALL_MKVMLINUZ)/lib
+ install -m 644 -o root -g root lib/lib.a $(INSTALL_MKVMLINUZ)/lib/ppc.a
+ install -m 644 -o root -g root common/lib.a $(INSTALL_MKVMLINUZ)/lib/common.a
+ install -m 644 -o root -g root of1275/lib.a $(INSTALL_MKVMLINUZ)/lib/of.a
+ if [ -e of1275/lib.a ]; then \
+ install -m 644 -o root -g root of1275/lib.a $(INSTALL_MKVMLINUZ)/lib/of.a; \
+ fi
+
+ if [ -e common.o ]; \
+ mkdir -p $(INSTALL_MKVMLINUZ)/obj/openfirmware \
+ install -m 644 -o root -g root openfirmware/*.o $(INSTALL_MKVMLINUZ)/obj/openfirmware \
+ rm -f $(INSTALL_MKVMLINUZ)/obj/openfirmware/image* \
+ if [ -e openfirmware/common.o ]; then \
+ mkdir -p $(INSTALL_MKVMLINUZ)/obj/openfirmware; \
+ install -m 644 -o root -g root openfirmware/*.o $(INSTALL_MKVMLINUZ)/obj/openfirmware; \
+ rm -f $(INSTALL_MKVMLINUZ)/obj/openfirmware/image*; \
+ fi
+
+ mkdir -p $(INSTALL_MKVMLINUZ)/obj/simple