Enable retries for SYNCRONIZE_CACHE commands to fix I/O error

add ext3 fs error patch from linux-next.

svn path=/dists/sid/linux-2.6/; revision=15640
This commit is contained in:
Maximilian Attems 2010-05-08 17:13:29 +00:00
parent 46b6f91ed4
commit 2cd26425f2
3 changed files with 35 additions and 0 deletions

1
debian/changelog vendored
View File

@ -11,6 +11,7 @@ linux-2.6 (2.6.32-13) UNRELEASED; urgency=low
(closes: #580652)
* KEYS: find_keyring_by_name() can gain access to a freed keyring.
CVE-2010-1437
* [SCSI] Enable retries for SYNCRONIZE_CACHE commands to fix I/O error
-- Frederik Schüler <fs@debian.org> Wed, 05 May 2010 17:54:01 +0200

View File

@ -0,0 +1,33 @@
From c213e1407be6b04b144794399a91472e0ef92aec Mon Sep 17 00:00:00 2001
From: Hannes Reinecke <hare@suse.de>
Date: Tue, 4 May 2010 16:49:21 +0200
Subject: [PATCH] [SCSI] Enable retries for SYNCRONIZE_CACHE commands to fix I/O error
Some arrays are giving I/O errors with ext3 filesystems when
SYNCHRONIZE_CACHE gets a UNIT_ATTENTION. What is happening is that
these commands have no retries, so the UNIT_ATTENTION causes the
barrier to fail. We should be enable retries here to clear any
transient error and allow the barrier to succeed.
Signed-off-by: Hannes Reinecke <hare@suse.de>
Cc: Stable Tree <stable@kernel.org>
Signed-off-by: James Bottomley <James.Bottomley@suse.de>
---
drivers/scsi/sd.c | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
index 8b827f3..de6c603 100644
--- a/drivers/scsi/sd.c
+++ b/drivers/scsi/sd.c
@@ -1040,6 +1040,7 @@ static void sd_prepare_flush(struct request_queue *q, struct request *rq)
{
rq->cmd_type = REQ_TYPE_BLOCK_PC;
rq->timeout = SD_TIMEOUT;
+ rq->retries = SD_MAX_RETRIES;
rq->cmd[0] = SYNCHRONIZE_CACHE;
rq->cmd_len = 10;
}
--
1.6.5

View File

@ -1,3 +1,4 @@
+ bugfix/sparc/sparc-Fix-use-of-uid16_t-and-gid16_t.patch
+ bugfix/all/KVM-x86-Extend-KVM_SET_VCPU_EVENTS-with-selective-up.patch
+ bugfix/all/keys-the-request_key-syscall-should-link-an-existing-key-to-the-dest-keyring.patch
+ bugfix/all/SCSI-Enable-retries-for-SYNCRONIZE_CACHE-commands-to.patch