Refresh fuzzy patches

svn path=/dists/trunk/linux/; revision=19129
This commit is contained in:
Ben Hutchings 2012-06-11 05:25:25 +00:00
parent f9d7178138
commit 2dc1c81000
4 changed files with 21 additions and 39 deletions

View File

@ -15,7 +15,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
--- a/drivers/gpu/drm/nouveau/Kconfig
+++ b/drivers/gpu/drm/nouveau/Kconfig
@@ -11,8 +11,8 @@ config DRM_NOUVEAU
@@ -11,8 +11,8 @@
select FRAMEBUFFER_CONSOLE if !EXPERT
select FB_BACKLIGHT if DRM_NOUVEAU_BACKLIGHT
select ACPI_VIDEO if ACPI && X86 && BACKLIGHT_CLASS_DEVICE && VIDEO_OUTPUT_CONTROL && INPUT
@ -28,7 +28,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Choose this option for open-source nVidia support.
--- a/drivers/gpu/drm/nouveau/Makefile
+++ b/drivers/gpu/drm/nouveau/Makefile
@@ -37,6 +37,8 @@ nouveau-y := nouveau_drv.o nouveau_state.o nouveau_channel.o nouveau_mem.o \
@@ -42,6 +42,8 @@
nouveau-$(CONFIG_DRM_NOUVEAU_DEBUG) += nouveau_debugfs.o
nouveau-$(CONFIG_COMPAT) += nouveau_ioc32.o
nouveau-$(CONFIG_DRM_NOUVEAU_BACKLIGHT) += nouveau_backlight.o
@ -39,7 +39,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
obj-$(CONFIG_DRM_NOUVEAU)+= nouveau.o
--- a/drivers/gpu/drm/nouveau/nouveau_drv.h
+++ b/drivers/gpu/drm/nouveau/nouveau_drv.h
@@ -968,7 +968,7 @@ extern int nouveau_dma_wait(struct nouveau_channel *, int slots, int size);
@@ -1095,7 +1095,7 @@
/* nouveau_acpi.c */
#define ROM_BIOS_PAGE 4096
@ -47,4 +47,4 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
+#if defined(CONFIG_ACPI) && defined(CONFIG_X86)
void nouveau_register_dsm_handler(void);
void nouveau_unregister_dsm_handler(void);
int nouveau_acpi_get_bios_chunk(uint8_t *bios, int offset, int len);
void nouveau_switcheroo_optimus_dsm(void);

View File

@ -10,14 +10,14 @@ Original version by Bastian Blank <waldi@debian.org>.
--- a/drivers/tty/hvc/hvc_vio.c
+++ b/drivers/tty/hvc/hvc_vio.c
@@ -48,6 +48,7 @@
#include <asm/firmware.h>
#include <asm/prom.h>
#include <asm/hvsi.h>
#include <asm/udbg.h>
+#include <asm/machdep.h>
#include "hvc_console.h"
@@ -446,7 +447,9 @@ void __init hvc_vio_init_early(void)
@@ -440,7 +441,9 @@
if (hvterm_priv0.proto == HV_PROTOCOL_HVSI)
goto out;
#endif

View File

@ -17,11 +17,9 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
drivers/net/ethernet/emulex/benet/be_main.c | 44 ++++++++++++++++++---------
1 file changed, 30 insertions(+), 14 deletions(-)
diff --git a/drivers/net/ethernet/emulex/benet/be_main.c b/drivers/net/ethernet/emulex/benet/be_main.c
index 376a2fa..34b8ad2 100644
--- a/drivers/net/ethernet/emulex/benet/be_main.c
+++ b/drivers/net/ethernet/emulex/benet/be_main.c
@@ -797,22 +797,30 @@ static int be_vid_config(struct be_adapter *adapter, bool vf, u32 vf_num)
@@ -797,22 +797,30 @@
if (adapter->promiscuous)
return 0;
@ -64,8 +62,8 @@ index 376a2fa..34b8ad2 100644
+ return status;
}
static void be_vlan_add_vid(struct net_device *netdev, u16 vid)
@@ -854,6 +862,7 @@ static void be_vlan_rem_vid(struct net_device *netdev, u16 vid)
static int be_vlan_add_vid(struct net_device *netdev, u16 vid)
@@ -862,6 +870,7 @@
static void be_set_rx_mode(struct net_device *netdev)
{
struct be_adapter *adapter = netdev_priv(netdev);
@ -73,7 +71,7 @@ index 376a2fa..34b8ad2 100644
if (netdev->flags & IFF_PROMISC) {
be_cmd_rx_filter(adapter, IFF_PROMISC, ON);
@@ -900,7 +909,14 @@ static void be_set_rx_mode(struct net_device *netdev)
@@ -908,7 +917,14 @@
}
}
@ -89,6 +87,3 @@ index 376a2fa..34b8ad2 100644
done:
return;
}
--
1.7.10

View File

@ -76,11 +76,9 @@ Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
kernel/sysctl.c | 11 +++++
5 files changed, 152 insertions(+), 6 deletions(-)
diff --git a/Documentation/sysctl/fs.txt b/Documentation/sysctl/fs.txt
index 88fd7f5..4b47cd5 100644
--- a/Documentation/sysctl/fs.txt
+++ b/Documentation/sysctl/fs.txt
@@ -32,6 +32,7 @@ Currently, these files are in /proc/sys/fs:
@@ -32,6 +32,7 @@
- nr_open
- overflowuid
- overflowgid
@ -88,7 +86,7 @@ index 88fd7f5..4b47cd5 100644
- suid_dumpable
- super-max
- super-nr
@@ -157,6 +158,26 @@ The default is 65534.
@@ -157,6 +158,26 @@
==============================================================
@ -115,11 +113,9 @@ index 88fd7f5..4b47cd5 100644
suid_dumpable:
This value can be used to query and set the core dump mode for setuid
diff --git a/fs/Kconfig b/fs/Kconfig
index 1497ddf..d0fdbdd 100644
--- a/fs/Kconfig
+++ b/fs/Kconfig
@@ -272,4 +272,38 @@ endif # NETWORK_FILESYSTEMS
@@ -277,4 +277,38 @@
source "fs/nls/Kconfig"
source "fs/dlm/Kconfig"
@ -158,11 +154,9 @@ index 1497ddf..d0fdbdd 100644
+ default "0"
+
endmenu
diff --git a/fs/namei.c b/fs/namei.c
index 5d1fab5..5b4c05b 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -623,10 +623,84 @@ static inline void put_link(struct nameidata *nd, struct path *link, void *cooki
@@ -623,10 +623,84 @@
path_put(link);
}
@ -249,8 +243,8 @@ index 5d1fab5..5b4c05b 100644
struct dentry *dentry = link->dentry;
BUG_ON(nd->flags & LOOKUP_RCU);
@@ -645,7 +719,10 @@ follow_link(struct path *link, struct nameidata *nd, void **p)
touch_atime(link->mnt, dentry);
@@ -645,7 +719,10 @@
touch_atime(link);
nd_set_link(nd, NULL);
- error = security_inode_follow_link(link->dentry, nd);
@ -261,7 +255,7 @@ index 5d1fab5..5b4c05b 100644
if (error) {
*p = ERR_PTR(error); /* no ->put_link(), please */
path_put(&nd->path);
@@ -1342,7 +1419,7 @@ static inline int nested_symlink(struct path *path, struct nameidata *nd)
@@ -1351,7 +1428,7 @@
struct path link = *path;
void *cookie;
@ -270,7 +264,7 @@ index 5d1fab5..5b4c05b 100644
if (!res)
res = walk_component(nd, path, &nd->last,
nd->last_type, LOOKUP_FOLLOW);
@@ -1615,7 +1692,8 @@ static int path_lookupat(int dfd, const char *name,
@@ -1743,7 +1820,8 @@
void *cookie;
struct path link = path;
nd->flags |= LOOKUP_PARENT;
@ -280,7 +274,7 @@ index 5d1fab5..5b4c05b 100644
if (!err)
err = lookup_last(nd, &path);
put_link(nd, &link, cookie);
@@ -2327,7 +2405,8 @@ static struct file *path_openat(int dfd, const char *pathname,
@@ -2405,7 +2483,8 @@
}
nd->flags |= LOOKUP_PARENT;
nd->flags &= ~(LOOKUP_OPEN|LOOKUP_CREATE|LOOKUP_EXCL);
@ -290,11 +284,9 @@ index 5d1fab5..5b4c05b 100644
if (unlikely(error))
filp = ERR_PTR(error);
else
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 9808b21..aba8db0 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -423,6 +423,7 @@ extern unsigned long get_max_files(void);
@@ -427,6 +427,7 @@
extern int sysctl_nr_open;
extern struct inodes_stat_t inodes_stat;
extern int leases_enable, lease_break_time;
@ -302,11 +294,9 @@ index 9808b21..aba8db0 100644
struct buffer_head;
typedef int (get_block_t)(struct inode *inode, sector_t iblock,
diff --git a/kernel/sysctl.c b/kernel/sysctl.c
index 62538ee..c469b88 100644
--- a/kernel/sysctl.c
+++ b/kernel/sysctl.c
@@ -1497,6 +1497,17 @@ static struct ctl_table fs_table[] = {
@@ -1493,6 +1493,17 @@
},
#endif
#endif
@ -324,6 +314,3 @@ index 62538ee..c469b88 100644
{
.procname = "suid_dumpable",
.data = &suid_dumpable,
--
1.7.9.1