Release linux-tools (4.2-2).

-----BEGIN PGP SIGNATURE-----
 Version: GnuPG v1
 
 iQIVAwUAVg7Gq+e/yOyVhhEJAQre+w/+MLBBzdQlaNeE31U40DInWZThYzKcKC2U
 IM/DYR5Z4LtNUEFk1xHvhXQm8aUF15NgB5XdXG4NTYW1cMjbz69DumlNFuWgB5U6
 oc4eC3IrjwRDgZS9+xwgcC6BLY5e9CVOviGYL8lXEq6BIMyMfGjwLFXqdKAyknu+
 SWVyOu1JilgGNyCYHNbscR4sKETMdA/z/8zSNJDwUqw/oTPCWxfZEkKHkXb3FzUp
 FKZ8uIWd1HVpEJeL6oA46/GaVUkYMER34wIGapL2ADmErxC6ws2DUXEOyF8f3+ie
 nzs6TB/yx6RUeQeM09ip645ONEGYcmLDgzSkoZwGEEqCv6/N1nP3ZWVPUhRHRmko
 CyWnLXJPGO52pwIIC9MFx3jivynUQbX05D7ALQpzAzv0Amyf/Wugv5zrIDVxZuK9
 MILkkKadEURgBIby/rPKlIMoUYszCfqZJPmZ/2D5zA7gPfmurBnFBoCRn3MDa2Vi
 Zo+5rq1mPAs3iOsHpcy3WTtv8IVBadRnxgp16Aaym1OmR/uo0dNpDlhcvlrQOae6
 iD16/yOd6xyv4rnRUUO+O1osIt683/9Byg26eE8+hprHRThQdYoH325aAJq8Szri
 jx6khs56Haozqzavj9WH7jMm0S4Le0BngSiJRH3E5C5/aFWtj9fNOv37BIZcD8lA
 Y1CVW6+Gyj0=
 =HuYh
 -----END PGP SIGNATURE-----

Merge tag 'debian/4.2-2'
This commit is contained in:
Ben Hutchings 2015-10-06 23:57:50 +01:00
commit 2f0a4173ed
6 changed files with 73 additions and 5 deletions

View File

@ -23,7 +23,10 @@ else ifeq ($(DEB_HOST_ARCH_CPU),sh4)
else ifneq ($(filter sparc%,$(DEB_HOST_ARCH_CPU)),)
KERNEL_ARCH_PERF = sparc
else ifneq ($(filter amd64 i386,$(DEB_HOST_ARCH_CPU)),)
KERNEL_ARCH_PERF = x86
# But x32 isn't supported yet
ifneq ($(shell dpkg-architecture -qDEB_HOST_ARCH),x32)
KERNEL_ARCH_PERF = x86
endif
endif
MAKE_PERF := $(MAKE) prefix=/usr V=1 ARCH=$(KERNEL_ARCH_PERF) EXTRA_WARNINGS=-Wno-error EXTRA_CFLAGS='$(CFLAGS) $(CPPFLAGS)' LDFLAGS='$(LDFLAGS)'

8
debian/changelog vendored
View File

@ -4,6 +4,14 @@ linux-tools (4.3~rc3-1~exp1) UNRELEASED; urgency=medium
-- Ben Hutchings <ben@decadent.org.uk> Mon, 28 Sep 2015 01:54:21 +0100
linux-tools (4.2-2) unstable; urgency=medium
* [x32] Don't attempt to build linux-perf (fixes FTBFS)
* [x32] Build hyperv-daemons package
* [alpha] uapi: Add support for __SANE_USERSPACE_TYPES__(fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 02 Oct 2015 18:41:22 +0100
linux-tools (4.2-1) unstable; urgency=medium
* New upstream release

View File

@ -0,0 +1,56 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 29 Sep 2015 02:55:06 +0100
Subject: [PATCH] alpha: uapi: Add support for __SANE_USERSPACE_TYPES__
Forwarded: http://mid.gmane.org/1443659755.2730.14.camel@decadent.org.uk
This fixes compiler errors in perf such as:
tests/attr.c: In function 'store_event':
tests/attr.c:66:27: error: format '%llu' expects argument of type 'long long unsigned int', but argument 6 has type '__u64 {aka long unsigned int}' [-Werror=format=]
snprintf(path, PATH_MAX, "%s/event-%d-%llu-%d", dir,
^
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Tested-by: Michael Cree <mcree@orcon.net.nz>
Cc: stable@vger.kernel.org
---
arch/alpha/include/asm/types.h | 2 +-
arch/alpha/include/uapi/asm/types.h | 12 +++++++++++-
2 files changed, 12 insertions(+), 2 deletions(-)
diff --git a/arch/alpha/include/asm/types.h b/arch/alpha/include/asm/types.h
index 4cb4b6d..0bc66e1 100644
--- a/arch/alpha/include/asm/types.h
+++ b/arch/alpha/include/asm/types.h
@@ -1,6 +1,6 @@
#ifndef _ALPHA_TYPES_H
#define _ALPHA_TYPES_H
-#include <asm-generic/int-ll64.h>
+#include <uapi/asm/types.h>
#endif /* _ALPHA_TYPES_H */
diff --git a/arch/alpha/include/uapi/asm/types.h b/arch/alpha/include/uapi/asm/types.h
index 9fd3cd4..8d1024d 100644
--- a/arch/alpha/include/uapi/asm/types.h
+++ b/arch/alpha/include/uapi/asm/types.h
@@ -9,8 +9,18 @@
* need to be careful to avoid a name clashes.
*/
-#ifndef __KERNEL__
+/*
+ * This is here because we used to use l64 for alpha
+ * and we don't want to impact user mode with our change to ll64
+ * in the kernel.
+ *
+ * However, some user programs are fine with this. They can
+ * flag __SANE_USERSPACE_TYPES__ to get int-ll64.h here.
+ */
+#if !defined(__SANE_USERSPACE_TYPES__) && !defined(__KERNEL__)
#include <asm-generic/int-l64.h>
+#else
+#include <asm-generic/int-ll64.h>
#endif
#endif /* _UAPI_ALPHA_TYPES_H */

View File

@ -14,3 +14,4 @@ tools-lib-traceevent-use-ldflags.patch
tools-lib-lockdep-use-ldflags.patch
tools-hv-fix-fortify-format-warning.patch
revert-perf-build-fix-libunwind-feature-detection-on.patch
alpha-uapi-add-support-for-__sane_userspace_types__.patch

4
debian/rules.real vendored
View File

@ -4,10 +4,10 @@ export KBUILD_BUILD_TIMESTAMP := $(shell dpkg-parsechangelog | sed -ne 's,^Date:
include debian/rules.defs
binary-arch: install-kbuild install-usbip install-lockdep
ifneq ($(filter alpha amd64 arm64 armel armhf hppa i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el s390 s390x sh4 sparc sparc64 x32,$(DEB_BUILD_ARCH)),)
ifneq ($(filter alpha amd64 arm64 armel armhf hppa i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el s390 s390x sh4 sparc sparc64,$(DEB_BUILD_ARCH)),)
binary-arch: install-perf
endif
ifneq ($(filter i386 amd64,$(DEB_BUILD_ARCH)),)
ifneq ($(filter i386 amd64 x32,$(DEB_BUILD_ARCH)),)
binary-arch: install-hyperv-daemons
endif

View File

@ -7,7 +7,7 @@ Description: Kbuild infrastructure for Linux @version@
Package: linux-perf-@version@
Section: devel
Architecture: alpha amd64 arm64 armel armhf hppa i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el s390 s390x sh4 sparc sparc64 x32
Architecture: alpha amd64 arm64 armel armhf hppa i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el s390 s390x sh4 sparc sparc64
Depends: ${shlibs:Depends}, ${misc:Depends}, ${perl:Depends}, ${python:Depends}
Recommends: linux-base (>= 3.4~)
Provides: linux-tools-@version@
@ -54,7 +54,7 @@ Description: USB device sharing system over IP network
client tool 'usbip'.
Package: hyperv-daemons
Architecture: i386 amd64
Architecture: i386 amd64 x32
Depends: ${shlibs:Depends}, ${misc:Depends}
Section: admin
Description: Support daemons for Linux running on Hyper-V