m68k updates

svn path=/dists/sid/linux-2.6/; revision=6566
This commit is contained in:
Christian T. Steigies 2006-05-14 18:32:00 +00:00
parent e320da436f
commit 315acc2f96
4 changed files with 65 additions and 1 deletions

26
debian/arch/m68k/README.build vendored Normal file
View File

@ -0,0 +1,26 @@
HOWTO cross-build m68k linux-image
Building linux-image packages takes a while, especially on the "slower
arches", ie m68k. Cross-compiling is an alternative, and it works very well
for m68k.
You need to set up a cross-compiler. The toolchain-source package has some
limitations, I prefer using cross-tools, see this page for instructions:
http://people.debian.org/~cts/debian-m68k/cross-compile/
Now you only have to tell the debian build system, that you do want to build
packages for m68k. It used to be sufficient to pass an option to debuild,
since recently you also have to set an environment variable, like this:
DEB_HOST_ARCH=m68k debuild -B -am68k
If you also want to build source packages, omit the -B.
If you want to build images for just one of the currently nine subarches,
you can uncomment some lines in the flavours section in:
debian/arch/m68k/defines
The first run of debuild will give you an error message that updating the
configs suceeded, the second run will build the images.

7
debian/changelog vendored
View File

@ -4,7 +4,12 @@ linux-2.6 (2.6.16-14) UNRELEASED; urgency=low
- fs/locks.c: Fix lease_init (CVE-2006-1860)
* Make i386 xen images recommend libc6-xen.
-- Bastian Blank <waldi@debian.org> Thu, 11 May 2006 12:27:20 +0200
[ Christian T. Steigies ]
* [m68k] Add buddha patch again.
* [m68k] Add cross-compile instructions.
* [6m8k] Enable INPUT_EVDEV for yaird.
-- Christian T. Steigies <cts@debian.org> Sun, 14 May 2006 19:46:29 +0200
linux-2.6 (2.6.16-13) unstable; urgency=low

32
debian/patches/m68k-buddha.patch vendored Normal file
View File

@ -0,0 +1,32 @@
Hi,
On Tue, 31 Jan 2006, Christian T. Steigies wrote:
> ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
> ide0: Catweasel IDE interface
> ide1: Catweasel IDE interface
> ide2: Catweasel IDE interface
> hda: FUJITSU MPF3204AT, ATA DISK drive
> Unable to handle kernel access at virtual address 79735f7a
This might need the same fix, I already needed for gayle.c.
bye, Roman
Index: drivers/ide/legacy/buddha.c
===================================================================
RCS file: /home/linux-m68k/cvsroot/linux/drivers/ide/legacy/buddha.c,v
retrieving revision 1.2
diff -u -p -r1.2 buddha.c
--- linux/drivers/ide/legacy/buddha.c 7 Dec 2003 10:25:18 -0000 1.2
+++ linux/drivers/ide/legacy/buddha.c 1 Feb 2006 14:57:35 -0000
@@ -197,6 +197,7 @@ fail_base2:
z_writeb(0, buddha_board+BUDDHA_IRQ_MR);
for(i=0;i<buddha_num_hwifs;i++) {
+ memset(&hw, 0, sizeof(hw));
if(type != BOARD_XSURF) {
ide_setup_ports(&hw, (buddha_board+buddha_bases[i]),
buddha_offsets, 0,

1
debian/patches/series/14-extra vendored Normal file
View File

@ -0,0 +1 @@
+ m68k-buddha.patch m68k