Update to 3.10-rc7

svn path=/dists/trunk/linux/; revision=20286
This commit is contained in:
Ben Hutchings 2013-06-23 22:02:49 +00:00
parent 575f8cebf3
commit 359aacce08
2 changed files with 11 additions and 11 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.10~rc6-1~exp1) UNRELEASED; urgency=low
linux (3.10~rc7-1~exp1) UNRELEASED; urgency=low
* New upstream release candidate

View File

@ -19,7 +19,7 @@ removed in later patches.
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -604,14 +604,23 @@ static ssize_t firmware_loading_store(st
@@ -619,14 +619,23 @@ static ssize_t firmware_loading_store(st
* is completed.
* */
fw_map_pages_buf(fw_buf);
@ -45,17 +45,17 @@ removed in later patches.
fw_load_abort(fw_priv);
break;
}
@@ -781,6 +790,9 @@ static void firmware_class_timeout_work(
mutex_unlock(&fw_lock);
return;
}
@@ -792,6 +801,9 @@ static void firmware_class_timeout_work(
struct firmware_priv, timeout_work.work);
mutex_lock(&fw_lock);
+ dev_err(fw_priv->dev.parent,
+ "firmware: agent did not handle request for %s\n",
+ fw_priv->buf->fw_id);
fw_load_abort(fw_priv);
mutex_unlock(&fw_lock);
}
@@ -832,25 +844,28 @@ static int _request_firmware_load(struct
@@ -843,25 +855,28 @@ static int _request_firmware_load(struct
retval = device_add(f_dev);
if (retval) {
@ -88,7 +88,7 @@ removed in later patches.
if (timeout != MAX_SCHEDULE_TIMEOUT)
schedule_delayed_work(&fw_priv->timeout_work, timeout);
@@ -940,7 +955,8 @@ _request_firmware_prepare(struct firmwar
@@ -949,7 +964,8 @@ _request_firmware_prepare(struct firmwar
}
if (fw_get_builtin_firmware(firmware, name)) {
@ -98,7 +98,7 @@ removed in later patches.
return 0; /* assigned */
}
@@ -970,9 +986,16 @@ static int assign_firmware_buf(struct fi
@@ -979,9 +995,16 @@ static int assign_firmware_buf(struct fi
struct firmware_buf *buf = fw->priv;
mutex_lock(&fw_lock);
@ -116,7 +116,7 @@ removed in later patches.
}
/*
@@ -1021,7 +1044,7 @@ _request_firmware(const struct firmware
@@ -1030,7 +1053,7 @@ _request_firmware(const struct firmware
if (nowait) {
timeout = usermodehelper_read_lock_wait(timeout);
if (!timeout) {
@ -125,7 +125,7 @@ removed in later patches.
name);
ret = -EBUSY;
goto out;
@@ -1047,6 +1070,9 @@ _request_firmware(const struct firmware
@@ -1056,6 +1079,9 @@ _request_firmware(const struct firmware
if (ret < 0) {
release_firmware(fw);
fw = NULL;