add stable 2.6.32.14-rc1 patch

nuke merged forwarded revert.

svn path=/dists/sid/linux-2.6/; revision=15764
This commit is contained in:
Maximilian Attems 2010-05-25 04:06:41 +00:00
parent 1d53ee02e6
commit 39d4f41982
4 changed files with 1361 additions and 46 deletions

3
debian/changelog vendored
View File

@ -20,6 +20,9 @@ linux-2.6 (2.6.32-14) UNRELEASED; urgency=low
[ Bastian Blank ]
* Update Xen patch.
[ maximilian attems]
* Add stable 2.6.32.14-rc1.
-- Ben Hutchings <ben@decadent.org.uk> Tue, 18 May 2010 02:13:44 +0100
linux-2.6 (2.6.32-13) unstable; urgency=low

File diff suppressed because it is too large Load Diff

View File

@ -1,45 +0,0 @@
From ef2925a0fc92740921e71cb9d638dbe232838910 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 22 May 2010 01:16:55 +0100
Subject: [PATCH] Revert "parisc: Set PCI CLS early in boot."
This reverts commit 5d233bf3dcad483e5f89865aaf5973e67c1630b1.
---
arch/parisc/kernel/pci.c | 7 ++-----
1 files changed, 2 insertions(+), 5 deletions(-)
diff --git a/arch/parisc/kernel/pci.c b/arch/parisc/kernel/pci.c
index 9e74bfe..f7064ab 100644
--- a/arch/parisc/kernel/pci.c
+++ b/arch/parisc/kernel/pci.c
@@ -18,6 +18,7 @@
#include <asm/io.h>
#include <asm/system.h>
+#include <asm/cache.h> /* for L1_CACHE_BYTES */
#include <asm/superio.h>
#define DEBUG_RESOURCES 0
@@ -122,10 +123,6 @@ static int __init pcibios_init(void)
} else {
printk(KERN_WARNING "pci_bios != NULL but init() is!\n");
}
-
- /* Set the CLS for PCI as early as possible. */
- pci_cache_line_size = pci_dfl_cache_line_size;
-
return 0;
}
@@ -174,7 +171,7 @@ void pcibios_set_master(struct pci_dev *dev)
** upper byte is PCI_LATENCY_TIMER.
*/
pci_write_config_word(dev, PCI_CACHE_LINE_SIZE,
- (0x80 << 8) | pci_cache_line_size);
+ (0x80 << 8) | (L1_CACHE_BYTES / sizeof(u32)));
}
--
1.7.1

View File

@ -8,4 +8,6 @@
+ features/all/macvtap-add-GSO-csum-offload-support.patch
+ bugfix/all/mac80211-explicitly-disable-enable-QoS.patch
+ bugfix/all/iwlwifi-manage-QoS-by-mac-stack.patch
+ bugfix/parisc/Revert-parisc-Set-PCI-CLS-early-in-boot.patch
- bugfix/all/megaraid_sas-fix-compat_ioctl-sense_ptr.patch
- bugfix/all/p54-disable-channels-with-incomplete-calibration-dat.patch
+ bugfix/all/stable/2.6.32.14-rc1.patch