Update to 3.8

Refresh perf patches.

svn path=/dists/trunk/linux-tools/; revision=19845
This commit is contained in:
Ben Hutchings 2013-02-24 05:15:41 +00:00
parent c80b6d4d54
commit 3ad6795577
4 changed files with 27 additions and 18 deletions

View File

@ -38,6 +38,7 @@ ifdef KERNEL_ARCH_PERF
-mkdir out
# upstream makefile is broken
cp -al $(top_srcdir)/tools/perf/Documentation doc
cp -al $(top_srcdir)/tools/perf/config config
+$(MAKE_PERF) -C $(top_srcdir)/tools/perf O=$(CURDIR)/out all VERSION=$(VERSION)
+$(MAKE_PERF) -C doc man VERSION=$(VERSION)
endif

4
debian/changelog vendored
View File

@ -1,4 +1,6 @@
linux-tools (3.7.1-1~experimental.2) UNRELEASED; urgency=low
linux-tools (3.8-1~experimental.1) UNRELEASED; urgency=low
* New upstream release
-- Jonathan Nieder <jrnieder@gmail.com> Sat, 29 Dec 2012 22:51:43 -0800

View File

@ -1,6 +1,6 @@
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -1051,16 +1051,16 @@
@@ -1105,20 +1105,20 @@ install: all try-install-man
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'
$(INSTALL) $(OUTPUT)perf-archive -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
@ -19,6 +19,12 @@
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d'
- $(INSTALL) bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf'
+ $(INSTALL) -m 644 bash_completion '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'
- $(INSTALL) tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'
+ $(INSTALL) -m 644 tests/attr.py '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
- $(INSTALL) tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
+ $(INSTALL) -m 644 tests/attr/* '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/tests/attr'
install-python_ext:
$(PYTHON_WORD) util/setup.py --quiet install --root='/$(DESTDIR_SQ)'

View File

@ -1,31 +1,31 @@
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -1047,7 +1047,7 @@
@@ -1101,7 +1101,7 @@ perfexec_instdir_SQ = $(subst ','\'',$(p
install: all
install: all try-install-man
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'
- $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)/perf_$(VERSION)'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'
$(INSTALL) $(OUTPUT)perf-archive -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
@@ -1069,7 +1069,7 @@
$(MAKE) -C Documentation install
@@ -1125,7 +1125,7 @@ install-python_ext:
install-man:
- $(MAKE) -C Documentation install-man
+ $(MAKE) -C Documentation install-man VERSION=$(VERSION)
# 'make install-doc' should call 'make -C Documentation install'
$(INSTALL_DOC_TARGETS):
- $(QUIET_SUBDIR0)Documentation $(QUIET_SUBDIR1) $(@:-doc=)
+ $(QUIET_SUBDIR0)Documentation $(QUIET_SUBDIR1) $(@:-doc=) VERSION=$(VERSION)
### Cleaning rules
install-html:
$(MAKE) -C Documentation install-html
--- a/tools/perf/Documentation/Makefile
+++ b/tools/perf/Documentation/Makefile
@@ -170,13 +170,15 @@
@@ -188,13 +188,15 @@ ifdef missing_tools
$(error "You need to install $(missing_tools) for man pages")
endif
install: install-man
-install-man: man
+install-man: $(addprefix install-man-,$(_DOC_MAN1))
-do-install-man: man
+do-install-man: $(addprefix install-man-,$(_DOC_MAN1))
+
+install-man-perf.1: $(OUTPUT)perf.1
+ $(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)
@ -40,5 +40,5 @@
-# $(INSTALL) -m 644 $(DOC_MAN7) $(DESTDIR)$(man7dir)
+ sed -e 's/"PERF\\-/"PERF_$(VERSION)\\-/' -e 's/fBperf-/fBperf_$(VERSION)-/g' $^ > $(DESTDIR)$(man1dir)/perf_$(VERSION)$*.1
install-info: info
$(INSTALL) -d -m 755 $(DESTDIR)$(infodir)
install-man: check-man-tools man