* Update unusual_devs entry for ipod to fix an eject issue (closes: #406124)

svn path=/dists/sid/linux-2.6/; revision=8142
This commit is contained in:
dann frazier 2007-01-09 00:44:15 +00:00
parent 02817b2f3b
commit 3dc9ab1719
3 changed files with 32 additions and 1 deletions

3
debian/changelog vendored
View File

@ -52,6 +52,7 @@ linux-2.6 (2.6.18-9) UNRELEASED; urgency=low
* Hardcode the output of the scripts under arch/ia64/scripts as executed
in an etch environment so that we can build out of tree modules correctly
(closes: #392592)
* Update unusual_devs entry for ipod to fix an eject issue (closes: #406124)
[ Norbert Tretkowski ]
* libata: handle 0xff status properly. (closes: #391867)
@ -145,7 +146,7 @@ linux-2.6 (2.6.18-9) UNRELEASED; urgency=low
memory accesses in ehci-hub-control() by adding an alignment attribute
to the tbuf array declaration. Thanks to David Miller for the patch.
-- Bastian Blank <waldi@debian.org> Sat, 6 Jan 2007 21:58:08 +0100
-- dann frazier <dannf@debian.org> Mon, 8 Jan 2007 15:40:54 -0700
linux-2.6 (2.6.18-8) unstable; urgency=low

View File

@ -0,0 +1,29 @@
From: Pete Zaitcev <zaitcev@yahoo.com>
Date: Sun, 31 Dec 2006 21:43:26 +0000 (-0800)
Subject: USB storage: fix ipod ejecting issue
X-Git-Tag: v2.6.20-rc4^0~4^2~5
X-Git-Url: http://www.kernel.org/git/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git;a=commitdiff_plain;h=ad1428c96ebdee592aa475afe129530225bef186
USB storage: fix ipod ejecting issue
This patch from Pete fixes the 'ejecting problem' on yet another ipod. Please applyt.
Signed-off-by: Pete Zaitcev <zaitcev@yahoo.com>
Signed-off-by: Phil Dibowitz <phil@ipom.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
diff --git a/drivers/usb/storage/unusual_devs.h b/drivers/usb/storage/unusual_devs.h
index 5239e47..cddef3e 100644
--- a/drivers/usb/storage/unusual_devs.h
+++ b/drivers/usb/storage/unusual_devs.h
@@ -728,7 +728,7 @@ UNUSUAL_DEV( 0x05ac, 0x1204, 0x0000, 0x9999,
"Apple",
"iPod",
US_SC_DEVICE, US_PR_DEVICE, NULL,
- US_FL_FIX_CAPACITY ),
+ US_FL_FIX_CAPACITY | US_FL_NOT_LOCKABLE ),
UNUSUAL_DEV( 0x05ac, 0x1205, 0x0000, 0x9999,
"Apple",

View File

@ -45,3 +45,4 @@
+ bugfix/flush_anon_page-generic.patch
+ bugfix/flush_anon_page-arm.patch
+ bugfix/arm/cyber2010_burst.patch
+ bugfix/ipod-eject-fix.patch