Fix mangled patch "Build with -ffreestanding on m68k ..."

This commit is contained in:
Ben Hutchings 2018-12-31 19:42:29 +00:00
parent 127ba927a9
commit 3f9bd54247
1 changed files with 5 additions and 7 deletions

View File

@ -4,25 +4,23 @@ Subject: Build with -ffreestanding on m68k to avoid
risky optimizations involving libc
Origin: https://marc.info/?l=linux-m68k&m=154537329920545&w=2
diff --git a/arch/m68k/Makefile b/arch/m68k/Makefile
index 997c9f20ea0f..c318afd15e33 100644
--- a/arch/m68k/Makefile
+++ b/arch/m68k/Makefile
@@ -58,1 +58,1 @@ cpuflags-$(CONFIG_M5206e) := $(call cc-option,-mcpu=5206e,-m5200)
@@ -58,7 +58,7 @@ cpuflags-$(CONFIG_M5206e) := $(call cc-o
cpuflags-$(CONFIG_M5206) := $(call cc-option,-mcpu=5206,-m5200)
KBUILD_AFLAGS += $(cpuflags-y)
-KBUILD_CFLAGS += $(cpuflags-y) -pipe
+KBUILD_CFLAGS += $(cpuflags-y)
ifdef CONFIG_MMU
# without -fno-strength-reduce the 53c7xx.c driver fails ;-(
KBUILD_CFLAGS += -fno-strength-reduce -ffixed-a2
@@ -69,2 +69,2 @@ KBUILD_CFLAGS += -D__uClinux__
@@ -69,6 +69,8 @@ KBUILD_CFLAGS += -D__uClinux__
KBUILD_AFLAGS += -D__uClinux__
endif
+KBUILD_CFLAGS += -pipe -ffreestanding
+
KBUILD_LDFLAGS := -m m68kelf
KBUILD_LDFLAGS_MODULE += -T $(srctree)/arch/m68k/kernel/module.lds