add a pci id to r8169

svn path=/dists/trunk/linux-2.6/; revision=7645
This commit is contained in:
maximilian attems 2006-10-24 15:04:18 +00:00
parent e1d6919d80
commit 48e94efbd1
3 changed files with 21 additions and 1 deletions

3
debian/changelog vendored
View File

@ -20,8 +20,9 @@ linux-2.6 (2.6.18-4) UNRELEASED; urgency=low
* Add netpoll leak fix.
* Add sky2 lookup patch for the Marvell 88E803X Yukon-FE chip.
* Add upstream forcedeth swsusp support.
* r8169: PCI ID for Corega Gigabit network card.
-- maximilian attems <maks@sternwelten.at> Tue, 24 Oct 2006 16:59:20 +0200
-- maximilian attems <maks@sternwelten.at> Tue, 24 Oct 2006 17:02:56 +0200
linux-2.6 (2.6.18-3) unstable; urgency=low

View File

@ -0,0 +1,18 @@
Andrew Morton:
r8169: PCI ID for Corega Gigabit network card
diff --git a/drivers/net/r8169.c b/drivers/net/r8169.c
index 4c47c5b..c7309e9 100644
--- a/drivers/net/r8169.c
+++ b/drivers/net/r8169.c
@@ -214,6 +214,7 @@ static struct pci_device_id rtl8169_pci_
{ PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8168), 0, 0, RTL_CFG_2 },
{ PCI_DEVICE(PCI_VENDOR_ID_REALTEK, 0x8169), 0, 0, RTL_CFG_0 },
{ PCI_DEVICE(PCI_VENDOR_ID_DLINK, 0x4300), 0, 0, RTL_CFG_0 },
+ { PCI_DEVICE(0x1259, 0xc107), 0, 0, RTL_CFG_0 },
{ PCI_DEVICE(0x16ec, 0x0116), 0, 0, RTL_CFG_0 },
{ PCI_VENDOR_ID_LINKSYS, 0x1032,
PCI_ANY_ID, 0x0024, 0, 0, RTL_CFG_0 },

View File

@ -4,3 +4,4 @@
+ bugfix/net-netpoll.patch
+ bugfix/net-sky2-lockup.patch
+ features/net-forcedeth-swsusp.patch
+ features/net-r8169-pci_id-corega.patch