perf: Fix include order for bison/flex-generated C files

This doesn't seem to cause a problem with the Gtk UI disabled, but I
can't see any reason why -I/usr/include/slang shouldn't trigger it
just as -I/usr/include/gtk-2.0 does.  And we might enable the Gtk UI
later anyway.


svn path=/dists/trunk/linux-tools/; revision=19338
This commit is contained in:
Ben Hutchings 2012-08-19 23:56:30 +00:00
parent 4b391a0528
commit 4ba53ec510
2 changed files with 37 additions and 0 deletions

View File

@ -0,0 +1,36 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 20 Aug 2012 00:35:01 +0100
Subject: perf: Fix include order for bison/flex-generated C files
When we use a separate output directory, we add util/ to the include
path for the generated C files. However, this is currently added to
the end of the path, behind /usr/include/slang and
/usr/include/gtk-2.0 if use of the respective libraries is enabled.
Thus the '#include "../perf.h"' in util/parse-events.l can actually
include /usr/include/perf.h if it exists.
Move '-Iutil/' ahead of all the other preprocessor options.
Reported-by: Sedat Dilek <sedat.dilek@gmail.com>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
tools/perf/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tools/perf/Makefile b/tools/perf/Makefile
index 0eee64c..434175c 100644
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -756,10 +756,10 @@ $(OUTPUT)perf.o perf.spec \
# over the general rule for .o
$(OUTPUT)util/%-flex.o: $(OUTPUT)util/%-flex.c $(OUTPUT)PERF-CFLAGS
- $(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -Iutil/ -w $<
+ $(QUIET_CC)$(CC) -o $@ -c -Iutil/ $(ALL_CFLAGS) -w $<
$(OUTPUT)util/%-bison.o: $(OUTPUT)util/%-bison.c $(OUTPUT)PERF-CFLAGS
- $(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Iutil/ -w $<
+ $(QUIET_CC)$(CC) -o $@ -c -Iutil/ $(ALL_CFLAGS) -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -w $<
$(OUTPUT)%.o: %.c $(OUTPUT)PERF-CFLAGS
$(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) $<

View File

@ -1,3 +1,4 @@
modpost-symbol-prefix.patch
tools-perf-version.patch
tools-perf-install.patch
perf-Fix-include-order-for-bison-flex-generated-C-fi.patch