selftests: breakpoint: Actually build it

This commit is contained in:
Ben Hutchings 2015-10-30 10:27:40 +00:00
parent a29879587a
commit 4c1226a6c4
2 changed files with 18 additions and 0 deletions

View File

@ -0,0 +1,17 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 30 Oct 2015 10:22:55 +0000
Subject: selftests: breakpoint: Actually build it
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/testing/selftests/breakpoints/Makefile
+++ b/tools/testing/selftests/breakpoints/Makefile
@@ -6,7 +6,7 @@ ifeq ($(ARCH),x86)
TEST_PROGS := breakpoint_test
endif
-all:
+all: $(TEST_PROGS)
include ../lib.mk

View File

@ -87,3 +87,4 @@ bugfix/all/selftests-memfd-stop-unnecessary-rebuilds.patch
bugfix/all/selftests-kprobe-choose-an-always-defined-function-t.patch
bugfix/all/selftests-make-scripts-executable.patch
bugfix/all/selftests-vm-try-harder-to-allocate-huge-pages.patch
bugfix/all/selftests-breakpoints-actually-build-it.patch