Update to 2.6.38-rc6

I never did upload 2.6.38~rc5.1~experimental.1, so reopen the
changelog entry.

Drop some patches merged upstream.

svn path=/dists/trunk/linux-2.6/; revision=16933
This commit is contained in:
Ben Hutchings 2011-02-22 13:19:11 +00:00
parent ac2c07bd7a
commit 50642bd64f
5 changed files with 1 additions and 103 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux-2.6 (2.6.38~rc5-1~experimental.1) experimental; urgency=low
linux-2.6 (2.6.38~rc6-1~experimental.1) UNRELEASED; urgency=low
[ Ben Hutchings ]
* New upstream release candidate

View File

@ -1,30 +0,0 @@
From: Vasiliy Kulikov <segoon@openwall.com>
Date: Fri, 4 Feb 2011 15:23:56 +0300
Subject: [PATCH 7/9] platform: x86: acer-wmi: world-writable sysfs threeg file
commit a6414907541a44db0586b894b0f19b3be6457da3 upstream.
Don't allow everybody to write to hardware registers.
Signed-off-by: Vasiliy Kulikov <segoon@openwall.com>
Signed-off-by: Matthew Garrett <mjg@redhat.com>
---
drivers/platform/x86/acer-wmi.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/platform/x86/acer-wmi.c b/drivers/platform/x86/acer-wmi.c
index c5c4b8c..a7bcad7 100644
--- a/drivers/platform/x86/acer-wmi.c
+++ b/drivers/platform/x86/acer-wmi.c
@@ -1280,7 +1280,7 @@ static ssize_t set_bool_threeg(struct device *dev,
return -EINVAL;
return count;
}
-static DEVICE_ATTR(threeg, S_IWUGO | S_IRUGO | S_IWUSR, show_bool_threeg,
+static DEVICE_ATTR(threeg, S_IRUGO | S_IWUSR, show_bool_threeg,
set_bool_threeg);
static ssize_t show_interface(struct device *dev, struct device_attribute *attr,
--
1.7.2.3

View File

@ -1,39 +0,0 @@
From: Vasiliy Kulikov <segoon@openwall.com>
Date: Fri, 4 Feb 2011 15:23:59 +0300
Subject: [PATCH 8/9] platform: x86: asus_acpi: world-writable procfs files
commit e75b7eb5716256c52a123a467be25fb5e03fa930 upstream.
Don't allow everybody to change ACPI settings. The comment says that it
is done deliberatelly, however, the comment before disp_proc_write()
says that at least one of these setting is experimental.
Signed-off-by: Vasiliy Kulikov <segoon@openwall.com>
Signed-off-by: Matthew Garrett <mjg@redhat.com>
---
drivers/platform/x86/asus_acpi.c | 8 +-------
1 files changed, 1 insertions(+), 7 deletions(-)
diff --git a/drivers/platform/x86/asus_acpi.c b/drivers/platform/x86/asus_acpi.c
index 4633fd8..fe49593 100644
--- a/drivers/platform/x86/asus_acpi.c
+++ b/drivers/platform/x86/asus_acpi.c
@@ -1081,14 +1081,8 @@ static int asus_hotk_add_fs(struct acpi_device *device)
struct proc_dir_entry *proc;
mode_t mode;
- /*
- * If parameter uid or gid is not changed, keep the default setting for
- * our proc entries (-rw-rw-rw-) else, it means we care about security,
- * and then set to -rw-rw----
- */
-
if ((asus_uid == 0) && (asus_gid == 0)) {
- mode = S_IFREG | S_IRUGO | S_IWUGO;
+ mode = S_IFREG | S_IRUGO | S_IWUSR | S_IWGRP;
} else {
mode = S_IFREG | S_IRUSR | S_IRGRP | S_IWUSR | S_IWGRP;
printk(KERN_WARNING " asus_uid and asus_gid parameters are "
--
1.7.2.3

View File

@ -1,30 +0,0 @@
From: Vasiliy Kulikov <segoon@openwall.com>
Date: Fri, 4 Feb 2011 15:24:03 +0300
Subject: [PATCH 9/9] platform: x86: tc1100-wmi: world-writable sysfs wireless and jogdial files
commit 9f6c8b9930b72876dbd934e8563818cfb5e481e2 upstream.
Don't allow everybody to change WMI settings.
Signed-off-by: Vasiliy Kulikov <segoon@openwall.com>
Signed-off-by: Matthew Garrett <mjg@redhat.com>
---
drivers/platform/x86/tc1100-wmi.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/platform/x86/tc1100-wmi.c b/drivers/platform/x86/tc1100-wmi.c
index 1fe0f1f..865ef78 100644
--- a/drivers/platform/x86/tc1100-wmi.c
+++ b/drivers/platform/x86/tc1100-wmi.c
@@ -162,7 +162,7 @@ set_bool_##value(struct device *dev, struct device_attribute *attr, \
return -EINVAL; \
return count; \
} \
-static DEVICE_ATTR(value, S_IWUGO | S_IRUGO | S_IWUSR, \
+static DEVICE_ATTR(value, S_IRUGO | S_IWUSR, \
show_bool_##value, set_bool_##value);
show_set_bool(wireless, TC1100_INSTANCE_WIRELESS);
--
1.7.2.3

View File

@ -41,9 +41,6 @@
+ features/all/r8712u-Switch-driver-to-use-external-firmware.patch
+ features/all/r8712u-Firmware-changes-for-driver.patch
+ bugfix/x86/platform-x86-acer-wmi-world-writable-sysfs-threeg-fi.patch
+ bugfix/x86/platform-x86-asus_acpi-world-writable-procfs-files.patch
+ bugfix/x86/platform-x86-tc1100-wmi-world-writable-sysfs-wireles.patch
+ bugfix/all/rtc-rtc-ds1511-world-writable-sysfs-nvram-file.patch
+ bugfix/all/scsi-aic94xx-world-writable-sysfs-update_bios-file.patch
+ bugfix/all/scsi-iscsi-world-writable-sysfs-priv_sess-file.patch