firmware_class: Fix condition in directory search loop (Closes: #804862)

This commit is contained in:
Ben Hutchings 2015-11-12 14:59:37 +00:00
parent b531af6929
commit 5269f93afe
2 changed files with 3 additions and 4 deletions

1
debian/changelog vendored
View File

@ -10,6 +10,7 @@ linux (4.3-1~exp2) UNRELEASED; urgency=medium
* debian/control: Add ':any' to Build-Depends on python3, to support cross-
bootstrap
* [s390*] Update linux-compiler metapackage to gcc-4.9
* firmware_class: Fix condition in directory search loop (Closes: #804862)
[ Ian Campbell ]
* [armel/orion5x] Enable Device Tree for orion5x. Patch from Roger Shimizu

View File

@ -23,13 +23,11 @@ format to detect missing firmware.
---
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -340,17 +340,20 @@ static int fw_get_filesystem_firmware(st
}
@@ -340,16 +340,19 @@ static int fw_get_filesystem_firmware(st
rc = fw_read_file_contents(file, buf);
fput(file);
- if (rc)
if (rc)
- dev_warn(device, "firmware, attempted to load %s, but failed with error %d\n",
+ if (!rc)
+ dev_dbg(device, "firmware, attempted to load %s, but failed with error %d\n",
path, rc);
else