Readded patch to support prctl syscall, got lost when upgrading to 2.6.16.

svn path=/dists/sid/linux-2.6/; revision=6594
This commit is contained in:
Norbert Tretkowski 2006-05-18 15:44:49 +00:00
parent 3cc3ec11c9
commit 5ae3ad4021
3 changed files with 39 additions and 2 deletions

8
debian/changelog vendored
View File

@ -11,9 +11,13 @@ linux-2.6 (2.6.16-14) UNRELEASED; urgency=low
[ dann frazier ]
* cs4281 - Fix the check of timeout in probe to deal with variable HZ.
(closes: #361197)
(closes: #361197)
-- dann frazier <dannf@debian.org> Mon, 15 May 2006 00:43:43 -0500
[ Norbert Tretkowski ]
* [alpha] Readded patch to support prctl syscall, got lost when upgrading
to 2.6.16.
-- Norbert Tretkowski <nobse@debian.org> Thu, 18 May 2006 10:09:30 -0500
linux-2.6 (2.6.16-13) unstable; urgency=low

32
debian/patches/alpha-prctl.patch vendored Normal file
View File

@ -0,0 +1,32 @@
diff --git a/include/asm-alpha/thread_info.h b/include/asm-alpha/thread_info.h
index 69ffd93..011daaf 100644
--- a/include/asm-alpha/thread_info.h
+++ b/include/asm-alpha/thread_info.h
@@ -92,5 +92,27 @@ register struct thread_info *__current_t
#define _TIF_ALLWORK_MASK (_TIF_WORK_MASK \
| _TIF_SYSCALL_TRACE)
+#define ALPHA_UAC_SHIFT 6
+#define ALPHA_UAC_MASK (1 << TIF_UAC_NOPRINT | 1 << TIF_UAC_NOFIX | \
+ 1 << TIF_UAC_SIGBUS)
+
+#define SET_UNALIGN_CTL(task,value) ({ \
+ (task)->thread_info->flags = (((task)->thread_info->flags & \
+ ~ALPHA_UAC_MASK) \
+ | (((value) << ALPHA_UAC_SHIFT) & (1 << TIF_UAC_NOPRINT)) \
+ | (((value) << ALPHA_UAC_SHIFT + 1) & (1 << TIF_UAC_SIGBUS)) \
+ | (((value) << ALPHA_UAC_SHIFT - 1) & (1 << TIF_UAC_NOFIX)));\
+ 0; })
+
+#define GET_UNALIGN_CTL(task,value) ({ \
+ put_user(((task)->thread_info->flags & (1 << TIF_UAC_NOPRINT)) \
+ >> ALPHA_UAC_SHIFT \
+ | ((task)->thread_info->flags & (1 << TIF_UAC_SIGBUS)) \
+ >> ALPHA_UAC_SHIFT + 1 \
+ | ((task)->thread_info->flags & (1 << TIF_UAC_NOFIX)) \
+ >> ALPHA_UAC_SHIFT - 1, \
+ (int __user *)(value)); \
+ })
+
#endif /* __KERNEL__ */
#endif /* _ALPHA_THREAD_INFO_H */

View File

@ -1,2 +1,3 @@
+ 2.6.16.16
+ cs4281-probe-timeout.patch
+ alpha-prctl.patch