aufs: Update support patches to aufs4.7-20160822 (Closes: #834764)

This commit is contained in:
Ben Hutchings 2016-08-26 00:06:02 +01:00
parent fe9ef5846d
commit 5c0b3b2b37
4 changed files with 144 additions and 80 deletions

1
debian/changelog vendored
View File

@ -29,6 +29,7 @@ linux (4.7.2-1) UNRELEASED; urgency=medium
* [arm*] Enable SECCOMP (Closes: #833183)
* [hppa] Fix automatic selection of cr16 clocksource
* [hppa] Fix order of EREFUSED define in errno.h
* aufs: Update support patches to aufs4.7-20160822 (Closes: #834764)
[ Martin Michlmayr ]
* [armhf] Enable MMC_SDHCI_IPROC and HW_RANDOM_BCM2835 for BCM2835.

View File

@ -1,18 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat May 21 13:01:18 2016 +0900
Subject: aufs4.6 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/57b92ac80a7564243de7e5c69f77e1616af9808a
Date: Sat Jul 30 20:52:25 2016 +0900
Subject: aufs4.7 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/30de7bf869b468b78f91a856323a5f0d2225a186
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.6 base patch
aufs4.7 base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 9c567a4..a62aea4 100644
index 8c20323..d170184 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2128,6 +2128,19 @@ F: include/linux/audit.h
@@ -2213,6 +2213,19 @@ F: include/linux/audit.h
F: include/uapi/linux/audit.h
F: kernel/audit*
@ -33,7 +33,7 @@ index 9c567a4..a62aea4 100644
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
W: http://miguelojeda.es/auxdisplay.htm
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index 80cf8ad..ba9e4a7 100644
index 1fa8cc2..7339e65 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -712,6 +712,24 @@ static inline int is_loop_device(struct file *file)
@ -62,10 +62,10 @@ index 80cf8ad..ba9e4a7 100644
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index d5ecc6e..4de75b2 100644
index d6847d7..c3c0b6d 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1156,7 +1156,7 @@ enum d_walk_ret {
@@ -1202,7 +1202,7 @@ enum d_walk_ret {
*
* The @enter() and @finish() callbacks are called with d_lock held.
*/
@ -96,11 +96,24 @@ index 350a2c8..6f42279 100644
if (error)
return error;
diff --git a/fs/inode.c b/fs/inode.c
index 4ccbc21..aa6d071 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1591,7 +1591,7 @@ EXPORT_SYMBOL(generic_update_time);
* This does the actual work of updating an inodes time or version. Must have
* had called mnt_want_write() before calling this.
*/
-static int update_time(struct inode *inode, struct timespec *time, int flags)
+int update_time(struct inode *inode, struct timespec *time, int flags)
{
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/read_write.c b/fs/read_write.c
index cf377cf..0ebcdc5 100644
index 933b53a..2d13282 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -534,6 +534,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
@@ -515,6 +515,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
}
EXPORT_SYMBOL(__vfs_write);
@ -158,7 +171,7 @@ index dd9bf7e..9326c2a 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/file.h b/include/linux/file.h
index f87d308..9a290b3 100644
index 7444f5f..bdac0be 100644
--- a/include/linux/file.h
+++ b/include/linux/file.h
@@ -19,6 +19,7 @@ struct dentry;
@ -170,10 +183,10 @@ index f87d308..9a290b3 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 70e61b5..351bb05 100644
index dd28814..b689a48 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1277,6 +1277,7 @@ extern void fasync_free(struct fasync_struct *);
@@ -1306,6 +1306,7 @@ extern void fasync_free(struct fasync_struct *);
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -181,7 +194,7 @@ index 70e61b5..351bb05 100644
extern void __f_setown(struct file *filp, struct pid *, enum pid_type, int force);
extern void f_setown(struct file *filp, unsigned long arg, int force);
extern void f_delown(struct file *filp);
@@ -1660,6 +1661,7 @@ struct file_operations {
@@ -1690,6 +1691,7 @@ struct file_operations {
ssize_t (*sendpage) (struct file *, struct page *, int, size_t, loff_t *, int);
unsigned long (*get_unmapped_area)(struct file *, unsigned long, unsigned long, unsigned long, unsigned long);
int (*check_flags)(int);
@ -189,7 +202,7 @@ index 70e61b5..351bb05 100644
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1718,6 +1720,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
@@ -1750,6 +1752,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -202,6 +215,14 @@ index 70e61b5..351bb05 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t __vfs_write(struct file *, const char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
@@ -2105,6 +2113,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec *, int);
+extern int update_time(struct inode *, struct timespec *, int);
/* /sys/fs */
extern struct kobject *fs_kobj;
diff --git a/include/linux/splice.h b/include/linux/splice.h
index da2751d..2e0fca6 100644
--- a/include/linux/splice.h

View File

@ -1,18 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat May 21 13:01:18 2016 +0900
Subject: aufs4.6 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/57b92ac80a7564243de7e5c69f77e1616af9808a
Date: Sat Jul 30 20:52:25 2016 +0900
Subject: aufs4.7 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/30de7bf869b468b78f91a856323a5f0d2225a186
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.6 mmap patch
aufs4.7 mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index 0d163a8..b958f79 100644
index a11eb71..8f10865 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -1934,7 +1934,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
@@ -1939,7 +1939,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -38,7 +38,7 @@ index f8595e8..cb8eda0 100644
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index 5415835..c41eb73 100644
index 4648c7f..061cb85 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -298,7 +298,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
@ -53,7 +53,7 @@ index 5415835..c41eb73 100644
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1617,7 +1620,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
@@ -1624,7 +1627,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -79,10 +79,10 @@ index faacb0c..17b43be 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index 8f468e0..4ab3095 100644
index ece042d..1e24513 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1251,6 +1251,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
@@ -1239,6 +1239,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
}
#endif
@ -112,10 +112,10 @@ index 8f468e0..4ab3095 100644
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
void *buf, int len, int write);
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index c2d75b4..9e324fe 100644
index ca3e517..10bc491 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -269,6 +269,7 @@ struct vm_region {
@@ -274,6 +274,7 @@ struct vm_region {
unsigned long vm_top; /* region allocated to here */
unsigned long vm_pgoff; /* the offset in vm_file corresponding to vm_start */
struct file *vm_file; /* the backing file or NULL */
@ -123,7 +123,7 @@ index c2d75b4..9e324fe 100644
int vm_usage; /* region usage count (access under nommu_region_sem) */
bool vm_icache_flushed : 1; /* true if the icache has been flushed for
@@ -343,6 +344,7 @@ struct vm_area_struct {
@@ -348,6 +349,7 @@ struct vm_area_struct {
unsigned long vm_pgoff; /* Offset (within vm_file) in PAGE_SIZE
units */
struct file * vm_file; /* File we map to (can be NULL). */
@ -132,10 +132,10 @@ index c2d75b4..9e324fe 100644
#ifndef CONFIG_MMU
diff --git a/kernel/fork.c b/kernel/fork.c
index d277e83..683b8a2 100644
index 4a7ec0c..8c8f7ac 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -475,7 +475,7 @@ static int dup_mmap(struct mm_struct *mm, struct mm_struct *oldmm)
@@ -479,7 +479,7 @@ static int dup_mmap(struct mm_struct *mm, struct mm_struct *oldmm)
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -145,7 +145,7 @@ index d277e83..683b8a2 100644
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index deb467e..0f6ae63 100644
index 78c6f7d..aea4230 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -37,7 +37,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
@ -158,10 +158,10 @@ index deb467e..0f6ae63 100644
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index f2479af..31f4b0d 100644
index 20f3b1f..ee827ce 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2211,7 +2211,7 @@ int filemap_page_mkwrite(struct vm_area_struct *vma, struct vm_fault *vmf)
@@ -2208,7 +2208,7 @@ int filemap_page_mkwrite(struct vm_area_struct *vma, struct vm_fault *vmf)
int ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);
@ -171,10 +171,10 @@ index f2479af..31f4b0d 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/memory.c b/mm/memory.c
index 07493e3..dc696bc 100644
index 9e04681..06980d1 100644
--- a/mm/memory.c
+++ b/mm/memory.c
@@ -2098,7 +2098,7 @@ static inline int wp_page_reuse(struct mm_struct *mm,
@@ -2100,7 +2100,7 @@ static inline int wp_page_reuse(struct mm_struct *mm,
}
if (!page_mkwrite)
@ -184,10 +184,10 @@ index 07493e3..dc696bc 100644
return VM_FAULT_WRITE;
diff --git a/mm/mmap.c b/mm/mmap.c
index bd2e1a53..7328b74 100644
index de2c176..b7f391c 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -166,7 +166,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
@@ -162,7 +162,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -196,7 +196,7 @@ index bd2e1a53..7328b74 100644
mpol_put(vma_policy(vma));
kmem_cache_free(vm_area_cachep, vma);
return next;
@@ -785,7 +785,7 @@ again: remove_next = 1 + (end > next->vm_end);
@@ -782,7 +782,7 @@ again: remove_next = 1 + (end > next->vm_end);
if (remove_next) {
if (file) {
uprobe_munmap(next, next->vm_start, next->vm_end);
@ -205,7 +205,7 @@ index bd2e1a53..7328b74 100644
}
if (next->anon_vma)
anon_vma_merge(vma, next);
@@ -1566,8 +1566,8 @@ out:
@@ -1563,8 +1563,8 @@ out:
return addr;
unmap_and_free_vma:
@ -215,7 +215,7 @@ index bd2e1a53..7328b74 100644
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2362,7 +2362,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2358,7 +2358,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -224,7 +224,7 @@ index bd2e1a53..7328b74 100644
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2381,7 +2381,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2377,7 +2377,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -233,7 +233,7 @@ index bd2e1a53..7328b74 100644
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2523,7 +2523,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2528,7 +2528,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -242,7 +242,7 @@ index bd2e1a53..7328b74 100644
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
current->comm, current->pid);
@@ -2590,10 +2590,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2597,10 +2597,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}
@ -271,7 +271,7 @@ index bd2e1a53..7328b74 100644
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -2864,7 +2881,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
@@ -2873,7 +2890,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -281,7 +281,7 @@ index bd2e1a53..7328b74 100644
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index c8bd59a..4cfc2fc 100644
index c2e588802..c39edc4 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -644,7 +644,7 @@ static void __put_nommu_region(struct vm_region *region)

View File

@ -1,16 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat May 21 13:01:18 2016 +0900
Subject: aufs4.6 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/57b92ac80a7564243de7e5c69f77e1616af9808a
Date: Sat Jul 30 20:52:25 2016 +0900
Subject: aufs4.7 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/30de7bf869b468b78f91a856323a5f0d2225a186
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.6 standalone patch
aufs4.7 standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index c3c0b6d..c99d2d2 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1274,6 +1274,7 @@ rename_retry:
@@ -1310,6 +1310,7 @@ rename_retry:
seq = 1;
goto again;
}
@ -18,9 +20,11 @@ aufs4.6 standalone patch
/*
* Search for at least 1 mount point in the dentry's subdirs.
diff --git a/fs/exec.c b/fs/exec.c
index 887c1c9..40e8767 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -104,6 +104,7 @@ bool path_noexec(const struct path *path
@@ -104,6 +104,7 @@ bool path_noexec(const struct path *path)
return (path->mnt->mnt_flags & MNT_NOEXEC) ||
(path->mnt->mnt_sb->s_iflags & SB_I_NOEXEC);
}
@ -28,9 +32,11 @@ aufs4.6 standalone patch
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 6f42279..04fd33c 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -82,6 +82,7 @@ int setfl(int fd, struct file * filp, un
@@ -82,6 +82,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
out:
return error;
}
@ -38,6 +44,8 @@ aufs4.6 standalone patch
static void f_modown(struct file *filp, struct pid *pid, enum pid_type type,
int force)
diff --git a/fs/file_table.c b/fs/file_table.c
index ad17e05..ae9f267 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -147,6 +147,7 @@ over:
@ -72,9 +80,23 @@ aufs4.6 standalone patch
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index aa6d071..f336032 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1600,6 +1600,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
return update_time(inode, time, flags);
}
+EXPORT_SYMBOL_GPL(update_time);
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 419f746..9c0e0af 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -463,6 +463,7 @@ void __mnt_drop_write(struct vfsmount *m
@@ -463,6 +463,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
mnt_dec_writers(real_mount(mnt));
preempt_enable();
}
@ -82,7 +104,7 @@ aufs4.6 standalone patch
/**
* mnt_drop_write - give up write access to a mount
@@ -1811,6 +1812,7 @@ int iterate_mounts(int (*f)(struct vfsmo
@@ -1812,6 +1813,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -90,6 +112,8 @@ aufs4.6 standalone patch
static void cleanup_group_ids(struct mount *mnt, struct mount *end)
{
diff --git a/fs/notify/group.c b/fs/notify/group.c
index 3e2dd85..b17cb4b 100644
--- a/fs/notify/group.c
+++ b/fs/notify/group.c
@@ -22,6 +22,7 @@
@ -100,7 +124,7 @@ aufs4.6 standalone patch
#include <linux/fsnotify_backend.h>
#include "fsnotify.h"
@@ -81,6 +82,7 @@ void fsnotify_get_group(struct fsnotify_
@@ -81,6 +82,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
{
atomic_inc(&group->refcnt);
}
@ -108,7 +132,7 @@ aufs4.6 standalone patch
/*
* Drop a reference to a group. Free it if it's through.
@@ -90,6 +92,7 @@ void fsnotify_put_group(struct fsnotify_
@@ -90,6 +92,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
if (atomic_dec_and_test(&group->refcnt))
fsnotify_final_destroy_group(group);
}
@ -116,7 +140,7 @@ aufs4.6 standalone patch
/*
* Create a new fsnotify_group and hold a reference for the group returned.
@@ -118,6 +121,7 @@ struct fsnotify_group *fsnotify_alloc_gr
@@ -118,6 +121,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
return group;
}
@ -124,9 +148,11 @@ aufs4.6 standalone patch
int fsnotify_fasync(int fd, struct file *file, int on)
{
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index d3fea0b..5fc06ad 100644
--- a/fs/notify/mark.c
+++ b/fs/notify/mark.c
@@ -113,6 +113,7 @@ void fsnotify_put_mark(struct fsnotify_m
@@ -113,6 +113,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
mark->free_mark(mark);
}
}
@ -134,7 +160,7 @@ aufs4.6 standalone patch
/* Calculate mask of events for a list of marks */
u32 fsnotify_recalc_mask(struct hlist_head *head)
@@ -230,6 +231,7 @@ void fsnotify_destroy_mark(struct fsnoti
@@ -230,6 +231,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
mutex_unlock(&group->mark_mutex);
fsnotify_free_mark(mark);
}
@ -150,17 +176,19 @@ aufs4.6 standalone patch
int fsnotify_add_mark(struct fsnotify_mark *mark, struct fsnotify_group *group,
struct inode *inode, struct vfsmount *mnt, int allow_dups)
@@ -521,6 +524,7 @@ void fsnotify_duplicate_mark(struct fsno
new->mask = old->mask;
new->free_mark = old->free_mark;
@@ -533,6 +536,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
atomic_set(&mark->refcnt, 1);
mark->free_mark = free_mark;
}
+EXPORT_SYMBOL_GPL(fsnotify_init_mark);
/*
* Nothing fancy, just initialize lists and locks and counters.
* Destroy all marks in destroy_list, waits for SRCU period to finish before
diff --git a/fs/open.c b/fs/open.c
index 93ae3cd..d25b9bd 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, l
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
inode_unlock(dentry->d_inode);
return ret;
}
@ -176,6 +204,8 @@ aufs4.6 standalone patch
static int do_dentry_open(struct file *f,
struct inode *inode,
diff --git a/fs/read_write.c b/fs/read_write.c
index 2d13282..260c4a4 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -525,6 +525,7 @@ vfs_readf_t vfs_readf(struct file *file)
@ -186,7 +216,7 @@ aufs4.6 standalone patch
vfs_writef_t vfs_writef(struct file *file)
{
@@ -536,6 +537,7 @@ vfs_writef_t vfs_writef(struct file *fil
@@ -536,6 +537,7 @@ vfs_writef_t vfs_writef(struct file *file)
return new_sync_write;
return ERR_PTR(-ENOSYS);
}
@ -194,9 +224,11 @@ aufs4.6 standalone patch
ssize_t __kernel_write(struct file *file, const char *buf, size_t count, loff_t *pos)
{
diff --git a/fs/splice.c b/fs/splice.c
index 9326c2a..0606690 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1124,6 +1124,7 @@ long do_splice_from(struct pipe_inode_in
@@ -1124,6 +1124,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@ -204,7 +236,7 @@ aufs4.6 standalone patch
/*
* Attempt to initiate a splice from a file to a pipe.
@@ -1153,6 +1154,7 @@ long do_splice_to(struct file *in, loff_
@@ -1153,6 +1154,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@ -212,9 +244,11 @@ aufs4.6 standalone patch
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/xattr.c b/fs/xattr.c
index 4beafc4..e118715 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -207,6 +207,7 @@ vfs_getxattr_alloc(struct dentry *dentry
@@ -207,6 +207,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
*xattr_value = value;
return error;
}
@ -222,6 +256,8 @@ aufs4.6 standalone patch
ssize_t
vfs_getxattr(struct dentry *dentry, const char *name, void *value, size_t size)
diff --git a/kernel/task_work.c b/kernel/task_work.c
index 53fa971..bce3211 100644
--- a/kernel/task_work.c
+++ b/kernel/task_work.c
@@ -118,3 +118,4 @@ void task_work_run(void)
@ -229,6 +265,8 @@ aufs4.6 standalone patch
}
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index e7fadde..6423e53 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1058,12 +1058,14 @@ int cap_mmap_addr(unsigned long addr)
@ -246,6 +284,8 @@ aufs4.6 standalone patch
#ifdef CONFIG_SECURITY
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 03c1652..f88c84b 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -7,6 +7,7 @@
@ -256,7 +296,7 @@ aufs4.6 standalone patch
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
@@ -849,6 +850,7 @@ int __devcgroup_inode_permission(struct
@@ -849,6 +850,7 @@ int __devcgroup_inode_permission(struct inode *inode, int mask)
return __devcgroup_check_permission(type, imajor(inode), iminor(inode),
access);
}
@ -264,9 +304,11 @@ aufs4.6 standalone patch
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index 7095693..da7fe2c 100644
--- a/security/security.c
+++ b/security/security.c
@@ -434,6 +434,7 @@ int security_path_rmdir(const struct pat
@@ -434,6 +434,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
return 0;
return call_int_hook(path_rmdir, 0, dir, dentry);
}
@ -274,7 +316,7 @@ aufs4.6 standalone patch
int security_path_unlink(const struct path *dir, struct dentry *dentry)
{
@@ -450,6 +451,7 @@ int security_path_symlink(const struct p
@@ -450,6 +451,7 @@ int security_path_symlink(const struct path *dir, struct dentry *dentry,
return 0;
return call_int_hook(path_symlink, 0, dir, dentry, old_name);
}
@ -282,7 +324,7 @@ aufs4.6 standalone patch
int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
struct dentry *new_dentry)
@@ -458,6 +460,7 @@ int security_path_link(struct dentry *ol
@@ -458,6 +460,7 @@ int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
return 0;
return call_int_hook(path_link, 0, old_dentry, new_dir, new_dentry);
}
@ -290,7 +332,7 @@ aufs4.6 standalone patch
int security_path_rename(const struct path *old_dir, struct dentry *old_dentry,
const struct path *new_dir, struct dentry *new_dentry,
@@ -485,6 +488,7 @@ int security_path_truncate(const struct
@@ -485,6 +488,7 @@ int security_path_truncate(const struct path *path)
return 0;
return call_int_hook(path_truncate, 0, path);
}
@ -298,7 +340,7 @@ aufs4.6 standalone patch
int security_path_chmod(const struct path *path, umode_t mode)
{
@@ -492,6 +496,7 @@ int security_path_chmod(const struct pat
@@ -492,6 +496,7 @@ int security_path_chmod(const struct path *path, umode_t mode)
return 0;
return call_int_hook(path_chmod, 0, path, mode);
}
@ -306,7 +348,7 @@ aufs4.6 standalone patch
int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
{
@@ -499,6 +504,7 @@ int security_path_chown(const struct pat
@@ -499,6 +504,7 @@ int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
return 0;
return call_int_hook(path_chown, 0, path, uid, gid);
}
@ -314,7 +356,7 @@ aufs4.6 standalone patch
int security_path_chroot(const struct path *path)
{
@@ -584,6 +590,7 @@ int security_inode_readlink(struct dentr
@@ -584,6 +590,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return call_int_hook(inode_readlink, 0, dentry);
}
@ -322,7 +364,7 @@ aufs4.6 standalone patch
int security_inode_follow_link(struct dentry *dentry, struct inode *inode,
bool rcu)
@@ -599,6 +606,7 @@ int security_inode_permission(struct ino
@@ -599,6 +606,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return call_int_hook(inode_permission, 0, inode, mask);
}
@ -330,7 +372,7 @@ aufs4.6 standalone patch
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -737,6 +745,7 @@ int security_file_permission(struct file
@@ -737,6 +745,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -338,7 +380,7 @@ aufs4.6 standalone patch
int security_file_alloc(struct file *file)
{
@@ -796,6 +805,7 @@ int security_mmap_file(struct file *file
@@ -796,6 +805,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
return ret;
return ima_file_mmap(file, prot);
}