the DZ driver got converted

svn path=/dists/sid/linux-2.6/; revision=6687
This commit is contained in:
Martin Michlmayr 2006-05-24 17:46:20 +00:00
parent 94bfb29304
commit 5cdef22214
1 changed files with 47 additions and 11 deletions

View File

@ -6,8 +6,6 @@
# linux-mips tree
diff --git a/drivers/char/Kconfig b/drivers/char/Kconfig
index 78d928f..10027dd 100644
--- a/drivers/char/Kconfig
+++ b/drivers/char/Kconfig
@@ -354,6 +354,41 @@ config AU1000_SERIAL_CONSOLE
@ -52,8 +50,6 @@ index 78d928f..10027dd 100644
config QTRONIX_KEYBOARD
bool "Enable Qtronix 990P Keyboard Support"
depends on IT8712
diff --git a/drivers/char/Makefile b/drivers/char/Makefile
index f5b01c6..5a6f7d6 100644
--- a/drivers/char/Makefile
+++ b/drivers/char/Makefile
@@ -51,6 +51,7 @@ obj-$(CONFIG_VIOCONS) += viocons.o
@ -64,11 +60,14 @@ index f5b01c6..5a6f7d6 100644
obj-$(CONFIG_PRINTER) += lp.o
obj-$(CONFIG_TIPAR) += tipar.o
diff --git a/drivers/char/decserial.c b/drivers/char/decserial.c
index aa14409..71f3d9c 100644
--- a/drivers/char/decserial.c
+++ b/drivers/char/decserial.c
@@ -28,7 +28,7 @@ extern int zs_init(void);
@@ -24,17 +24,17 @@
extern int zs_init(void);
#endif
-#ifdef CONFIG_DZ
+#ifdef CONFIG_SERIAL_DZ
extern int dz_init(void);
#endif
@ -77,7 +76,14 @@ index aa14409..71f3d9c 100644
#ifdef CONFIG_ZS
extern void zs_serial_console_init(void);
@@ -43,7 +43,7 @@ extern void dz_serial_console_init(void)
#endif
-#ifdef CONFIG_DZ
+#ifdef CONFIG_SERIAL_DZ
extern void dz_serial_console_init(void);
#endif
@@ -43,12 +43,12 @@ extern void dz_serial_console_init(void)
/* rs_init - starts up the serial interface -
handle normal case of starting up the serial interface */
@ -86,7 +92,22 @@ index aa14409..71f3d9c 100644
int __init rs_init(void)
{
@@ -70,7 +70,7 @@ __initcall(rs_init);
-#if defined(CONFIG_ZS) && defined(CONFIG_DZ)
+#if defined(CONFIG_ZS) && defined(CONFIG_SERIAL_DZ)
if (IOASIC)
return zs_init();
else
@@ -59,7 +59,7 @@ int __init rs_init(void)
return zs_init();
#endif
-#ifdef CONFIG_DZ
+#ifdef CONFIG_SERIAL_DZ
return dz_init();
#endif
@@ -70,14 +70,14 @@ __initcall(rs_init);
#endif
@ -95,5 +116,20 @@ index aa14409..71f3d9c 100644
/* serial_console_init handles the special case of starting
* up the console on the serial port
diff --git a/include/asm-arm/arch-rpc/uncompress.h b/include/asm-arm/arch-rpc/uncompress.h
*/
static int __init decserial_console_init(void)
{
-#if defined(CONFIG_ZS) && defined(CONFIG_DZ)
+#if defined(CONFIG_ZS) && defined(CONFIG_SERIAL_DZ)
if (IOASIC)
zs_serial_console_init();
else
@@ -88,7 +88,7 @@ static int __init decserial_console_init
zs_serial_console_init();
#endif
-#ifdef CONFIG_DZ
+#ifdef CONFIG_SERIAL_DZ
dz_serial_console_init();
#endif