Merge unreleased changes from sid branch and reset changelog date

svn path=/dists/trunk/linux/; revision=20706
This commit is contained in:
Ben Hutchings 2013-10-16 23:33:08 +00:00
commit 64cf010989
6 changed files with 50 additions and 1 deletions

4
debian/changelog vendored
View File

@ -36,6 +36,7 @@ linux (3.11.5-1) unstable; urgency=low
* [arm64] Build a linux-libc-dev package (Closes: #695241)
* crypto: ansi_cprng - Fix off by one error in non-block size request
(CVE-2013-4345)
* mvsas: Recognise device/subsystem 9485/9485 as 88SE9485
* Set ABI to 1
[ Ian Campbell ]
@ -44,8 +45,9 @@ linux (3.11.5-1) unstable; urgency=low
* [armhf] Add multiplatform + LPAE flavour (armmp-lpae).
* [armhf] Remove mx5, omap and vexpress flavours. These are all supported
by the multiplatform flavour.
* [armel/kirkwood] Add orion-ehci, mvmdio and of_mdio modules to udebs.
-- Ben Hutchings <ben@decadent.org.uk> Wed, 16 Oct 2013 14:59:00 +0100
-- Ben Hutchings <ben@decadent.org.uk> Thu, 17 Oct 2013 00:32:15 +0100
linux (3.11-1~exp1) experimental; urgency=low

View File

@ -1,2 +1,3 @@
inet_lro
mv643xx_eth
mvmdio

View File

@ -1 +1,2 @@
#include <nic-shared-modules>
of_mdio

View File

@ -1 +1,2 @@
#include <usb-modules>
ehci-orion

View File

@ -0,0 +1,43 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 16 Sep 2013 03:26:32 +0100
Subject: mvsas: Recognise device/subsystem 9485/9485 as 88SE9485
Forwarded: http://mid.gmane.org/1379298957.23881.10.camel@deadeye.wl.decadent.org.uk
Matt Taggart reported that mvsas didn't bind to the Marvell
SAS controller on a Supermicro AOC-SAS2LP-MV8 board.
lspci reports it as:
01:00.0 RAID bus controller [0104]: Marvell Technology Group Ltd. Device [1b4b:9485] (rev 03)
Subsystem: Marvell Technology Group Ltd. Device [1b4b:9485]
[...]
Add it to the device table as chip_9485.
Reported-by: Matt Taggart <taggart@debian.org>
Tested-by: Matt Taggart <taggart@debian.org>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/scsi/mvsas/mv_init.c | 9 +++++++++
1 file changed, 9 insertions(+)
diff --git a/drivers/scsi/mvsas/mv_init.c b/drivers/scsi/mvsas/mv_init.c
index 7b7381d..83fa5f8 100644
--- a/drivers/scsi/mvsas/mv_init.c
+++ b/drivers/scsi/mvsas/mv_init.c
@@ -729,6 +729,15 @@ static struct pci_device_id mvs_pci_table[] = {
.class_mask = 0,
.driver_data = chip_9485,
},
+ {
+ .vendor = PCI_VENDOR_ID_MARVELL_EXT,
+ .device = 0x9485,
+ .subvendor = PCI_ANY_ID,
+ .subdevice = 0x9485,
+ .class = 0,
+ .class_mask = 0,
+ .driver_data = chip_9485,
+ },
{ PCI_VDEVICE(OCZ, 0x1021), chip_9485}, /* OCZ RevoDrive3 */
{ PCI_VDEVICE(OCZ, 0x1022), chip_9485}, /* OCZ RevoDrive3/zDriveR4 (exact model unknown) */
{ PCI_VDEVICE(OCZ, 0x1040), chip_9485}, /* OCZ RevoDrive3/zDriveR4 (exact model unknown) */

View File

@ -78,3 +78,4 @@ bugfix/m68k/atari-irqs.patch
bugfix/all/compiler-gcc-4-add-quirk-for-asm-goto-miscompilation-bug.patch
bugfix/all/crypto-ansi_cprng-Fix-off-by-one-error-in-non-block-.patch
features/all/mvsas-Recognise-device-subsystem-9485-9485-as-88SE94.patch