Drop an i915 patch that went into 3.4.37

svn path=/dists/sid/linux/; revision=19932
This commit is contained in:
Ben Hutchings 2013-03-21 07:13:31 +00:00
parent e871712cbc
commit 69cf3c5922
3 changed files with 0 additions and 38 deletions

1
debian/changelog vendored
View File

@ -103,7 +103,6 @@ linux (3.2.41-1) UNRELEASED; urgency=low
* drm, agp: Update to 3.4.37:
- drm/radeon/dce6: fix display powergating
- drm: don't add inferred modes for monitors that don't support them
- drm/i915: EBUSY status handling added to i915_gem_fault().
- drm/i915: Increase the RC6p threshold.
* signal: Fix use of missing sa_restorer field (build regression
introduced by fix for CVE-2013-0914)

View File

@ -1,36 +0,0 @@
From: Dmitry Rogozhkin <dmitry.v.rogozhkin@intel.com>
Date: Wed, 3 Oct 2012 17:15:26 +0300
Subject: drm/i915: EBUSY status handling added to i915_gem_fault().
commit e79e0fe380847493266fba557217e2773c61bd1b upstream.
Subsequent threads returning EBUSY from vm_insert_pfn() was not handled
correctly. As a result concurrent access from new threads to
mmapped data caused SIGBUS.
Note that this fixes i-g-t/tests/gem_threaded_tiled_access.
Tested-by: Mika Kuoppala <mika.kuoppala@intel.com>
Signed-off-by: Dmitry Rogozhkin <dmitry.v.rogozhkin@intel.com>
Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
---
drivers/gpu/drm/i915/i915_gem.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/drivers/gpu/drm/i915/i915_gem.c b/drivers/gpu/drm/i915/i915_gem.c
index 76bbb37..5fa3419 100644
--- a/drivers/gpu/drm/i915/i915_gem.c
+++ b/drivers/gpu/drm/i915/i915_gem.c
@@ -1400,6 +1400,11 @@ out:
case 0:
case -ERESTARTSYS:
case -EINTR:
+ case -EBUSY:
+ /*
+ * EBUSY is ok: this just means that another thread
+ * already did the job.
+ */
return VM_FAULT_NOPAGE;
case -ENOMEM:
return VM_FAULT_OOM;

View File

@ -474,7 +474,6 @@ bugfix/x86/drm-i915-add-quirk-to-invert-brightness-on-emachines-g725.patch
bugfix/x86/drm-i915-add-quirk-to-invert-brightness-on-emachines-e725.patch
bugfix/x86/drm-i915-add-quirk-to-invert-brightness-on-packard-bell-ncl20.patch
bugfix/all/drm-nouveau-fix-init-with-agpgart-uninorth.patch
bugfix/x86/drm-i915-EBUSY-status-handling-added-to-i915_gem_fau.patch
bugfix/x86/drm-i915-Close-race-between-processing-unpin-task-an.patch
bugfix/all/drm-radeon-dce32-use-fractional-fb-dividers-for-high.patch
bugfix/all/drm-radeon-fix-amd-afusion-gpu-setup-aka-sumo-v2.patch