[arm64] ptrace: Avoid ABI change in 4.9.6

This commit is contained in:
Ben Hutchings 2017-01-27 04:56:57 +00:00
parent e345ccbabe
commit 6f6fc512f3
3 changed files with 25 additions and 0 deletions

1
debian/changelog vendored
View File

@ -463,6 +463,7 @@ linux (4.9.6-1) UNRELEASED; urgency=medium
layout. (CVE-2017-5576)
* [armhf,arm64] drm/vc4: Return -EINVAL on the overflow checks failing.
(CVE-2017-5577)
* [arm64] ptrace: Avoid ABI change in 4.9.6
[ Roger Shimizu ]
* [armel] Add DT support of Buffalo Linkstation Live v3 (LS-CHL)

View File

@ -0,0 +1,23 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 27 Jan 2017 04:53:54 +0000
Subject: arm64: ptrace: Avoid ABI change in 4.9.6
Forwarded: not-needed
Commit aeb1f39d814b "arm64/ptrace: Avoid uninitialised struct padding
in fpr_set()" added a new member to struct user_fpsimd_state, but it
takes the place of what was padding (for 128-bit alignment). Hide
this from genksyms.
---
--- a/arch/arm64/include/uapi/asm/ptrace.h
+++ b/arch/arm64/include/uapi/asm/ptrace.h
@@ -77,7 +77,9 @@ struct user_fpsimd_state {
__uint128_t vregs[32];
__u32 fpsr;
__u32 fpcr;
+#if !defined(__KERNEL__) || !defined(__GENKSYMS__)
__u32 __reserved[2];
+#endif
};
struct user_hwdebug_state {

View File

@ -117,6 +117,7 @@ bugfix/all/module-disable-matching-missing-version-crc.patch
debian/memcg-avoid-abi-change-in-4.9.5.patch
debian/power-avoid-abi-change-in-4.9.3.patch
debian/cfg80211-avoid-abi-change-in-4.9.3.patch
debian/arm64-ptrace-avoid-abi-change-in-4.9.6.patch
# Tools bug fixes
bugfix/all/usbip-document-tcp-wrappers.patch