Add oabi shim for fstatat64 (Riku Voipio). (closes: #462677)

svn path=/dists/trunk/linux-2.6/; revision=11010
This commit is contained in:
Martin Michlmayr 2008-03-29 15:35:53 +00:00
parent 23e2caa52e
commit 81bdc0bbd9
3 changed files with 75 additions and 0 deletions

1
debian/changelog vendored
View File

@ -51,6 +51,7 @@ linux-2.6 (2.6.25~rc7-1~experimental.1) UNRELEASED; urgency=low
* [mips/r5k-ip32] Enable R8169, requested by Giuseppe Sacco.
* [arm/iop32x] Enable write buffer coalescing (Arnaud Patard).
* [arm/iop32x] Enable MACH_EM7210. (closes: #473136)
* [armel] Add oabi shim for fstatat64 (Riku Voipio). (closes: #462677)
[ Daniel Baumann ]
* Added patch from unionfs upstream to export release_open_intent symbol.

View File

@ -0,0 +1,73 @@
http://www.arm.linux.org.uk/developer/patches/viewpatch.php?id=4878/1
From 15c4a48e1d6c2249dece6b327e0ff2b0f3b720d4 Mon Sep 17 00:00:00 2001
From: Riku Voipio <riku.voipio@movial.fi>
Date: Thu, 27 Mar 2008 21:51:27 +0200
Subject: [PATCH] Add oabi shim for fstatat64
fixes bugs.debian.org/462677
Signed-off-by: Riku Voipio <riku.voipio@movial.fi>
---
arch/arm/kernel/calls.S | 2 +-
arch/arm/kernel/sys_oabi-compat.c | 24 ++++++++++++++++++++++++
2 files changed, 25 insertions(+), 1 deletions(-)
diff --git a/arch/arm/kernel/calls.S b/arch/arm/kernel/calls.S
index 283e14f..7e97b73 100644
--- a/arch/arm/kernel/calls.S
+++ b/arch/arm/kernel/calls.S
@@ -336,7 +336,7 @@
CALL(sys_mknodat)
/* 325 */ CALL(sys_fchownat)
CALL(sys_futimesat)
- CALL(sys_fstatat64)
+ CALL(ABI(sys_fstatat64, sys_oabi_fstatat64))
CALL(sys_unlinkat)
CALL(sys_renameat)
/* 330 */ CALL(sys_linkat)
diff --git a/arch/arm/kernel/sys_oabi-compat.c b/arch/arm/kernel/sys_oabi-compat.c
index e8b9804..96ab5f5 100644
--- a/arch/arm/kernel/sys_oabi-compat.c
+++ b/arch/arm/kernel/sys_oabi-compat.c
@@ -25,6 +25,7 @@
* sys_stat64:
* sys_lstat64:
* sys_fstat64:
+ * sys_fstatat64:
*
* struct stat64 has different sizes and some members are shifted
* Compatibility wrappers are needed for them and provided below.
@@ -169,6 +170,29 @@ asmlinkage long sys_oabi_fstat64(unsigned long fd,
return error;
}
+asmlinkage long sys_oabi_fstatat64(int dfd,
+ char __user *filename,
+ struct oldabi_stat64 __user *statbuf,
+ int flag)
+{
+ struct kstat stat;
+ int error = -EINVAL;
+
+ if ((flag & ~AT_SYMLINK_NOFOLLOW) != 0)
+ goto out;
+
+ if (flag & AT_SYMLINK_NOFOLLOW)
+ error = vfs_lstat_fd(dfd, filename, &stat);
+ else
+ error = vfs_stat_fd(dfd, filename, &stat);
+
+ if (!error)
+ error = cp_oldabi_stat64(&stat, statbuf);
+
+out:
+ return error;
+}
+
struct oabi_flock64 {
short l_type;
short l_whence;
--
1.5.4.3

View File

@ -36,3 +36,4 @@
+ bugfix/all/rtc-x1205-new-style-conversion.patch
+ bugfix/all/rtc-x1205-new-style-conversion-checkpatch-fixes.patch
+ bugfix/all/mtd-prevent-physmap-from-causing-request_module-runaway-loop-modprobe-net-pf-1.patch
+ bugfix/arm/oabi-shim-for-fstatat64.patch