debian/patches/debian/dfsg/firmware-cleanup.patch: Add patch.

debian/patches/debian/dfsg/sound-pci.patch: Fix.
debian/patches/series/orig-0: Readd patches.

svn path=/dists/trunk/linux-2.6/; revision=12034
This commit is contained in:
Bastian Blank 2008-08-10 15:59:06 +00:00
parent 6f72929f2a
commit 827697ef56
3 changed files with 68 additions and 72 deletions

View File

@ -0,0 +1,62 @@
diff --git a/firmware/Makefile b/firmware/Makefile
index 9fe8604..9a852ae 100644
--- a/firmware/Makefile
+++ b/firmware/Makefile
@@ -20,57 +20,8 @@ fw-external-y := $(subst ",,$(CONFIG_EXTRA_FIRMWARE))
# accurate. In the latter case it doesn't matter -- it'll use $(fw-shipped-all).
# But be aware that the config file might not be included at all.
-fw-shipped-$(CONFIG_ATARI_DSP56K) += dsp56k/bootstrap.bin
-fw-shipped-$(CONFIG_ATM_AMBASSADOR) += atmsar11.fw
-fw-shipped-$(CONFIG_COMPUTONE) += intelliport2.bin
-fw-shipped-$(CONFIG_DVB_TTUSB_BUDGET) += ttusb-budget/dspbootcode.bin
-fw-shipped-$(CONFIG_SMCTR) += tr_smctr.bin
-fw-shipped-$(CONFIG_SND_KORG1212) += korg/k1212.dsp
-fw-shipped-$(CONFIG_SND_MAESTRO3) += ess/maestro3_assp_kernel.fw \
- ess/maestro3_assp_minisrc.fw
-fw-shipped-$(CONFIG_SND_SB16_CSP) += sb16/mulaw_main.csp sb16/alaw_main.csp \
- sb16/ima_adpcm_init.csp \
- sb16/ima_adpcm_playback.csp \
- sb16/ima_adpcm_capture.csp
-fw-shipped-$(CONFIG_SND_YMFPCI) += yamaha/ds1_ctrl.fw yamaha/ds1_dsp.fw \
- yamaha/ds1e_ctrl.fw
-fw-shipped-$(CONFIG_USB_DABUSB) += dabusb/firmware.fw dabusb/bitstream.bin
-fw-shipped-$(CONFIG_USB_EMI26) += emi26/loader.fw emi26/firmware.fw \
- emi26/bitstream.fw
-fw-shipped-$(CONFIG_USB_EMI62) += emi62/loader.fw emi62/bitstream.fw \
- emi62/spdif.fw emi62/midi.fw
-fw-shipped-$(CONFIG_USB_KAWETH) += kaweth/new_code.bin kaweth/trigger_code.bin \
- kaweth/new_code_fix.bin \
- kaweth/trigger_code_fix.bin
-ifdef CONFIG_FIRMWARE_IN_KERNEL
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_MPR) += keyspan/mpr.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA18X) += keyspan/usa18x.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA19) += keyspan/usa19.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA19QI) += keyspan/usa19qi.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA19QW) += keyspan/usa19qw.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA19W) += keyspan/usa19w.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA28) += keyspan/usa28.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA28XA) += keyspan/usa28xa.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA28XB) += keyspan/usa28xb.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA28X) += keyspan/usa28x.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA49W) += keyspan/usa49w.fw
-fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_USA49WLC) += keyspan/usa49wlc.fw
-else
-fw-shipped- += keyspan/mpr.fw keyspan/usa18x.fw keyspan/usa19.fw \
- keyspan/usa19qi.fw keyspan/usa19qw.fw keyspan/usa19w.fw \
- keyspan/usa28.fw keyspan/usa28xa.fw keyspan/usa28xb.fw \
- keyspan/usa28x.fw keyspan/usa49w.fw keyspan/usa49wlc.fw
-endif
-fw-shipped-$(CONFIG_USB_SERIAL_TI) += ti_3410.fw ti_5052.fw
-fw-shipped-$(CONFIG_USB_SERIAL_EDGEPORT) += edgeport/boot.fw edgeport/boot2.fw \
- edgeport/down.fw edgeport/down2.fw
-fw-shipped-$(CONFIG_USB_SERIAL_EDGEPORT_TI) += edgeport/down3.bin
-fw-shipped-$(CONFIG_USB_SERIAL_WHITEHEAT) += whiteheat_loader.fw whiteheat.fw \
- # whiteheat_loader_debug.fw
fw-shipped-$(CONFIG_USB_SERIAL_KEYSPAN_PDA) += keyspan_pda/keyspan_pda.fw
fw-shipped-$(CONFIG_USB_SERIAL_XIRCOM) += keyspan_pda/xircom_pgs.fw
-fw-shipped-$(CONFIG_USB_VICAM) += vicam/firmware.fw
-fw-shipped-$(CONFIG_VIDEO_CPIA2) += cpia2/stv0672_vp4.bin
fw-shipped-all := $(fw-shipped-y) $(fw-shipped-m) $(fw-shipped-)

View File

@ -1,77 +1,8 @@
--- a/sound/pci/Kconfig
+++ b/sound/pci/Kconfig
@@ -199,2 +199,3 @@ config SND_CS46XX
@@ -229,4 +229,5 @@ config SND_CS46XX
config SND_CS46XX
tristate "Cirrus Logic (Sound Fusion) CS4280/CS461x/CS462x/CS463x"
+ depends on BROKEN
depends on SND
@@ -587,7 +587,7 @@ config SND_INTEL8X0M
config SND_KORG1212
tristate "Korg 1212 IO"
depends on SND
- select FW_LOADER if !SND_KORG1212_FIRMWARE_IN_KERNEL
+ select FW_LOADER
select SND_PCM
help
Say Y here to include support for Korg 1212IO soundcards.
@@ -595,19 +595,10 @@ config SND_KORG1212
To compile this driver as a module, choose M here: the module
will be called snd-korg1212.
-config SND_KORG1212_FIRMWARE_IN_KERNEL
- bool "In-kernel firmware for Korg1212 driver"
- depends on SND_KORG1212
- default y
- help
- Say Y here to include the static firmware built in the kernel
- for the Korg1212 driver. If you choose N here, you need to
- install the firmware files from the alsa-firmware package.
-
config SND_MAESTRO3
tristate "ESS Allegro/Maestro3"
depends on SND
- select FW_LOADER if !SND_MAESTRO3_FIRMWARE_IN_KERNEL
+ select FW_LOADER
select SND_RAWMIDI
select SND_AC97_CODEC
help
Say Y here to include support for soundcards based on ESS Maestro 3
@@ -616,15 +607,6 @@ config SND_MAESTRO3
To compile this driver as a module, choose M here: the module
will be called snd-maestro3.
-config SND_MAESTRO3_FIRMWARE_IN_KERNEL
- bool "In-kernel firmware for Maestro3 driver"
- depends on SND_MAESTRO3
- default y
- help
- Say Y here to include the static firmware built in the kernel
- for the Maestro3 driver. If you choose N here, you need to
- install the firmware files from the alsa-firmware package.
-
config SND_MIXART
tristate "Digigram miXart"
depends on SND
@@ -766,7 +748,7 @@ config SND_VX222
config SND_YMFPCI
tristate "Yamaha YMF724/740/744/754"
depends on SND
- select FW_LOADER if !SND_YMFPCI_FIRMWARE_IN_KERNEL
+ select FW_LOADER
select SND_OPL3_LIB
select SND_MPU401_UART
select SND_AC97_CODEC
@@ -777,15 +759,6 @@ config SND_YMFPCI
To compile this driver as a module, choose M here: the module
will be called snd-ymfpci.
-config SND_YMFPCI_FIRMWARE_IN_KERNEL
- bool "In-kernel firmware for YMFPCI driver"
- depends on SND_YMFPCI
- default y
- help
- Say Y here to include the static firmware built in the kernel
- for the YMFPCI driver. If you choose N here, you need to
- install the firmware files from the alsa-firmware package.
-
config SND_AC97_POWER_SAVE
bool "AC97 Power-Saving Mode"
depends on SND_AC97_CODEC && EXPERIMENTAL

View File

@ -7,4 +7,7 @@ X debian/dfsg/files-1
+ debian/dfsg/drivers-net-hamradio-yam.patch
+ debian/dfsg/drivers-net-myri.patch
+ debian/dfsg/drivers-net-tg3-remove.patch
+ debian/dfsg/drivers-net-tokenring-3c359-smctr.patch
+ debian/dfsg/drivers-scsi-qlogicpti.patch
+ debian/dfsg/firmware-cleanup.patch
+ debian/dfsg/sound-pci.patch