net: sysfs: Check for null ethtool_ops before getting speed/duplex

svn path=/dists/sid/linux-2.6/; revision=15770
This commit is contained in:
Ben Hutchings 2010-05-26 03:43:45 +00:00
parent 1e3b85e9f1
commit 88ca49b2ab
3 changed files with 53 additions and 0 deletions

1
debian/changelog vendored
View File

@ -20,6 +20,7 @@ linux-2.6 (2.6.32-14) UNRELEASED; urgency=low
(Closes: #583162)
* [amd64] ext4: Fix compat EXT4_IOC_ADD_GROUP (used by online resize)
* Install debug kernel image in /usr/lib/debug/boot (Closes: #582810)
* net: sysfs: Check for null ethtool_ops before getting speed/duplex
[ Bastian Blank ]
* Update Xen patch.

View File

@ -0,0 +1,51 @@
From ac5e3af9996fb911d4fdff910a8ac3cb7fc63a94 Mon Sep 17 00:00:00 2001
From: Eric Dumazet <eric.dumazet@gmail.com>
Date: Mon, 26 Oct 2009 01:23:33 +0000
Subject: [PATCH] net: sysfs: ethtool_ops can be NULL
commit d519e17e2d01a0ee9abe083019532061b4438065
(net: export device speed and duplex via sysfs)
made the wrong assumption that netdev->ethtool_ops was always set.
This makes possible to crash kernel and let rtnl in locked state.
modprobe dummy
ip link set dummy0 up
(udev runs and crash)
Signed-off-by: Eric Dumazet <eric.dumazet@gmail.com>
Acked-by: Andy Gospodarek <andy@greyhouse.net>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
net/core/net-sysfs.c | 8 ++++++--
1 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/net/core/net-sysfs.c b/net/core/net-sysfs.c
index 753c420..89de182 100644
--- a/net/core/net-sysfs.c
+++ b/net/core/net-sysfs.c
@@ -139,7 +139,9 @@ static ssize_t show_speed(struct device *dev,
if (!rtnl_trylock())
return restart_syscall();
- if (netif_running(netdev) && netdev->ethtool_ops->get_settings) {
+ if (netif_running(netdev) &&
+ netdev->ethtool_ops &&
+ netdev->ethtool_ops->get_settings) {
struct ethtool_cmd cmd = { ETHTOOL_GSET };
if (!netdev->ethtool_ops->get_settings(netdev, &cmd))
@@ -158,7 +160,9 @@ static ssize_t show_duplex(struct device *dev,
if (!rtnl_trylock())
return restart_syscall();
- if (netif_running(netdev) && netdev->ethtool_ops->get_settings) {
+ if (netif_running(netdev) &&
+ netdev->ethtool_ops &&
+ netdev->ethtool_ops->get_settings) {
struct ethtool_cmd cmd = { ETHTOOL_GSET };
if (!netdev->ethtool_ops->get_settings(netdev, &cmd))
--
1.7.1

View File

@ -18,3 +18,4 @@
+ bugfix/all/drm-nouveau-Fix-fbcon-corruption-with-font-width-not.patch
+ bugfix/all/ext4-Conditionally-define-compat-ioctl-numbers.patch
+ bugfix/all/ext4-Fix-compat-EXT4_IOC_ADD_GROUP.patch
+ bugfix/all/net-sysfs-ethtool_ops-can-be-NULL.patch