Build inet_lro as a module

svn path=/dists/sid/linux-2.6/; revision=15826
This commit is contained in:
Ben Hutchings 2010-06-05 18:09:30 +00:00
parent d3ff4805f9
commit 8adb6bf457
4 changed files with 37 additions and 1 deletions

1
debian/changelog vendored
View File

@ -8,6 +8,7 @@ linux-2.6 (2.6.32-16) UNRELEASED; urgency=low
* Add stable 2.6.32.15
* Add mantis DVB driver and mb86a16 and tda665x DVB front-ends,
backported by Bjørn Mork (Closes: #577264)
* Build inet_lro as a module
[ Aurelien Jarno ]
* [sh4] fix sh_tmu clocksource following recent nohz changes.

View File

@ -3519,7 +3519,7 @@ CONFIG_INET_IPCOMP=m
CONFIG_INET_XFRM_MODE_TRANSPORT=m
CONFIG_INET_XFRM_MODE_TUNNEL=m
CONFIG_INET_XFRM_MODE_BEET=m
CONFIG_INET_LRO=y
CONFIG_INET_LRO=m
CONFIG_INET_DIAG=m
CONFIG_TCP_CONG_ADVANCED=y
CONFIG_TCP_CONG_BIC=m

View File

@ -0,0 +1,34 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 5 Jun 2010 00:42:57 +0100
Subject: [PATCH] Revert "ipv4: Make INET_LRO a bool instead of tristate."
This reverts commit e81963b180ac502fda0326edf059b1e29cdef1a2.
This code is now deprecated in favour of GRO, and only a few drivers
use it. For Debian kernels (and probably other distribution kernels)
it should be built as a module.
The original change to prevent building it as a module was made in an
attempt to avoid the case where some dependents are set to y and some
to m, and INET_LRO can be set to m rather than y. However, the
Kconfig system will now reliably set INET_LRO=y in this case.
---
net/ipv4/Kconfig | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/net/ipv4/Kconfig b/net/ipv4/Kconfig
index 70491d9..483d427 100644
--- a/net/ipv4/Kconfig
+++ b/net/ipv4/Kconfig
@@ -398,7 +398,7 @@ config INET_XFRM_MODE_BEET
If unsure, say Y.
config INET_LRO
- bool "Large Receive Offload (ipv4/tcp)"
+ tristate "Large Receive Offload (ipv4/tcp)"
default y
---help---
Support for Large Receive Offload (ipv4/tcp).
--
1.7.1

View File

@ -123,3 +123,4 @@
+ features/all/mantis/0119-Mantis-hopper-use-MODULE_DEVICE_TABLE-use-the-macro-.patch
+ features/all/mantis/0120-V4L-DVB-13808-Mantis-Hopper-Build-update-for-Mantis-.patch
+ features/all/mantis/0121-V4L-DVB-mantis-Select-correct-frontends.patch
+ features/all/revert-ipv4-Make-INET_LRO-a-bool-instead-of-tristate.patch