update patches with those that went into Linus' git

svn path=/dists/trunk/linux-2.6/; revision=5995
This commit is contained in:
Martin Michlmayr 2006-02-28 22:55:30 +00:00
parent 36f10251a9
commit 8f7c16957f
2 changed files with 66 additions and 32 deletions

View File

@ -1,23 +1,53 @@
## DP: Only include iomap on systems with PCI
## DP: Patch author: Maciej W. Rozycki <macro@linux-mips.org>
## DP: Upstream status: temporary fix to get iomap to compile on
## DECstation; the real solution is to fix iomap
## DP: Fix build error on processors that don's support copy-on-write
## DP: Patch author: Ralf Baechle <ralf@linux-mips.org>
## DP: Upstream status: in Linus git (went in after rc5)
## DECstation fails to compile without this path:
## tbm> CC arch/mips/lib/iomap.o
# tbm> arch/mips/lib/iomap.c: In function pci_iomap:
# tbm> arch/mips/lib/iomap.c:66: error: _CACHE_CACHABLE_COW undeclared (first use in this function)
#
# Yes, R3000 does not define _CACHE_CACHABLE_COW.
From: Ralf Baechle <ralf@linux-mips.org>
Date: Tue, 28 Feb 2006 17:04:20 +0000 (+0000)
Subject: [MIPS] Fix build error on processors that don's support copy-on-write.
X-Git-Url: http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=778e2ac5970e445f8c6b7d8aa597ac162afe270a
--- a/arch/mips/lib/Makefile 2006-02-27 23:50:16.000000000 +0000
+++ b/arch/mips/lib/Makefile 2006-02-27 23:50:33.000000000 +0000
@@ -5,6 +5,6 @@
lib-y += csum_partial_copy.o memcpy.o promlib.o strlen_user.o strncpy_user.o \
strnlen_user.o uncached.o
[MIPS] Fix build error on processors that don's support copy-on-write.
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
---
--- a/arch/mips/lib/iomap.c
+++ b/arch/mips/lib/iomap.c
@@ -63,7 +63,7 @@ void __iomem *pci_iomap(struct pci_dev *
return ioport_map(start, len);
if (flags & IORESOURCE_MEM) {
if (flags & IORESOURCE_CACHEABLE)
- return ioremap_cacheable_cow(start, len);
+ return ioremap_cachable(start, len);
return ioremap_nocache(start, len);
}
-obj-y += iomap.o
+obj-$(CONFIG_PCI) += iomap.o
--- a/include/asm-mips/io.h
+++ b/include/asm-mips/io.h
@@ -283,6 +283,24 @@ static inline void __iomem * __ioremap_m
__ioremap_mode((offset), (size), _CACHE_UNCACHED)
EXTRA_AFLAGS := $(CFLAGS)
/*
+ * ioremap_cachable - map bus memory into CPU space
+ * @offset: bus address of the memory
+ * @size: size of the resource to map
+ *
+ * ioremap_nocache performs a platform specific sequence of operations to
+ * make bus memory CPU accessible via the readb/readw/readl/writeb/
+ * writew/writel functions and the other mmio helpers. The returned
+ * address is not guaranteed to be usable directly as a virtual
+ * address.
+ *
+ * This version of ioremap ensures that the memory is marked cachable by
+ * the CPU. Also enables full write-combining. Useful for some
+ * memory-like regions on I/O busses.
+ */
+#define ioremap_cachable(offset, size) \
+ __ioremap_mode((offset), (size), PAGE_CACHABLE_DEFAULT)
+
+/*
* These two are MIPS specific ioremap variant. ioremap_cacheable_cow
* requests a cachable mapping, ioremap_uncached_accelerated requests a
* mapping using the uncached accelerated mode which isn't supported on

View File

@ -1,20 +1,24 @@
## DP: Initialize scache flushing functions when CPU has no scache
## DP: Patch author: Martin Michlmayr <tbm@cyrius.com>
## DP: Upstream status: submitted to linux-mips
## DP: Patch author: Ralf Baechle <ralf@linux-mips.org>
## DP: Upstream status: in Linus git (went in after rc5)
# [PATCH] Initialize scache flushing functions when CPU has no scache
From: Ralf Baechle <ralf@linux-mips.org>
Date: Mon, 27 Feb 2006 19:05:55 +0000 (+0000)
Subject: [MIPS] Initialize S-cache function pointers even on S-cache-less CPUs.
X-Git-Url: http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=4debe4f963f9135771a8c5bc66e84396201dcfd8
# When a CPU has no scache, the scache flushing functions currently
# aren't getting initialized and the NULL pointer is eventually called
# as a function. Initialize the scache flushing functions as a noop
# when there's no scache.
# Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
# ---
# c-r4k.c | 16 +++++++++++-----
# 1 file changed, 11 insertions(+), 5 deletions(-)
[MIPS] Initialize S-cache function pointers even on S-cache-less CPUs.
When a CPU has no scache, the scache flushing functions currently
aren't getting initialized and the NULL pointer is eventually called
as a function. Initialize the scache flushing functions as a noop
when there's no scache.
Initial patch by me and most of the debugging done by Martin Michlmayr.
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
---
--- a/arch/mips/mm/c-r4k.c
+++ b/arch/mips/mm/c-r4k.c