Make powernow-k7 work on SMP kernels (Dave Jones).

svn path=/dists/sid/linux-2.6.16/; revision=7012
This commit is contained in:
Martin Michlmayr 2006-07-15 12:29:56 +00:00
parent 8ecfc9d53e
commit 915f8c1fee
3 changed files with 30 additions and 0 deletions

1
debian/changelog vendored
View File

@ -27,6 +27,7 @@ linux-2.6.16 (2.6.16-17) UNRELEASED; urgency=high
* [arm/nslu2] Unset CONFIG_USB_STORAGE_DEBUG. Closes: #377853.
* [mips] SGI ip22 RTC was broken, fixed thanks to Julien Blache.
* [mips] Fix SGI ip22 serial console, thanks to Julien Blache.
* [i386] Make powernow-k7 work on SMP kernels (Dave Jones).
-- Martin Michlmayr <tbm@cyrius.com> Fri, 14 Jul 2006 01:00:57 +0200

28
debian/patches/powernow-k7.patch vendored Normal file
View File

@ -0,0 +1,28 @@
commit 436fe7b8b4a5016ef1fcb32bff77bde84003e15d
Author: Dave Jones <davej@redhat.com>
Date: Mon Jun 5 14:03:50 2006 -0400
[CPUFREQ] Make powernow-k7 work on SMP kernels.
Even though powernow-k7 doesn't work in SMP environments,
it can work on an SMP configured kernel if there's only
one CPU present, however recalibrate_cpu_khz was returning
-EINVAL on such kernels, so we failed to init the cpufreq driver.
Signed-off-by: Dave Jones <davej@redhat.com>
diff --git a/arch/i386/kernel/cpu/cpufreq/powernow-k7.c b/arch/i386/kernel/cpu/cpufreq/powernow-k7.c
index 5d2b601..694d479 100644
--- a/arch/i386/kernel/cpu/cpufreq/powernow-k7.c
+++ b/arch/i386/kernel/cpu/cpufreq/powernow-k7.c
@@ -581,10 +581,7 @@ static int __init powernow_cpu_init (str
rdmsrl (MSR_K7_FID_VID_STATUS, fidvidstatus.val);
- /* recalibrate cpu_khz */
- result = recalibrate_cpu_khz();
- if (result)
- return result;
+ recalibrate_cpu_khz();
fsb = (10 * cpu_khz) / fid_codes[fidvidstatus.bits.CFID];
if (!fsb) {

View File

@ -6,3 +6,4 @@
+ mips-ip22-serial-fix.patch
+ 2.6.16.25
+ relax-proc-fix.patch
+ powernow-k7.patch