Update vserver patch to 2.0.2-rc17.

* debian/changelog: Update.
* debian/patches/series/9-extra: Enable vserver-vs2.0.2-rc17-update.patch.
* debian/patches/vserver-vs2.0.2-rc17-update.patch: Add.

svn path=/dists/sid/linux-2.6/; revision=6456
This commit is contained in:
Bastian Blank 2006-04-19 12:55:42 +00:00
parent 02673caa36
commit 962cb8aa63
3 changed files with 81 additions and 1 deletions

6
debian/changelog vendored
View File

@ -1,11 +1,15 @@
linux-2.6 (2.6.16-9) UNRELEASED; urgency=low
[ maximilian attems ]
* Add stable release 2.6.16.8:
- ip_route_input panic fix (CVE-2006-1525)
* Add stable release 2.6.16.9:
- i386/x86-64: Fix x87 information leak between processes (CVE-2006-1056)
-- maximilian attems <maks@sternwelten.at> Wed, 19 Apr 2006 09:36:45 +0200
[ Bastian Blank ]
* Update vserver patch to 2.0.2-rc17.
-- Bastian Blank <waldi@debian.org> Wed, 19 Apr 2006 14:53:50 +0200
linux-2.6 (2.6.16-8) unstable; urgency=low

1
debian/patches/series/9-extra vendored Normal file
View File

@ -0,0 +1 @@
+ vserver-vs2.0.2-rc17-update.patch *_vserver

View File

@ -0,0 +1,75 @@
diff -urN linux-2.6-2.6.16-vs2.0.2-rc16/fs/namei.c linux-2.6-2.6.16-vs2.0.2-rc17/fs/namei.c
--- linux-2.6-2.6.16-vs2.0.2-rc16/fs/namei.c 2006-04-19 14:47:38.000000000 +0200
+++ linux-2.6-2.6.16-vs2.0.2-rc17/fs/namei.c 2006-04-19 14:48:36.000000000 +0200
@@ -242,7 +242,7 @@
vxwprintk(1, "xid=%d denied access to %p[#%d,%lu] »%s«.",
vx_current_xid(), inode, inode->i_xid, inode->i_ino,
- vxd_path(nd->dentry, nd->mnt));
+ vxd_cond_path(nd));
return -EACCES;
}
diff -urN linux-2.6-2.6.16-vs2.0.2-rc16/include/linux/vserver/debug.h linux-2.6-2.6.16-vs2.0.2-rc17/include/linux/vserver/debug.h
--- linux-2.6-2.6.16-vs2.0.2-rc16/include/linux/vserver/debug.h 2006-04-19 14:47:39.000000000 +0200
+++ linux-2.6-2.6.16-vs2.0.2-rc17/include/linux/vserver/debug.h 2006-04-19 14:48:36.000000000 +0200
@@ -60,11 +60,13 @@
printk(VX_WARNLEVEL f "\n" , ##x); \
} while (0)
-
#define vxd_path(d,m) \
({ static char _buffer[PATH_MAX]; \
d_path((d), (m), _buffer, sizeof(_buffer)); })
+#define vxd_cond_path(n) \
+ ((n) ? vxd_path((n)->dentry, (n)->mnt) : "<null>" )
+
#else /* CONFIG_VSERVER_DEBUG */
#define vx_debug_switch 0
@@ -82,6 +84,7 @@
#define vxwprintk(x...) do { } while (0)
#define vxd_path "<none>"
+#define vxd_cond_path vxd_path
#endif /* CONFIG_VSERVER_DEBUG */
diff -urN linux-2.6-2.6.16-vs2.0.2-rc16/net/ipv4/devinet.c linux-2.6-2.6.16-vs2.0.2-rc17/net/ipv4/devinet.c
--- linux-2.6-2.6.16-vs2.0.2-rc16/net/ipv4/devinet.c 2006-04-19 14:47:39.000000000 +0200
+++ linux-2.6-2.6.16-vs2.0.2-rc17/net/ipv4/devinet.c 2006-04-19 14:48:37.000000000 +0200
@@ -529,33 +529,6 @@
return rc;
}
-/*
- Check that a device is not member of the ipv4root assigned to the process
- Return true if this is the case
-
- If the process is not bound to specific IP, then it returns 0 (all
- interface are fine).
-*/
-static inline int devinet_notiproot (struct in_ifaddr *ifa)
-{
- int ret = 0;
- struct nx_info *nxi;
-
- if ((nxi = current->nx_info)) {
- int i;
- int nbip = nxi->nbipv4;
- __u32 addr = ifa->ifa_local;
- ret = 1;
- for (i=0; i<nbip; i++) {
- if(nxi->ipv4[i] == addr) {
- ret = 0;
- break;
- }
- }
- }
- return ret;
-}
-
int devinet_ioctl(unsigned int cmd, void __user *arg)
{