Update to 4.8.9

This commit is contained in:
Salvatore Bonaccorso 2016-11-26 09:20:32 +01:00
parent b69731a96b
commit a559c41683
2 changed files with 68 additions and 24 deletions

69
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.8.8-1) UNRELEASED; urgency=medium
linux (4.8.9-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.8
@ -40,6 +40,73 @@ linux (4.8.8-1) UNRELEASED; urgency=medium
- scsi: megaraid_sas: Fix data integrity failure for JBOD (passthrough)
devices
- scsi: megaraid_sas: fix macro MEGASAS_IS_LOGICAL to avoid regression
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.9
- ALSA: info: Return error for invalid read/write
- ALSA: info: Limit the proc text input size
- dib0700: fix nec repeat handling
- mm, frontswap: make sure allocated frontswap map is assigned
- shmem: fix pageflags after swapping DMA32 object
- swapfile: fix memory corruption via malformed swapfile
- mm: hwpoison: fix thp split handling in memory_failure()
- mm/hugetlb: fix huge page reservation leak in private mapping error paths
- coredump: fix unfreezable coredumping task
- [s390x] hypfs: Use get_free_page() instead of kmalloc to ensure page
alignment
- PCI: Don't attempt to claim shadow copies of ROM
- [x86] pinctrl: cherryview: Serialize register access in suspend/resume
- [x86] pinctrl: cherryview: Prevent possible interrupt storm on resume
- cpupower: Correct return type of cpu_power_is_cpu_online() in cpufreq-set
- mmc: sdhci: Fix CMD line reset interfering with ongoing data transfer
- mmc: sdhci: Fix unexpected data interrupt handling
- mmc: mmc: Use 500ms as the default generic CMD6 timeout
- [arm64, armhf] usb: dwc3: Fix error handling for core init
- USB: cdc-acm: fix TIOCMIWAIT
- usb: gadget: u_ether: remove interrupt throttling
- drbd: Fix kernel_sendmsg() usage - potential NULL deref
- cdc-acm: fix uninitialized variable
- scsi: qla2xxx: Fix scsi scan hang triggered if adapter fails during init
- scsi: mpt3sas: Fix for block device of raid exists even after deleting
raid disk
- scsi: scsi_dh_alua: fix missing kref_put() in alua_rtpg_work()
- scsi: scsi_dh_alua: Fix a reference counting bug
- [arm64] KVM: vgic: Prevent access to invalid SPIs
- drm/radeon: disable runtime pm in certain cases
- [x86] drm/i915: Respect alternate_ddc_pin for all DDI ports
- [x86] drm/i915/dp: BDW cdclk fix for DP audio
- [x86] drm/i915/dp: Extend BDW DP audio workaround to GEN9 platforms
- [x86] drm/amdgpu: disable runtime pm in certain cases
- xprtrdma: use complete() instead complete_all()
- xprtrdma: Fix DMAR failure in frwr_op_map() after reconnect
- [amd64] iommu/amd: Free domain id when free a domain of struct
dma_ops_domain
- [x86] iommu/vt-d: Fix dead-locks in disable_dmar_iommu() path
- [x86] agp/intel: Flush chipset writes after updating a single PTE
- watchdog: core: Fix devres_alloc() allocation size
- perf top: Fix refreshing hierarchy entries on TUI
- [x86] mei: bus: fix received data size check in NFC fixup
- svcrdma: Skip put_page() when send_reply() fails
- svcrdma: Tail iovec leaves an orphaned DMA mapping
- nvme: Delete created IO queues on reset
- [s390x] dumpstack: restore reliable indicator for call traces
- hwrng: core - Don't use a stack buffer in add_early_randomness()
- i40e: fix call of ndo_dflt_bridge_getlink()
- [arm64] mmc: sdhci-msm: Fix error return code in sdhci_msm_probe()
- [x86] ACPI / APEI: Fix incorrect return value of ghes_proc()
- ACPI/PCI/IRQ: assign ISA IRQ directly during early boot stages
- ACPI/PCI: pci_link: penalize SCI correctly
- ACPI/PCI: pci_link: Include PIRQ_PENALTY_PCI_USING for ISA IRQs
- batman-adv: Modify neigh_list only with rcu-list functions
- [armel, armhf] gpio/mvebu: Use irq_domain_add_linear
- ASoC: Intel: Skylake: Always acquire runtime pm ref on unload
- [armhf] ASoC: sun4i-codec: return error code instead of NULL when
create_card fails
- memcg: prevent memcg caches to be both OFF_SLAB & OBJFREELIST_SLAB
- libceph: fix legacy layout decode with pool 0
- [x86] drm/amdgpu: fix fence slab teardown
- [x86] drm/amdgpu: fix a vm_flush fence leak
- [x86] drm/i915: Fix mismatched INIT power domain disabling during
suspend
- netfilter: fix namespace handling in nf_log_proc_dostring
[ Salvatore Bonaccorso ]
* Bump ABI to 2 and remove ABI reference for 4.8.0-1

View File

@ -22,29 +22,6 @@ Cc: stable <stable@vger.kernel.org> # 4.7+
Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/power/cpupower/utils/cpufreq-set.c
+++ b/tools/power/cpupower/utils/cpufreq-set.c
@@ -296,7 +296,7 @@ int cmd_freq_set(int argc, char **argv)
struct cpufreq_affected_cpus *cpus;
if (!bitmask_isbitset(cpus_chosen, cpu) ||
- cpupower_is_cpu_online(cpu))
+ cpupower_is_cpu_online(cpu) != 1)
continue;
cpus = cpufreq_get_related_cpus(cpu);
@@ -316,10 +316,7 @@ int cmd_freq_set(int argc, char **argv)
cpu <= bitmask_last(cpus_chosen); cpu++) {
if (!bitmask_isbitset(cpus_chosen, cpu) ||
- cpupower_is_cpu_online(cpu))
- continue;
-
- if (cpupower_is_cpu_online(cpu) != 1)
+ cpupower_is_cpu_online(cpu) != 1)
continue;
printf(_("Setting cpu: %d\n"), cpu);
--- a/tools/power/cpupower/bench/system.c
+++ b/tools/power/cpupower/bench/system.c
@@ -58,12 +58,19 @@ long long int get_time()