selftests: Ignore compiler warnings

We can't fix them all yet, and they shouldn't cause a test failure.
Patch memfd makefile to ensure we don't rebuild it and thus emit
warnings during a test run.
This commit is contained in:
Ben Hutchings 2015-10-31 18:45:20 +00:00
parent 499a3df5b5
commit ac28c69026
3 changed files with 38 additions and 0 deletions

View File

@ -0,0 +1,34 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 31 Oct 2015 18:04:28 +0000
Subject: selftests: memfd: Stop unnecessary rebuilds
Instead of explicitly running the compiler, add dependencies and take
advantage of implicit rules to build only as necessary.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/testing/selftests/memfd/Makefile
+++ b/tools/testing/selftests/memfd/Makefile
@@ -4,16 +4,16 @@ CFLAGS += -I../../../../include/uapi/
CFLAGS += -I../../../../include/
CFLAGS += -I../../../../usr/include/
-all:
- $(CC) $(CFLAGS) memfd_test.c -o memfd_test
-
TEST_PROGS := memfd_test
+all: $(TEST_PROGS)
+
include ../lib.mk
-build_fuse:
- $(CC) $(CFLAGS) fuse_mnt.c `pkg-config fuse --cflags --libs` -o fuse_mnt
- $(CC) $(CFLAGS) fuse_test.c -o fuse_test
+build_fuse: fuse_mnt fuse_test
+
+fuse_mnt.o: CFLAGS += $(shell pkg-config fuse --cflags)
+fuse_mnt: LDFLAGS += $(shell pkg-config fuse --libs)
run_fuse: build_fuse
@./run_fuse_test.sh || echo "fuse_test: [FAIL]"

View File

@ -83,3 +83,4 @@ bugfix/all/media-uvcvideo-disable-hardware-timestamps-by-defaul.patch
bugfix/all/ovl-conditionally-use-o_largefile-in-ovl_copy_up.patch
bugfix/all/selftests-add-missing-include-directives.patch
bugfix/all/selftests-memfd-stop-unnecessary-rebuilds.patch

View File

@ -43,6 +43,9 @@ if [ "$step" -ge 0 ]; then
cd $ADTTMP/build
make headers_install
# Ignore compiler warnings
make -C tools/testing/selftests 2>&1 || echo >&2 "Build failed"
# Enable testing CLONE_USERNS by unprivileged users
sysctl kernel.unprivileged_userns_clone=1