audit: fix missing ifdefs in syscall classes hookup for generic targets

svn path=/dists/trunk/linux-2.6/; revision=7659
This commit is contained in:
Martin Michlmayr 2006-10-29 11:59:47 +00:00
parent 872fc68697
commit ae551f2173
3 changed files with 75 additions and 0 deletions

1
debian/changelog vendored
View File

@ -23,6 +23,7 @@ linux-2.6 (2.6.18-4) UNRELEASED; urgency=low
* arm/iop32x: Fix the interrupt of the 2nd Ethernet slot on N2100.
* arm/iop32x: Allow USB and serial to co-exist on N2100.
* arm/ixp4xx: Add clocksource for Intel IXP4xx platforms.
* audit: fix missing ifdefs in syscall classes hookup for generic targets
[ maximilian attems ]
* Add netpoll leak fix.

View File

@ -0,0 +1,73 @@
From: Al Viro <viro@ftp.linux.org.uk>
Date: Fri, 22 Sep 2006 23:10:18 +0000 (+0100)
Subject: [PATCH] fix missing ifdefs in syscall classes hookup for generic targets
X-Git-Tag: v2.6.19-rc1
X-Git-Url: http://kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=a83fbf635992442edf6aa3252e4008d4a08edf12
[PATCH] fix missing ifdefs in syscall classes hookup for generic targets
several targets have no ....at() family and m32r calls its only chown variant
chown32(), with __NR_chown being undefined. creat(2) is also absent in some
targets.
Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
Signed-off-by: Linus Torvalds <torvalds@osdl.org>
---
--- a/include/asm-generic/audit_change_attr.h
+++ b/include/asm-generic/audit_change_attr.h
@@ -1,16 +1,20 @@
__NR_chmod,
__NR_fchmod,
+#ifdef __NR_chown
__NR_chown,
__NR_fchown,
__NR_lchown,
+#endif
__NR_setxattr,
__NR_lsetxattr,
__NR_fsetxattr,
__NR_removexattr,
__NR_lremovexattr,
__NR_fremovexattr,
+#ifdef __NR_fchownat
__NR_fchownat,
__NR_fchmodat,
+#endif
#ifdef __NR_chown32
__NR_chown32,
__NR_fchown32,
--- a/include/asm-generic/audit_dir_write.h
+++ b/include/asm-generic/audit_dir_write.h
@@ -1,14 +1,18 @@
__NR_rename,
__NR_mkdir,
__NR_rmdir,
+#ifdef __NR_creat
__NR_creat,
+#endif
__NR_link,
__NR_unlink,
__NR_symlink,
__NR_mknod,
+#ifdef __NR_mkdirat
__NR_mkdirat,
__NR_mknodat,
__NR_unlinkat,
__NR_renameat,
__NR_linkat,
__NR_symlinkat,
+#endif
--- a/lib/audit.c
+++ b/lib/audit.c
@@ -28,8 +28,10 @@ int audit_classify_syscall(int abi, unsi
switch(syscall) {
case __NR_open:
return 2;
+#ifdef __NR_openat
case __NR_openat:
return 3;
+#endif
#ifdef __NR_socketcall
case __NR_socketcall:
return 4;

View File

@ -12,3 +12,4 @@
+ bugfix/net-r8169-hotplug_loop.patch
+ bugfix/arm/arm-generic-time.patch
+ bugfix/arm/ixp4xx-clocksource.patch
+ bugfix/audit-syscalls.patch