Update to 3.7

svn path=/dists/trunk/linux-tools/; revision=19650
This commit is contained in:
Jonathan Nieder 2012-12-26 08:45:26 +00:00
parent 000732c3ff
commit b06e85a63b
4 changed files with 2 additions and 95 deletions

4
debian/changelog vendored
View File

@ -1,6 +1,6 @@
linux-tools (3.6.8-1~experimental.1) UNRELEASED; urgency=low
linux-tools (3.7.1-1~experimental.1) UNRELEASED; urgency=low
* New upstream stable update
* New upstream release
[ Ben Hutchings ]
* [amd64] linux-tools: Enable optimisations and special-casing of x86_64

View File

@ -1,36 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 20 Aug 2012 00:35:01 +0100
Subject: perf: Fix include order for bison/flex-generated C files
When we use a separate output directory, we add util/ to the include
path for the generated C files. However, this is currently added to
the end of the path, behind /usr/include/slang and
/usr/include/gtk-2.0 if use of the respective libraries is enabled.
Thus the '#include "../perf.h"' in util/parse-events.l can actually
include /usr/include/perf.h if it exists.
Move '-Iutil/' ahead of all the other preprocessor options.
Reported-by: Sedat Dilek <sedat.dilek@gmail.com>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
tools/perf/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tools/perf/Makefile b/tools/perf/Makefile
index 0eee64c..434175c 100644
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -756,10 +756,10 @@ $(OUTPUT)perf.o perf.spec \
# over the general rule for .o
$(OUTPUT)util/%-flex.o: $(OUTPUT)util/%-flex.c $(OUTPUT)PERF-CFLAGS
- $(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -Iutil/ -w $<
+ $(QUIET_CC)$(CC) -o $@ -c -Iutil/ $(ALL_CFLAGS) -w $<
$(OUTPUT)util/%-bison.o: $(OUTPUT)util/%-bison.c $(OUTPUT)PERF-CFLAGS
- $(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -Iutil/ -w $<
+ $(QUIET_CC)$(CC) -o $@ -c -Iutil/ $(ALL_CFLAGS) -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0 -w $<
$(OUTPUT)%.o: %.c $(OUTPUT)PERF-CFLAGS
$(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) $<

View File

@ -1,55 +0,0 @@
From: David Ahern <dsahern@gmail.com>
Date: Mon, 27 Aug 2012 13:05:54 -0600
Subject: perf tools: Fix x86 builds with ARCH specified on the command line
commit 09a2f16a916178489fc4bf439de668d81fda7616 upstream.
e.g., compiling i386 on x86_64 using:
$ make -C tools/perf ARCH=i386
fails with:
CC /tmp/pbuild/util/evsel.o
In file included from util/evsel.c:21:0:
util/perf_regs.h:5:23: fatal error: perf_regs.h: No such file or directory
compilation terminated.
Adding V=1 you see that the include argument for the arch is
'-Iarch/i386/include' is wrong. It is supposed to be -Iarch/x86/include
per the redefinition of ARCH in the Makefile.
According to the make manual,
http://www.gnu.org/software/make/manual/make.html#Override-Directive:
"If a variable has been set with a command argument (see Overriding
Variables), then ordinary assignments in the makefile are ignored. If
you want to set the variable in the makefile even though it was set
with a command argument, you can use an override directive ..."
Make it so.
Signed-off-by: David Ahern <dsahern@gmail.com>
Cc: Frederic Weisbecker <fweisbec@gmail.com>
Cc: Ingo Molnar <mingo@kernel.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Link: http://lkml.kernel.org/r/1346094354-74356-1-git-send-email-dsahern@gmail.com
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
[bwh: Adjust context for 3.6.8]
---
tools/perf/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -56,10 +56,10 @@ AR = $(CROSS_COMPILE)ar
# Additional ARCH settings for x86
ifeq ($(ARCH),i386)
- ARCH := x86
+ override ARCH := x86
endif
ifeq ($(ARCH),x86_64)
- ARCH := x86
+ override ARCH := x86
IS_X86_64 := 0
ifeq (, $(findstring m32,$(EXTRA_CFLAGS)))
IS_X86_64 := $(shell echo __x86_64__ | ${CC} -E -x c - | tail -n 1)

View File

@ -1,5 +1,3 @@
modpost-symbol-prefix.patch
tools-perf-version.patch
tools-perf-install.patch
perf-Fix-include-order-for-bison-flex-generated-C-fi.patch
perf-tools-Fix-x86-builds-with-ARCH-specified-on-the.patch