Merge changes from sid

svn path=/dists/trunk/linux-2.6/; revision=18034
This commit is contained in:
Ben Hutchings 2011-08-29 13:36:42 +00:00
commit b44aa24a5b
6 changed files with 56 additions and 11 deletions

24
debian/changelog vendored
View File

@ -25,9 +25,33 @@ linux-2.6 (3.1.0~rc4-1~experimental.1) UNRELEASED; urgency=low
* gspca: Enable USB_GSPCA_SE401 as module
* de4x5: Disable on all architectures except alpha (Closes: #639538)
* wl128x: Disable on all flavours except armhf/omap
* Make bug script accept failure of lspci (Closes: #639439)
* [alpha] Disable GENERIC_GPIO (Closes: #638696)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 27 Jul 2011 23:58:10 +0200
linux-2.6 (3.0.0-3) unstable; urgency=low
[ Ben Hutchings ]
* Disable SENSORS_SHT15, unlikely to be usable on any supported platform
(Closes: #638696)
* Add stable 3.0.3, including:
- atm: br2864: sent packets truncated in VC routed mode (Closes: #638656)
For the complete list of changes, see:
http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.0.3
* netfilter: TCP and raw fix for ip_route_me_harder (fixes case where
SNAT/masquerading is not done)
* Remove net device features from bug reports (Closes: #638956)
* [mips,mipsel] Ignore nfs ABI changes made in 3.0.0-2; fixes FTBFS
* genirq: Fix wrong bit operation
* befs: Validate length of long symbolic links (CVE-2011-2928)
* CIFS: Fix memory corruption on mount (Closes: #635344)
* x86-32, vdso: On system call restart after SYSENTER, use int $0x80
* drm/ttm: fix ttm_bo_add_ttm(user) failure path
* fuse: check size of FUSE_NOTIFY_INVAL_ENTRY message
-- Ben Hutchings <ben@decadent.org.uk> Sat, 27 Aug 2011 08:04:02 +0100
linux-2.6 (3.0.0-2) unstable; urgency=high
[ Aurelien Jarno ]

View File

@ -473,7 +473,7 @@ CONFIG_SENSORS_MAX6650=m
CONFIG_SENSORS_NTC_THERMISTOR=m
CONFIG_SENSORS_PC87427=m
# CONFIG_PMBUS is not set
CONFIG_SENSORS_SHT15=m
# CONFIG_SENSORS_SHT15 is not set
CONFIG_SENSORS_SHT21=m
CONFIG_SENSORS_SMM665=m
CONFIG_SENSORS_DME1737=m

View File

@ -0,0 +1,29 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 28 Aug 2011 21:45:13 +0100
Subject: [PATCH] alpha, gpio: GENERIC_GPIO default must be n
Since GPIOLIB is optional on alpha, GENERIC_GPIO must not be
selected by default. If GPIOLIB is enabled, it will select
GENERIC_GPIO.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/alpha/Kconfig | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/arch/alpha/Kconfig b/arch/alpha/Kconfig
index 60cde53..8bb9362 100644
--- a/arch/alpha/Kconfig
+++ b/arch/alpha/Kconfig
@@ -51,7 +51,7 @@ config GENERIC_CMOS_UPDATE
def_bool y
config GENERIC_GPIO
- def_bool y
+ bool
config ZONE_DMA
bool
--
1.7.5.4

View File

@ -40,3 +40,4 @@
+ features/all/cgroups-Allow-memory-cgroup-support-to-be-included-b.patch
+ debian/cgroups-Document-the-Debian-memory-resource-controll.patch
+ bugfix/ia64/nouveau-ACPI-support-is-dependent-on-X86.patch
+ bugfix/alpha/alpha-gpio-GENERIC_GPIO-default-must-be-n.patch

View File

@ -27,11 +27,6 @@ add_network() {
netstat -s >&3 || true
echo >&3
fi
echo '*** Device features:' >&3
for dir in /sys/class/net/*; do
echo -n "${dir##*/}: " >&3
cat "$dir"/features >&3
done
echo >&3
}

View File

@ -1,10 +1,6 @@
add_pci() {
echo '** PCI devices:' >&3
if command -v lspci > /dev/null; then
lspci -nnvv >&3
else
echo 'not available' >&3
fi
lspci -nnvv >&3 2>/dev/null || echo 'not available' >&3
echo >&3
}