* debian/arch/defines, debian/arch/hppa/defines: Explicitely use gcc-4.0.

* debian/patches/series/15:
  Enable doc-build-parallel.patch and kernelvariables.patch.
* debian/patches/version.patch, debian/patches/doc-build-parallel.patch,
  debian/patches/kernelvariables.patch:
  Copy from /dists/trunk/linux-2.6/patches.

svn path=/dists/sid/linux-2.6.16/; revision=6833
This commit is contained in:
Bastian Blank 2006-06-19 18:54:51 +00:00
commit b521905d00
6 changed files with 78 additions and 61 deletions

3
debian/arch/defines vendored
View File

@ -16,6 +16,7 @@ arches:
powerpc
s390
sparc
compiler: gcc-4.0
[image]
initramfs-generators: initramfs-tools yaird
@ -26,8 +27,8 @@ initramfs-tools: mkinitramfs-kpkg
yaird: mkinitrd.yaird
[relations]
gcc: gcc (>= 4:4.0)
gcc-3.3: gcc-3.3
gcc-4.0: gcc-4.0
initramfs-fallback: linux-initramfs-tool
initramfs-tools: initramfs-tools (>= 0.53)
yaird: yaird (>= 0.0.12-8)

View File

@ -23,5 +23,5 @@ class: 64-bit PA-RISC
class: multi-processor 64-bit PA-RISC
[relations]
gcc: gcc (>= 4:4.0), binutils-hppa64, gcc-4.0-hppa64
gcc-4.0: gcc-4.0, binutils-hppa64, gcc-4.0-hppa64

13
debian/patches/doc-build-parallel.patch vendored Normal file
View File

@ -0,0 +1,13 @@
diff --git a/Documentation/DocBook/Makefile b/Documentation/DocBook/Makefile
index 5a2882d..71c7077 100644
--- a/Documentation/DocBook/Makefile
+++ b/Documentation/DocBook/Makefile
@@ -146,7 +146,7 @@ quiet_cmd_db2html = HTML $@
cp $(PNG-$(basename $(notdir $@))) $(patsubst %.html,%,$@); fi
quiet_cmd_db2man = MAN $@
- cmd_db2man = if grep -q refentry $<; then xmlto man $(XMLTOFLAGS) -o $(obj)/man $< ; gzip -f $(obj)/man/*.9; fi
+ cmd_db2man = if grep -q refentry $<; then xmlto man $(XMLTOFLAGS) -o $(obj)/man $< ; fi
%.9 : %.xml
@(which xmlto > /dev/null 2>&1) || \
(echo "*** You need to install xmlto ***"; \

13
debian/patches/kernelvariables.patch vendored Normal file
View File

@ -0,0 +1,13 @@
diff --git a/Makefile b/Makefile
index a3a7baa..32d9ea4 100644
--- a/Makefile
+++ b/Makefile
@@ -296,6 +296,8 @@ LDFLAGS_MODULE = -r
CFLAGS_KERNEL =
AFLAGS_KERNEL =
+-include .kernelvariables
+
# Use LINUXINCLUDE when you must reference the include/ directory.
# Needed to be compatible with the O= option

View File

@ -3,3 +3,5 @@
+ arm-rpc-initrd.patch
+ 2.6.16.19
+ 2.6.16.20
+ kernelvariables.patch
+ doc-build-parallel.patch

View File

@ -1,57 +1,5 @@
Attach informations from debian/changelog to compile.h.
---
commit 932fa20ce2db25e496f6aedf6f624e939f3dafa8
tree 87ebceaf3f1a47f9fafef53ad36510fab9cf3d5f
parent 05dbb1e557b392c8cef3675b4ba6497794ad4124
author Bastian Blank <waldi@debian.org> Tue, 13 Sep 2005 22:03:33 +0000
committer Bastian Blank <waldi@debian.org> Tue, 13 Sep 2005 22:03:33 +0000
scripts/mkcompile_h | 13 +++++++++++++
1 files changed, 13 insertions(+), 0 deletions(-)
diff --git a/scripts/mkcompile_h b/scripts/mkcompile_h
--- a/scripts/mkcompile_h
+++ b/scripts/mkcompile_h
@@ -55,6 +55,19 @@ UTS_TRUNCATE="sed -e s/\(.\{1,$UTS_LEN\}
fi
echo \#define LINUX_COMPILER \"`$CC -v 2>&1 | tail -n 1`\"
+
+ if [ -e debian/changelog ]; then
+ DISTRIBUTION=$(lsb_release -is 2>/dev/null)
+ [ "$DISTRIBUTION" ] || DISTRIBUTION=Debian
+ MAINTAINER=$(dpkg-parsechangelog | sed -ne 's,^Maintainer: .[^<]*<\([^>]*\)>,\1,p')
+ VERSION=$(dpkg-parsechangelog | awk '/^Version:/ {print $$2}')
+ echo \#define LINUX_COMPILE_SYSTEM_DISTRIBUTION \"$DISTRIBUTION\"
+ echo \#define LINUX_COMPILE_SYSTEM_MAINTAINER \"$MAINTAINER\"
+ echo \#define LINUX_COMPILE_SYSTEM_VERSION \"$VERSION\"
+ if [ -e debian/official ]; then
+ echo \#define LINUX_COMPILE_SYSTEM_OFFICIAL
+ fi
+ fi
) > .tmpcompile
# Only replace the real compile.h if the new one is different,
!-------------------------------------------------------------flip-
Use debian packaging informations in version string.
---
commit f9117a71c91d355243befb1a24bc557ea5d98e5b
tree 30e508720f0783c2a93b9103edd5e710f81f7f34
parent 932fa20ce2db25e496f6aedf6f624e939f3dafa8
author Bastian Blank <waldi@debian.org> Tue, 13 Sep 2005 22:04:14 +0000
committer Bastian Blank <waldi@debian.org> Tue, 13 Sep 2005 22:04:14 +0000
init/version.c | 14 ++++++++++++--
1 files changed, 12 insertions(+), 2 deletions(-)
diff --git a/init/version.c b/init/version.c
index 3ddc3ce..c2111a7 100644
--- a/init/version.c
+++ b/init/version.c
@@ -29,5 +29,15 @@ struct new_utsname system_utsname = {
@ -72,9 +20,49 @@ diff --git a/init/version.c b/init/version.c
+ "(" LINUX_COMPILE_BY "@" LINUX_COMPILE_HOST ") "
+#endif
+ "(" LINUX_COMPILER ") " UTS_VERSION "\n";
!-------------------------------------------------------------flip-
diff --git a/scripts/mkcompile_h b/scripts/mkcompile_h
index d7b8a38..87035a0 100755
--- a/scripts/mkcompile_h
+++ b/scripts/mkcompile_h
@@ -46,16 +46,34 @@ ( echo /\* This file is auto generated,
echo \#define UTS_VERSION \"`echo $UTS_VERSION | $UTS_TRUNCATE`\"
+ if [ -e debian/changelog ]; then
+ DISTRIBUTION=$(lsb_release -is 2>/dev/null)
+ DISTRIBUTION=${DISTRIBUTION:-Debian}
+ MAINTAINER=$(dpkg-parsechangelog | sed -ne 's,^Maintainer: .[^<]*<\([^>]*\)>,\1,p')
+ VERSION=$(dpkg-parsechangelog | awk '/^Version:/ {print $$2}')
+ echo \#define LINUX_COMPILE_SYSTEM_DISTRIBUTION \"$DISTRIBUTION\"
+ echo \#define LINUX_COMPILE_SYSTEM_MAINTAINER \"$MAINTAINER\"
+ echo \#define LINUX_COMPILE_SYSTEM_VERSION \"$VERSION\"
+ fi
+
echo \#define LINUX_COMPILE_TIME \"`LC_ALL=C LANG=C date +%T`\"
- echo \#define LINUX_COMPILE_BY \"`whoami`\"
- echo \#define LINUX_COMPILE_HOST \"`hostname | $UTS_TRUNCATE`\"
- if [ -x /bin/dnsdomainname ]; then
- echo \#define LINUX_COMPILE_DOMAIN \"`dnsdomainname | $UTS_TRUNCATE`\"
- elif [ -x /bin/domainname ]; then
- echo \#define LINUX_COMPILE_DOMAIN \"`domainname | $UTS_TRUNCATE`\"
- else
+ if [ -e debian/official ]; then
+ echo \#define LINUX_COMPILE_SYSTEM_OFFICIAL
+ echo \#define LINUX_COMPILE_BY \"unknown\"
+ echo \#define LINUX_COMPILE_HOST \"$DISTRIBUTION\"
echo \#define LINUX_COMPILE_DOMAIN
+ else
+ echo \#define LINUX_COMPILE_BY \"`whoami`\"
+ echo \#define LINUX_COMPILE_HOST \"`hostname | $UTS_TRUNCATE`\"
+
+ if [ -x /bin/dnsdomainname ]; then
+ echo \#define LINUX_COMPILE_DOMAIN \"`dnsdomainname | $UTS_TRUNCATE`\"
+ elif [ -x /bin/domainname ]; then
+ echo \#define LINUX_COMPILE_DOMAIN \"`domainname | $UTS_TRUNCATE`\"
+ else
+ echo \#define LINUX_COMPILE_DOMAIN
+ fi
fi
echo \#define LINUX_COMPILER \"`$CC -v 2>&1 | tail -n 1`\"