[mips{,64}r6{,el}] use boston as the target

Add a patch to disable uImage generation to avoid depend on u-boot-tools
Fix typo the EL's flavor names in installer: not same within defines
Malta is never used for r6. (Closes: #898523)
Boston also requires relocation table size >= 0x00121000
This commit is contained in:
YunQiang Su 2018-05-14 16:26:26 +08:00
parent ecefd63ffc
commit b968d18584
12 changed files with 46 additions and 8 deletions

5
debian/changelog vendored
View File

@ -34,6 +34,11 @@ linux (4.17~rc4-1~exp1) UNRELEASED; urgency=medium
[ YunQiang Su ]
* [mips{,64}el/loongson-3] enable NUMA, CPU_PM, CPU_IDLE, RS780_HPET,
REGULATOR. (Closes: #898521).
* [mips{,64}r6{,el}] use boston as the target.
Add a patch to disable uImage generation to avoid depend on u-boot-tools.
Fix typo the EL's flavor names in installer: not same within defines
Malta is never used for r6. (Closes: #898523)
Boston also requires relocation table size >= 0x00121000.
-- Luca Boccassi <bluca@debian.org> Wed, 02 May 2018 12:59:01 +0100

View File

@ -0,0 +1,11 @@
##
## file: arch/mips/Kconfig
##
## choice: System type
CONFIG_MIPS_GENERIC=y
CONFIG_RELOCATION_TABLE_SIZE=0x00121000
## end choice
##
## Common Clock Framework
##
CONFIG_COMMON_CLK_BOSTON=y

View File

@ -15,6 +15,6 @@ hardware-long: MIPS R6 (64 bit, big endian)
[mips64r6_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips64r6

View File

@ -15,6 +15,6 @@ hardware-long: MIPS R6 (64 bit, little endian)
[mips64r6el_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips64r6

View File

@ -16,7 +16,7 @@ hardware-long: MIPS R6 (32 bit, big endian)
[mips32r6_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips32r6
[mips64r6_description]
@ -25,6 +25,6 @@ hardware-long: MIPS R6 (64 bit, big endian)
[mips64r6_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips64r6

View File

@ -16,7 +16,7 @@ hardware-long: MIPS R6 (32 bit, little endian)
[mips32r6el_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips32r6
[mips64r6el_description]
@ -25,6 +25,6 @@ hardware-long: MIPS R6 (64 bit, little endian)
[mips64r6el_image]
configs:
kernelarch-mips/config.malta
kernelarch-mips/config.boston
kernelarch-mips/config.mips64r6

View File

@ -1,2 +1,2 @@
# arch version flavour installedname suffix build-depends
mips64r6el - mips64r6 - y -
mips64r6el - mips64r6el - y -

View File

@ -1,2 +1,2 @@
# arch version flavour installedname suffix build-depends
mipsr6el - mips32r6 - y -
mipsr6el - mips32r6el - y -

View File

@ -0,0 +1,21 @@
From: YunQiang Su <syq@debian.org>
Date: Mon, 14 May 2018 16:16:18 +0800
Subject: Disable uImage generation for mips generic
Forwarded: not-needed
MIPS generic trys to generate uImage when build, which then ask for
u-boot-tools.
Index: b/arch/mips/generic/Platform
===================================================================
--- a/arch/mips/generic/Platform
+++ b/arch/mips/generic/Platform
@@ -11,8 +11,6 @@
platform-$(CONFIG_MIPS_GENERIC) += generic/
cflags-$(CONFIG_MIPS_GENERIC) += -I$(srctree)/arch/mips/include/asm/mach-generic
load-$(CONFIG_MIPS_GENERIC) += 0xffffffff80100000
-all-$(CONFIG_MIPS_GENERIC) := vmlinux.gz.itb
-its-y := vmlinux.its.S
its-$(CONFIG_FIT_IMAGE_FDT_BOSTON) += board-boston.its.S
its-$(CONFIG_FIT_IMAGE_FDT_NI169445) += board-ni169445.its.S

View File

@ -5,6 +5,7 @@ debian/kernelvariables.patch
debian/gitignore.patch
debian/ia64-hardcode-arch-script-output.patch
debian/mips-disable-werror.patch
debian/mips-boston-disable-its.patch
debian/arch-sh4-fix-uimage-build.patch
debian/powerpcspe-omit-uimage.patch
debian/modpost-symbol-prefix.patch