rebase to 2.6.39

svn path=/dists/trunk/linux-2.6/; revision=17457
This commit is contained in:
Maximilian Attems 2011-05-19 08:15:48 +00:00
parent 260410c316
commit b96fbe4210
5 changed files with 2 additions and 164 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux-2.6 (2.6.39~rc7-1~experimental.2) UNRELEASED; urgency=low
linux-2.6 (2.6.39-1) UNRELEASED; urgency=low
[ maximilian attems ]
* [x86] Enable CRYPTO_AES_NI_INTEL for all flavours. (closes: #623631)

View File

@ -1,5 +1,5 @@
[abi]
abiname: trunk
abiname: 1
[base]
arches:

View File

@ -1,28 +0,0 @@
From 4fb027f4664b0571b41bd22a8921940b4b5bfb4b Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 7 May 2011 04:26:50 +0100
Subject: [PATCH] slub: Reenable for m68k
Following commit 4aac0b4815ba592052758f4b468f253d383dc9d6
'm68k/mm: Set all online nodes in N_NORMAL_MEMORY', SLUB should
actually work.
---
init/Kconfig | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/init/Kconfig b/init/Kconfig
index 47dd02f..f108e91 100644
--- a/init/Kconfig
+++ b/init/Kconfig
@@ -1209,7 +1209,7 @@ config SLAB
per cpu and per node queues.
config SLUB
- depends on BROKEN || NUMA || !DISCONTIGMEM
+ depends on BROKEN || NUMA || !DISCONTIGMEM || M68K
bool "SLUB (Unqueued Allocator)"
help
SLUB is a slab allocator that minimizes cache line usage
--
1.7.4.4

View File

@ -1,132 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 6 Mar 2011 21:56:24 +0000
Subject: [PATCH] perf: Define make variables ARCH and SRCARCH consistently with Kbuild
It is confusing to use RAW_ARCH/ARCH instead of ARCH/SRCARCH. The
current definitions also make it difficult to build for i386 on an
x86_64 host.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -174,19 +174,15 @@ uname_R := $(shell sh -c 'uname -r 2>/dev/null || echo not')
uname_M := $(shell uname -m 2>/dev/null || echo not)
-ARCH ?= $(shell echo $(uname_M) | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
+ARCH ?= $(uname_M)
+SRCARCH := $(shell echo $(ARCH) | sed -e s/i.86/x86/ -e s/sun4u/sparc64/ \
-e s/arm.*/arm/ -e s/sa110/arm/ \
-e s/s390x/s390/ -e s/parisc64/parisc/ \
-e s/ppc.*/powerpc/ -e s/mips.*/mips/ \
- -e s/sh[234].*/sh/ )
+ -e s/sh[234].*/sh/ -e s/x86_64/x86/ )
-# Additional ARCH settings for x86
-ifeq ($(ARCH),i386)
- ARCH := x86
-endif
+# Additional ARCH settings for x86_64
ifeq ($(ARCH),x86_64)
- RAW_ARCH := x86_64
- ARCH := x86
ARCH_CFLAGS := -DARCH_X86_64
ARCH_INCLUDE = ../../arch/x86/lib/memcpy_64.S
endif
@@ -305,7 +301,7 @@ endif
# Those must not be GNU-specific; they are shared with perl/ which may
# be built by a different compiler. (Note that this is an artifact now
# but it still might be nice to keep that distinction.)
-BASIC_CFLAGS = -Iutil/include -Iarch/$(ARCH)/include
+BASIC_CFLAGS = -Iutil/include -Iarch/$(SRCARCH)/include
BASIC_LDFLAGS =
# Guard against environment variables
@@ -488,7 +484,7 @@ BUILTIN_OBJS += $(OUTPUT)builtin-bench.o
# Benchmark modules
BUILTIN_OBJS += $(OUTPUT)bench/sched-messaging.o
BUILTIN_OBJS += $(OUTPUT)bench/sched-pipe.o
-ifeq ($(RAW_ARCH),x86_64)
+ifeq ($(ARCH),x86_64)
BUILTIN_OBJS += $(OUTPUT)bench/mem-memcpy-x86-64-asm.o
endif
BUILTIN_OBJS += $(OUTPUT)bench/mem-memcpy.o
@@ -533,7 +529,7 @@ ifneq ($(call try-cc,$(SOURCE_DWARF),$(FLAGS_DWARF)),y)
endif # Dwarf support
endif # NO_DWARF
--include arch/$(ARCH)/Makefile
+-include arch/$(SRCARCH)/Makefile
ifneq ($(OUTPUT),)
BASIC_CFLAGS += -I$(OUTPUT)
@@ -571,7 +567,7 @@ endif
ifndef NO_DWARF
ifeq ($(origin PERF_HAVE_DWARF_REGS), undefined)
- msg := $(warning DWARF register mappings have not been defined for architecture $(ARCH), DWARF support disabled);
+ msg := $(warning DWARF register mappings have not been defined for architecture $(SRCARCH), DWARF support disabled);
else
BASIC_CFLAGS += -DDWARF_SUPPORT
EXTLIBS += -lelf -ldw
diff --git a/tools/perf/arch/arm/Makefile b/tools/perf/arch/arm/Makefile
index 15130b5..571affa 100644
--- a/tools/perf/arch/arm/Makefile
+++ b/tools/perf/arch/arm/Makefile
@@ -1,4 +1,4 @@
ifndef NO_DWARF
PERF_HAVE_DWARF_REGS := 1
-LIB_OBJS += $(OUTPUT)arch/$(ARCH)/util/dwarf-regs.o
+LIB_OBJS += $(OUTPUT)arch/$(SRCARCH)/util/dwarf-regs.o
endif
diff --git a/tools/perf/arch/powerpc/Makefile b/tools/perf/arch/powerpc/Makefile
index 15130b5..571affa 100644
--- a/tools/perf/arch/powerpc/Makefile
+++ b/tools/perf/arch/powerpc/Makefile
@@ -1,4 +1,4 @@
ifndef NO_DWARF
PERF_HAVE_DWARF_REGS := 1
-LIB_OBJS += $(OUTPUT)arch/$(ARCH)/util/dwarf-regs.o
+LIB_OBJS += $(OUTPUT)arch/$(SRCARCH)/util/dwarf-regs.o
endif
diff --git a/tools/perf/arch/s390/Makefile b/tools/perf/arch/s390/Makefile
index 15130b5..571affa 100644
--- a/tools/perf/arch/s390/Makefile
+++ b/tools/perf/arch/s390/Makefile
@@ -1,4 +1,4 @@
ifndef NO_DWARF
PERF_HAVE_DWARF_REGS := 1
-LIB_OBJS += $(OUTPUT)arch/$(ARCH)/util/dwarf-regs.o
+LIB_OBJS += $(OUTPUT)arch/$(SRCARCH)/util/dwarf-regs.o
endif
diff --git a/tools/perf/arch/sh/Makefile b/tools/perf/arch/sh/Makefile
index 15130b5..571affa 100644
--- a/tools/perf/arch/sh/Makefile
+++ b/tools/perf/arch/sh/Makefile
@@ -1,4 +1,4 @@
ifndef NO_DWARF
PERF_HAVE_DWARF_REGS := 1
-LIB_OBJS += $(OUTPUT)arch/$(ARCH)/util/dwarf-regs.o
+LIB_OBJS += $(OUTPUT)arch/$(SRCARCH)/util/dwarf-regs.o
endif
diff --git a/tools/perf/arch/sparc/Makefile b/tools/perf/arch/sparc/Makefile
index 15130b5..571affa 100644
--- a/tools/perf/arch/sparc/Makefile
+++ b/tools/perf/arch/sparc/Makefile
@@ -1,4 +1,4 @@
ifndef NO_DWARF
PERF_HAVE_DWARF_REGS := 1
-LIB_OBJS += $(OUTPUT)arch/$(ARCH)/util/dwarf-regs.o
+LIB_OBJS += $(OUTPUT)arch/$(SRCARCH)/util/dwarf-regs.o
endif
diff --git a/tools/perf/arch/x86/Makefile b/tools/perf/arch/x86/Makefile
index 15130b5..571affa 100644
--- a/tools/perf/arch/x86/Makefile
+++ b/tools/perf/arch/x86/Makefile
@@ -1,4 +1,4 @@
ifndef NO_DWARF
PERF_HAVE_DWARF_REGS := 1
-LIB_OBJS += $(OUTPUT)arch/$(ARCH)/util/dwarf-regs.o
+LIB_OBJS += $(OUTPUT)arch/$(SRCARCH)/util/dwarf-regs.o
endif

View File

@ -39,9 +39,7 @@
+ bugfix/all/dm-Deal-with-merge_bvec_fn-in-component-devices-bett.patch
+ features/all/Kbuild-kconfig-Verbose-version-of-listnewconfig.patch
#+ features/all/perf-Define-make-variables-ARCH-and-SRCARCH-consiste.patch
+ debian/sched-autogroup-disabled.patch
+ bugfix/all/rt2800-disable-powersaving-as-default.patch
+ bugfix/powerpc/powerpc-kexec-Fix-build-failure-on-32-bit-SMP.patch
+ bugfix/all/xhci-hcd-Include-linux-slab.h-in-xhci-pci.c.patch
+ debian/slub-Reenable-for-m68k.patch