Fix for AUDITSYSCALL build probolem on powerpc64

svn path=/dists/trunk/linux-2.6/; revision=4704
This commit is contained in:
Simon Horman 2005-10-31 13:21:08 +00:00
parent e60619df55
commit c58bc8913f
4 changed files with 36 additions and 2 deletions

View File

@ -78,4 +78,3 @@ CONFIG_MPIC=y
CONFIG_NEED_MULTIPLE_NODES=y
CONFIG_XICS=y
CONFIG_NODES_SPAN_OTHER_NODES=y
CONFIG_AUDITSYSCALL=y

4
debian/changelog vendored
View File

@ -9,6 +9,8 @@ linux-2.6 (2.6.14-2) UNRELEASED; urgency=low
so headers get included. (closes: #336521)
N.B: I only filled in arches where other's hadn't done so alread.
Please fix if its wrong.
* Allow powerpc64 to compile with AUDIT enabled but
AUDITSYSCALL disabled. powerpc64-audit_sysctl-build.patch
[ dann frazier ]
* Update hppa.diff to 2.6.14-pa0
@ -27,7 +29,7 @@ linux-2.6 (2.6.14-2) UNRELEASED; urgency=low
* Deactivate AUDITSYSCALL globally, it slows down the kernel and is not
needed for selinux at all.
-- Simon Horman <horms@debian.org> Mon, 31 Oct 2005 16:57:56 +0900
-- Simon Horman <horms@debian.org> Mon, 31 Oct 2005 22:15:43 +0900
linux-2.6 (2.6.14-1) unstable; urgency=low

View File

@ -0,0 +1,32 @@
Date: Mon, 31 Oct 2005 22:10:59 +0900
From: Horms <horms@verge.net.au>
To: linuxppc-dev@ozlabs.org
Cc: Andrew Morton <akpm@osdl.org>, david@woodhou.se
Subject: audit_sysctl_exit can only be used with CONF_AUDIT_SYSCTL
This section of code calls .audit_syscal_exit,
but is inside CONFIG_AUDIT, so it will fail to build
if CONFIG_AUDITSYSCALL is not defined.
After discussion with David Woodhouse, change the
ifdef to CONFIG_AUDITSYSCALL
Signed-off-by: Horms <horms@verge.net.au>
--
Backported to 2.6.14 by Horms
diff --git a/arch/ppc64/kernel/entry.S b/arch/ppc64/kernel/entry.S
index 984a106..2d22bf0 100644
--- a/arch/ppc64/kernel/entry.S
+++ b/arch/ppc64/kernel/entry.S
@@ -279,7 +279,7 @@ _GLOBAL(ppc32_rt_sigsuspend)
bne syscall_exit
/* If sigsuspend() returns zero, we are going into a signal handler. We
may need to call audit_syscall_exit() to mark the exit from sigsuspend() */
-#ifdef CONFIG_AUDIT
+#ifdef CONFIG_AUDITSYSCALL
ld r3,PACACURRENT(r13)
ld r4,AUDITCONTEXT(r3)
cmpdi 0,r4,0

View File

@ -1 +1,2 @@
+ alpha-compile-fix.patch
+ powerpc64-audit_sysctl-build.patch