debian/patches/debian/powerpc-mkvmlinuz-support-powerpc.patch: Fix.

svn path=/dists/trunk/linux-2.6/; revision=8857
This commit is contained in:
Bastian Blank 2007-06-03 11:53:20 +00:00
parent fe61c72a45
commit c72007bbc9
1 changed files with 28 additions and 41 deletions

View File

@ -1,53 +1,40 @@
#
# Mkvmlinuz support patch, called by debian's kernel-package to generate
# the files needed by mkvmlinuz to generate the bootable images from vmlinux.
# Author: Sven Luther <luther@debian.org>
# Based on work from: Jens Schmalzing <jensen@debian.org>
# Original comment from Jens :
# This shell script is intended to be put into the debian subdirectory
# of a Linux kernel tree, where make-kpkg will find and execute it
# while building a kernel-image package. The purpose of this script
# is to add glue (object code, libraries, utilities and so on) from
# the kernel tree to the kernel-image package. Later, the mkvmlinuz
# utility, which is available as a separate Debian package, can use
# this glue to create a bootable compressed kernel from the
# uncompressed kernel in the kernel-image package and optionally a
# ramdisk. This is especially important on PowerPC subarchitectures
# that don't have a boot loader, but also comes handy for rescue
# systems and the like.
# Upstream status: This patch stays a debian specific patch for now,
# but it is not in a form where it could go upstream.
#
--- linux-2.6.19/arch/powerpc/Makefile.orig 2006-11-24 17:43:15.000000000 +0100
+++ linux-2.6.19/arch/powerpc/Makefile 2006-11-24 17:44:32.000000000 +0100
@@ -148,7 +148,7 @@
diff --git a/arch/powerpc/Makefile b/arch/powerpc/Makefile
index 6238b58..edfbed7 100644
--- a/arch/powerpc/Makefile
+++ b/arch/powerpc/Makefile
@@ -151,13 +151,19 @@ CPPFLAGS_vmlinux.lds := -Upowerpc
CPPFLAGS_vmlinux.lds := -Upowerpc
-BOOT_TARGETS = zImage zImage.initrd zImage.dts zImage.dts_initrd uImage
+BOOT_TARGETS = zImage zImage.initrd zImage.dts zImage.dts_initrd uImage mkvmlinuz_support_install
BOOT_TARGETS = zImage zImage.initrd zImage.dts zImage.dts_initrd uImage
+BOOT_TARGETS_SPECIAL = mkvmlinuz_support_install
+
PHONY += $(BOOT_TARGETS)
+PHONY += $(BOOT_TARGETS_SPECIAL)
--- linux-2.6.20-rc3/arch/powerpc/boot/Makefile.orig 2007-01-04 16:22:53.000000000 +0100
+++ linux-2.6.20-rc3/arch/powerpc/boot/Makefile 2007-01-04 16:23:40.000000000 +0100
@@ -186,3 +186,19 @@
boot := arch/$(ARCH)/boot
$(BOOT_TARGETS): vmlinux
$(Q)$(MAKE) ARCH=ppc64 $(build)=$(boot) $(patsubst %,$(boot)/%,$@)
+$(BOOT_TARGETS_SPECIAL):
+ $(Q)$(MAKE) $(build)=$(boot) $@
+
define archhelp
@echo '* zImage - Compressed kernel image (arch/$(ARCH)/boot/zImage.*)'
@echo ' install - Install kernel using'
diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
index 8378898..dd4c803 100644
--- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile
@@ -235,3 +235,11 @@ clean-kernel := vmlinux.strip vmlinux.bin
clean-kernel += $(addsuffix .gz,$(clean-kernel))
# If not absolute clean-files are relative to $(obj).
clean-files += $(addprefix $(objtree)/, $(clean-kernel))
+
+#-----------------------------------------------------------
+# install mkvmlinuz support files
+#-----------------------------------------------------------
+quiet_cmd_mkvmlinuz = INSTALL mkvmlinuz support files
+ cmd_mkvmlinuz = cp -f $? $(INSTALL_MKVMLINUZ)
+ cmd_mkvmlinuz = cp -f $(filter-out FORCE,$^) $(INSTALL_MKVMLINUZ)
+
+mkvmlinuz-files := $(extra-y) $(wrapper) $(addprefix $(obj)/,$(hostprogs-y))
+
+$(obj)/mkvmlinuz_support_install: $(mkvmlinuz-files)
+ mkdir -p $(INSTALL_MKVMLINUZ)
+mkvmlinuz_support_install: $(wrapperbits)
+ @mkdir -p $(INSTALL_MKVMLINUZ)
+ $(call cmd,mkvmlinuz)
+
+targets += mkvmlinuz_support_install
+
+