METH: fix MAC address setup.

svn path=/dists/trunk/linux-2.6/; revision=11946
This commit is contained in:
Martin Michlmayr 2008-08-03 06:10:54 +00:00
parent d59bcb59aa
commit d3459c6c85
3 changed files with 34 additions and 0 deletions

4
debian/changelog vendored
View File

@ -1,7 +1,11 @@
linux-2.6 (2.6.27~rc1-1~experimental.1) UNRELEASED; urgency=low
[ maximilian attems ]
* New upstream release
[ Martin Michlmayr ]
* METH: fix MAC address setup.
-- maximilian attems <maks@debian.org> Wed, 30 Jul 2008 18:23:09 +0200
linux-2.6 (2.6.26-1~experimental.1) UNRELEASED; urgency=low

View File

@ -0,0 +1,29 @@
From: Thomas Bogendoerfer <tsbogend@alpha.franken.de>
To: netdev@vger.kernel.org, linux-mips@linux-mips.org
cc: ralf@linux-mips.org, jgarzik@pobox.com
Subject: [PATCH] METH: fix MAC address setup
Date: Thu, 31 Jul 2008 01:14:24 +0200 (CEST)
Setup of the mac filter lost the upper 16bit of the mac address. This
bug got unconvered by a patch, which fixed the promiscous handling.
Signed-off-by: Thomas Bogendoerfer <tsbogend@alpha.franken.de>
---
drivers/net/meth.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/net/meth.c b/drivers/net/meth.c
index 4cb364e..0a97c26 100644
--- a/drivers/net/meth.c
+++ b/drivers/net/meth.c
@@ -100,7 +100,7 @@ static inline void load_eaddr(struct net_device *dev)
DPRINTK("Loading MAC Address: %s\n", print_mac(mac, dev->dev_addr));
macaddr = 0;
for (i = 0; i < 6; i++)
- macaddr |= dev->dev_addr[i] << ((5 - i) * 8);
+ macaddr |= (u64)dev->dev_addr[i] << ((5 - i) * 8);
mace->eth.mac_addr = macaddr;
}

View File

@ -20,6 +20,7 @@
#+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/mips/disable-advansys.patch
+ bugfix/mips/gbefb_fix_cmap_fifo_timeout.patch
+ bugfix/mips/meth-fix_mac.patch
+ bugfix/arm/disable-dvb_b2c2_flexcop.patch
+ bugfix/arm/disable-dvb_budget.patch
+ bugfix/arm/disable-netxen_nic.patch