debian/changelog: Set version to 2.6.27~rc4-1~experimental.1.

* debian/patches/debian/dfsg/drivers-net-bnx2-request_firmware-1.patch,
  debian/patches/bugfix/arm/ixp4xx_eth-build-fix.patch,
  debian/patches/bugfix/arm/tsx09-fix-mac.patch,
  debian/patches/bugfix/arm/tsx09-init-uart1.patch: Fix.
* debian/patches/features/arm/5281d0.patch,
  debian/patches/features/arm/ts409-export-leds.patch,
  debian/patches/features/arm/ts409-export-reset.patch,
  debian/patches/features/arm/tsx09-fix-key-codes.patch: Remove as merged.
* debian/patches/series/1~experimental.1: Remove patches.

svn path=/dists/trunk/linux-2.6/; revision=12117
This commit is contained in:
Bastian Blank 2008-08-21 09:42:59 +00:00
parent 4b79519404
commit d6704f553f
10 changed files with 5 additions and 273 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux-2.6 (2.6.27~rc3-1~experimental.1) UNRELEASED; urgency=low
linux-2.6 (2.6.27~rc4-1~experimental.1) UNRELEASED; urgency=low
* New upstream release

View File

@ -1,60 +0,0 @@
The arm ixp4xx_eth driver doesn't compile in 2.6.27-rc1:
CC [M] drivers/net/arm/ixp4xx_eth.o
drivers/net/arm/ixp4xx_eth.c: In function 'eth_poll':
drivers/net/arm/ixp4xx_eth.c:554: warning: passing argument 1 of 'dma_mapping_error' makes pointer from integer without a cast
drivers/net/arm/ixp4xx_eth.c:554: error: too few arguments to function 'dma_mapping_error'
drivers/net/arm/ixp4xx_eth.c: In function 'eth_xmit':
drivers/net/arm/ixp4xx_eth.c:701: warning: passing argument 1 of 'dma_mapping_error' makes pointer from integer without a cast
drivers/net/arm/ixp4xx_eth.c:701: error: too few arguments to function 'dma_mapping_error'
drivers/net/arm/ixp4xx_eth.c: In function 'init_queues':
drivers/net/arm/ixp4xx_eth.c:886: warning: passing argument 1 of 'dma_mapping_error' makes pointer from integer without a cast
drivers/net/arm/ixp4xx_eth.c:886: error: too few arguments to function 'dma_mapping_error'
make[3]: *** [drivers/net/arm/ixp4xx_eth.o] Error 1
make[2]: *** [drivers/net/arm] Error 2
make[1]: *** [drivers/net] Error 2
make: *** [drivers] Error 2
dma_mapping_error() changed in 2.6.27-rc1 to also take a device parameter,
but nobody bothered updating ixp4xx_eth.c. Fixed by passing the appropriate
device value in the dma_mapping_error() calls.
Tested on an ixp425 box.
Signed-off-by: Mikael Pettersson <mikpe@it.uu.se>
---
diff -rupN linux-2.6.27-rc1/drivers/net/arm/ixp4xx_eth.c linux-2.6.27-rc1.arm-ixp4xx_eth-dma_mapping_error-fix/drivers/net/arm/ixp4xx_eth.c
--- linux-2.6.27-rc1/drivers/net/arm/ixp4xx_eth.c 2008-07-29 10:40:10.000000000 +0200
+++ linux-2.6.27-rc1.arm-ixp4xx_eth-dma_mapping_error-fix/drivers/net/arm/ixp4xx_eth.c 2008-08-01 19:38:35.000000000 +0200
@@ -551,7 +551,7 @@ static int eth_poll(struct napi_struct *
if ((skb = netdev_alloc_skb(dev, RX_BUFF_SIZE))) {
phys = dma_map_single(&dev->dev, skb->data,
RX_BUFF_SIZE, DMA_FROM_DEVICE);
- if (dma_mapping_error(phys)) {
+ if (dma_mapping_error(&dev->dev, phys)) {
dev_kfree_skb(skb);
skb = NULL;
}
@@ -698,7 +698,7 @@ static int eth_xmit(struct sk_buff *skb,
#endif
phys = dma_map_single(&dev->dev, mem, bytes, DMA_TO_DEVICE);
- if (dma_mapping_error(phys)) {
+ if (dma_mapping_error(&dev->dev, phys)) {
#ifdef __ARMEB__
dev_kfree_skb(skb);
#else
@@ -883,7 +883,7 @@ static int init_queues(struct port *port
desc->buf_len = MAX_MRU;
desc->data = dma_map_single(&port->netdev->dev, data,
RX_BUFF_SIZE, DMA_FROM_DEVICE);
- if (dma_mapping_error(desc->data)) {
+ if (dma_mapping_error(&port->netdev->dev, desc->data)) {
free_buffer(buff);
return -EIO;
}
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html

View File

@ -22,8 +22,8 @@ index 809132d..2bce0a5 100644
orion5x_ehci1_init();
qnap_tsx09_find_mac_addr(QNAP_TS209_NOR_BOOT_BASE +
@@ -297,10 +301,6 @@ static void __init qnap_ts209_init(void)
orion5x_sata_init(&qnap_ts209_sata_data);
orion5x_uart0_init();
orion5x_xor_init();
- orion5x_setup_dev_boot_win(QNAP_TS209_NOR_BOOT_BASE,
- QNAP_TS209_NOR_BOOT_SIZE);

View File

@ -12,9 +12,9 @@ Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
orion5x_sata_init(&qnap_ts209_sata_data);
orion5x_uart0_init();
+ orion5x_uart1_init();
orion5x_xor_init();
platform_device_register(&qnap_ts209_button_device);
--- a/arch/arm/mach-orion5x/ts409-setup.c 2008-08-13 07:39:55.000000000 +0000
+++ b/arch/arm/mach-orion5x/ts409-setup.c 2008-08-13 07:40:10.000000000 +0000
@@ -293,6 +293,7 @@

View File

@ -20,8 +20,8 @@ index 5ebde67..5401dab 100644
@@ -59,12 +59,20 @@
#define PFX DRV_MODULE_NAME ": "
#define DRV_MODULE_VERSION "1.7.9"
#define DRV_MODULE_RELDATE "July 18, 2008"
#define DRV_MODULE_VERSION "1.8.0"
#define DRV_MODULE_RELDATE "Aug 14, 2008"
+#define FW_FILE_06 "bnx2-06-4.4.1.fw"
+#define FW_FILE_09 "bnx2-09-4.4.26.fw"

View File

@ -1,47 +0,0 @@
From: Lennert Buytenhek <buytenh@marvell.com>
Date: Mon, 5 May 2008 18:19:55 +0000 (-0400)
Subject: Orion: support for D0 stepping
Orion: support for D0 stepping
Signed-off-by: Lennert Buytenhek <buytenh@marvell.com>
Signed-off-by: Nicolas Pitre <nico@marvell.com>
diff --git a/arch/arm/mach-orion5x/common.c b/arch/arm/mach-orion5x/common.c
index faf4e32..a7a6d79 100644
--- a/arch/arm/mach-orion5x/common.c
+++ b/arch/arm/mach-orion5x/common.c
@@ -382,6 +382,8 @@ static void __init orion5x_id(u32 *dev, u32 *rev, char **dev_name)
*dev_name = "MV88F5281-D2";
} else if (*rev == MV88F5281_REV_D1) {
*dev_name = "MV88F5281-D1";
+ } else if (*rev == MV88F5281_REV_D0) {
+ *dev_name = "MV88F5281-D0";
} else {
*dev_name = "MV88F5281-Rev-Unsupported";
}
@@ -416,6 +418,12 @@ void __init orion5x_init(void)
* Setup Orion address map
*/
orion5x_setup_cpu_mbus_bridge();
+
+ /* apply workaround */
+ if (dev == MV88F5281_DEV_ID && rev == MV88F5281_REV_D0) {
+ printk(KERN_INFO "Orion: Applying 5281 D0 WFI workaround.\n");
+ disable_hlt();
+ }
}
/*
diff --git a/include/asm-arm/arch-orion5x/orion5x.h b/include/asm-arm/arch-orion5x/orion5x.h
index 10257f5..15f07a4 100644
--- a/arch/arm/arch-orion5x/include/mach/orion5x.h
+++ b/arch/arm/mach-orion5x/include/mach/orion5x.h
@@ -73,6 +73,7 @@
#define MV88F5182_REV_A2 2
/* Orion-2 (88F5281) */
#define MV88F5281_DEV_ID 0x5281
+#define MV88F5281_REV_D0 4
#define MV88F5281_REV_D1 5
#define MV88F5281_REV_D2 6

View File

@ -1,89 +0,0 @@
Subject: [PATCH] Orion: export red SATA lights on TS-409, fix SATA presence/activity
To: Nicolas Pitre <nico@cam.org>, Lennert Buytenhek <buytenh@wantstofly.org>
Cc: linux-arm-kernel@lists.arm.linux.org.uk
Export the four red SATA LEDs on the QNAP TS-409 that are connected
through gpio. Since the boot loader apparently sets the SATA LEDs 2-4
to red and the SATA LED can only be red or green (but not both),
exporting the red SATA LEDs (which automatically turns them off upon
boot) makes the green SATA presence/activity indication visible.
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
Acked-by: Sylver Bruneau <sylver.bruneau@googlemail.com>
--- a/arch/arm/mach-orion5x/ts409-setup.c
+++ b/arch/arm/mach-orion5x/ts409-setup.c
@@ -3,6 +3,9 @@
*
* Maintainer: Sylver Bruneau <sylver.bruneau@gmail.com>
*
+ * Copyright (C) 2008 Sylver Bruneau <sylver.bruneau@gmail.com>
+ * Copyright (C) 2008 Martin Michlmayr <tbm@cyrius.com>
+ *
* This program is free software; you can redistribute it and/or
* modify it under the terms of the GNU General Public License
* as published by the Free Software Foundation; either version
@@ -16,6 +19,7 @@
#include <linux/irq.h>
#include <linux/mtd/physmap.h>
#include <linux/mv643xx_eth.h>
+#include <linux/leds.h>
#include <linux/gpio_keys.h>
#include <linux/input.h>
#include <linux/i2c.h>
@@ -162,6 +166,46 @@ static struct i2c_board_info __initdata qnap_ts409_i2c_rtc = {
I2C_BOARD_INFO("s35390a", 0x30),
};
+/*****************************************************************************
+ * LEDs attached to GPIO
+ ****************************************************************************/
+
+static struct gpio_led ts409_led_pins[] = {
+ {
+ .name = "ts409:red:sata1",
+ .gpio = 4,
+ .active_low = 1,
+ },
+ {
+ .name = "ts409:red:sata2",
+ .gpio = 5,
+ .active_low = 1,
+ },
+ {
+ .name = "ts409:red:sata3",
+ .gpio = 6,
+ .active_low = 1,
+ },
+ {
+ .name = "ts409:red:sata4",
+ .gpio = 7,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_led_platform_data ts409_led_data = {
+ .leds = ts409_led_pins,
+ .num_leds = ARRAY_SIZE(ts409_led_pins),
+};
+
+static struct platform_device ts409_leds = {
+ .name = "leds-gpio",
+ .id = -1,
+ .dev = {
+ .platform_data = &ts409_led_data,
+ }
+};
+
/****************************************************************************
* GPIO Attached Keys
* Power button is attached to the PIC microcontroller
@@ -255,6 +299,7 @@ static void __init qnap_ts409_init(void)
if (qnap_ts409_i2c_rtc.irq == 0)
pr_warning("qnap_ts409_init: failed to get RTC IRQ\n");
i2c_register_board_info(0, &qnap_ts409_i2c_rtc, 1);
+ platform_device_register(&ts409_leds);
/* register tsx09 specific power-off method */
pm_power_off = qnap_tsx09_power_off;

View File

@ -1,28 +0,0 @@
To: Nicolas Pitre <nico@cam.org>, Lennert Buytenhek <buytenh@wantstofly.org>
Cc: linux-arm-kernel@lists.arm.linux.org.uk, Sylver Bruneau <sylver.bruneau@googlemail.com>
Subject: [PATCH] Orion: Export the reset button of the QNAP TS-409
The reset button on the QNAP TS-409 is available through gpio.
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
--- a/arch/arm/mach-orion5x/ts409-setup.c 2008-07-31 04:19:08.000000000 +0000
+++ b/arch/arm/mach-orion5x/ts409-setup.c 2008-07-31 04:21:10.000000000 +0000
@@ -211,10 +211,17 @@
* Power button is attached to the PIC microcontroller
****************************************************************************/
+#define QNAP_TS409_GPIO_KEY_RESET 14
#define QNAP_TS409_GPIO_KEY_MEDIA 15
static struct gpio_keys_button qnap_ts409_buttons[] = {
{
+ .code = KEY_RESTART,
+ .gpio = QNAP_TS409_GPIO_KEY_RESET,
+ .desc = "Reset Button",
+ .active_low = 1,
+ },
+ {
.code = KEY_COPY,
.gpio = QNAP_TS409_GPIO_KEY_MEDIA,
.desc = "USB Copy Button",

View File

@ -1,39 +0,0 @@
Subject: [PATCH] Orion: use better key codes for the TS-209/TS-409 buttons
To: Nicolas Pitre <nico@cam.org>, Lennert Buytenhek <buytenh@wantstofly.org>
Cc: linux-arm-kernel@lists.arm.linux.org.uk
Use key codes for the buttons on the QNAP TS-209/TS-409 that make
more sense than the current values.
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
Acked-by: Byron Bradley <byron.bbradley@gmail.com>
--- a/arch/arm/mach-orion5x/ts209-setup.c
+++ b/arch/arm/mach-orion5x/ts209-setup.c
@@ -207,12 +207,12 @@ static struct i2c_board_info __initdata qnap_ts209_i2c_rtc = {
static struct gpio_keys_button qnap_ts209_buttons[] = {
{
- .code = KEY_RESTART,
+ .code = KEY_COPY,
.gpio = QNAP_TS209_GPIO_KEY_MEDIA,
.desc = "USB Copy Button",
.active_low = 1,
}, {
- .code = KEY_POWER,
+ .code = KEY_RESTART,
.gpio = QNAP_TS209_GPIO_KEY_RESET,
.desc = "Reset Button",
.active_low = 1,
--- a/arch/arm/mach-orion5x/ts409-setup.c
+++ b/arch/arm/mach-orion5x/ts409-setup.c
@@ -171,7 +171,7 @@ static struct i2c_board_info __initdata qnap_ts409_i2c_rtc = {
static struct gpio_keys_button qnap_ts409_buttons[] = {
{
- .code = KEY_RESTART,
+ .code = KEY_COPY,
.gpio = QNAP_TS409_GPIO_KEY_MEDIA,
.desc = "USB Copy Button",
.active_low = 1,

View File

@ -27,13 +27,8 @@
+ bugfix/arm/disable-ath5k.patch
+ bugfix/arm/disable-r6040.patch
+ bugfix/arm/kurobox_fix_nr_controllers.patch
+ bugfix/arm/ixp4xx_eth-build-fix.patch
+ bugfix/arm/tsx09-fix-mac.patch
+ bugfix/arm/tsx09-init-uart1.patch
+ features/arm/5281d0.patch
+ features/arm/ts409-export-leds.patch
+ features/arm/tsx09-fix-key-codes.patch
+ features/arm/ts409-export-reset.patch
+ features/all/at76.patch
+ bugfix/fix-hifn_795X-divdi3.patch
+ bugfix/all/mtd-prevent-physmap-from-causing-request_module-runaway-loop-modprobe-net-pf-1.patch